Btrfs/ZFS support

  • It looks like it built the module. Did you reboot? What is the output of:


    lsmod | grep zfs


    Yes, I reboot, twice (reboot & halt).


    It's nice to get this quick replies, Thanks a lot!

    Files

    • lsmod zfs.txt

      (306 Byte, downloaded 281 times, last: )

    omv 1.10 kralizec | 64 bit | Linux 3.2.0-4-amd64 kernel | omvextrasorg 1.8

  • zfs is loaded. Make sure openmediavault-zfs is installed - apt-get install openmediavault-zfs and clear your browser cache.

    omv 6.0.30-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.0.9 | kvm 6.1.19 | mergerfs 6.1.1 | zfs 6.0.9
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • zfs is loaded. Make sure openmediavault-zfs is installed - apt-get install openmediavault-zfs and clear your browser cache.


    I clear the browser and also download Firefox, now I'm testing in Chrome, Firefox & Safari, all of them share the same on the GUI.

  • Strange... Try: apt-get install --reinstall openmediavault-zfs

    omv 6.0.30-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.0.9 | kvm 6.1.19 | mergerfs 6.1.1 | zfs 6.0.9
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • apt-get purge openmediavault-zfs
    apt-get clean
    rm -f /var/cache/openmediavault/*.json
    wget http://omv-extras.org/testing/openmediavault-zfs_0.6.3.5_amd64.deb
    dpkg -i openmediavault-zfs_0.6.3.5_amd64.deb

    omv 6.0.30-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.0.9 | kvm 6.1.19 | mergerfs 6.1.1 | zfs 6.0.9
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • apt-get purge openmediavault-zfs
    apt-get clean
    rm -f /var/cache/openmediavault/*.json
    wget http://omv-extras.org/testing/openmediavault-zfs_0.6.3.5_amd64.deb
    dpkg -i openmediavault-zfs_0.6.3.5_amd64.deb


    No change at this point

  • What is the output of: dpkg -l | grep openmediavault

    omv 6.0.30-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.0.9 | kvm 6.1.19 | mergerfs 6.1.1 | zfs 6.0.9
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Can you turn on the debugger (chrome - press f12) before you go to that tab. You may have to select console to see error messages. If not, we might have to go the teamviewer route.

    omv 6.0.30-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.0.9 | kvm 6.1.19 | mergerfs 6.1.1 | zfs 6.0.9
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Could @darthsmiley and @jf_rr send me PM's with their respective e-mail addresses where I may send an updated version? I hope I've fixed the problem with the help of the screendump from Chrome... I would appreciate if you could test this new version for me sine I'm not experiencing the problem myself and am not able to reproduce it either.

  • Thanks for your work on getting the plugin fixed.


    After working with @nicjo814 do get the plugin showing correctly in the web-interface. I followed this process on a fresh test vm:

    • Installed using openmediavault_1.9_amd64.iso
    • After install, I run the update manager and updated all packages.
    • Installed the openmediavault-omvextrasorg_1.9_all.deb plugin through the web interface (Plugins -> Upload).
    • After that is finished, I moved over to the OMV-Extras option in the web interface and ticked the ZFS checkbox.
    • Went back to the update manager and refreshed. There should be more ZFS related packages to install.
    • After that was done I returned to the plugin page and did an upload of the new ZFS plugin that I was testing for nicjo814.
    • Install went cleanly without errors and whenever the page was reloaded the ZFS menu did appear and i was able to select it and pull the configuration page.
    • Now i added a few Virtual HDD's for testing. Did a scan in the Physical Disks menu option. Then i returned to the ZFS menu and created a mirror flawlessly.
    • Added a few datasets & volumes just for fun.
    • Now i rebooted. to see if the configuration persists. This is were i caught my first snag.
    • Through some googling and testing. I was able to get the pool to persist through reboots by changing and attribute int the /etc/default/zfs file
    • I changed ZFS_UNMOUNT to no (notice the comment says this should be no on most systems) *MAKE SURE YOU GO TO THE ZFS MENU AND IMPORT YOUR CURRENT POOL BEFORE REBOOT*
    • Tried another reboot... Success no more Error cannot create upon login and the pool is visible in the ZFS menu
    • EXTRA TIP (This pertains to the whole reason i'm testing OMV) If you add a file under /etc/modprobe.d/ called zfs.conf and put this in the file without quotes "options zfs zvol_major=240" & reboot. You should be able to Add ZVols as block devices in targetcli (LIO). I'm not a fanboy of either LIO or SCST. I'm testing for my FC home SAN. OMV might end up being just what I need. Ill be posting a targetcli FC guide later on when I get more into my migration project.
    • I also want to add that this test did not use the backports kernel. Its a stock install.
  • I don't know where to offer this contribution:


    if you need testers for the zfs-Plugin, then I'm ready.
    I just moved from FreeNAS and installed OMV on hardware with a HBA and some disks without data.


    Kind regards,
    Thomas

  • I cannot place mysql DB folder in ZFS volume.
    I don't remember if I already warned about, but recently I faced that problem again and thought that it was useful to post.


    If you have the same problem as I did (zfs/innodb "missmatch") it could be fixed by adding the following to your mysql configuration:

    Code
    innodb_use_native_aio = false
  • If you have the same problem as I did (zfs/innodb "missmatch") it could be fixed by adding the following to your mysql configuration:

    Code
    innodb_use_native_aio = false


    Uhmmm I don't exactly remember the problem, but it had to do with aio while starting the server. So it could be.


    EDIT: That actually did the trick. Thanks.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!