If omv-update gives an error ...

  • If "omv-upgrade" gives an error ...

    Description

    This guide gives you some commands to fix your system, if omv-update or updating via GUI gives an error.


    Commands you can try
    Please try the following commands on the CLI one after another. Between them, please check, if omv-update works. Linux-systems don't put out any error message, if the command was successful ;)


    apt-get clean
    apt-get update
    apt-get upgrade
    ---
    apt-get -f install
    ---
    dpkg --configure -a
    ---
    rm -rf /var/lib/apt/lists/*
    mkdir /var/lib/apt/lists/partial
    ---
    especially when upgrading from 0.5.x to 1.x
    omv-mkconf nginx
    omv-mkconf php5fpm
    service apache2 stop
    service php5-fpm restart
    update-rc.d -f apache2 remove
    service nginx restart
    ---
    PHP Startup: Unable to load dynamic library '/usr/lib/php5/20100525/suhosin.so' - /usr/lib/php5/20100525/suhosin.so: cannot open shared object file: No such file or directory in Unknown on line 0
    apt-get purge php5-suhosin
    ---
    rm /etc/monit/conf.d/openmediavault
    rm /etc/monit/conf.d/openmediavault/collectd
    omv-mkconf monit
    omv-mkconf collectd
    monit restart omv-engined


    Does omv-update work?
    No? Then please open a new thread with a meaningful Topic and a detailed description of your error. Add as much info as possible and attach the OMV-Report (omv-sysinfo): Diagnostics > System Information > Report
    or use the Logupload system under Support Info (if you have omv-extras installed) > Send and tell us your ID.



    Questions / Problems / Diskussions
    Feel free to create a thread in the correct section!



    Version:
    0.1 Initial Version
    0.2 Added Logupload Info
    0.3 Added hint to omv-extras
    0.4 Added Questions / Problems / Diskussions

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!