Temperature CPU?

  • Not as of yet, but it would be a great addition. However, is not a priority as of right now unless someone with skills wants to contribute writing a plugin for it. So in short, not right now.

    Absolutely no support through PMs!!
    I work for the HPE R&D division. Have tech questions about ProLiant servers? Ask me!
    Learn more about HPE's iLO included in all ProLiant servers.

  • Pardon to correct you Spy, but the Plugin is already in the making by jhmiller, cpu temp is one of the first things thats working, but jhmiller still has to fix some bugs.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!


    I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.

  • The plugin needs feedback from end users so the more who try it and give feedback the better it will be.


    A lot of the issues that were found in the first release have been fixed and a new version has been released, it can be found here


    Please test and report any issues here


    Miller

    [align=center]
    What I am watching/watched on my Popcorn Hour media player
    omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
    MySQL (Percona[size=8]) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

  • Quote

    Please test and report any issues here


    Access denied



    Installed sensors on latest kralizec. Modified modules (chip was found). Restarted


    # /etc/init.d/kmod start
    Loading kernel module loop.
    Loading kernel module jc42.


    From this moment the access to dashboard and services got stuck. Uninstalled the module and services and dashboard works. During uninstall there was a error popup, unfortunately i lost the msg.

    Tom


    ----


    HP N54L, 6GB, 5disc Raid5, SSD Boot with OMV Stone Burner
    HP N54L, 16GB, 4disc Raid5, SSD Boot with OMV Stone Burner

  • click the link and report the issue in that thread. I think I know what is wrong but want to keep all info in I topic.

    [align=center]
    What I am watching/watched on my Popcorn Hour media player
    omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
    MySQL (Percona[size=8]) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

  • Sorry, I forgot that is a dev forum that you do not have access to, its nice to be special :D


    Did you run /etc/init.d/kmod start or did the system do it automatically?
    Also did you run sensors-detect?


    If you could re-install and give the output of the following 3 commands

    Code
    sensors
    ls /var/lib/rrdcached/db/localhost/sensors-*/
    cat /proc/cpuinfo

    [align=center]
    What I am watching/watched on my Popcorn Hour media player
    omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
    MySQL (Percona[size=8]) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

    Edited once, last by jhmiller ().

  • Modified modules (chip was found). Restarted


    Where did you see this?


    # /etc/init.d/kmod start
    Loading kernel module loop.
    Loading kernel module jc42.


    When was this run?


    This is the only info you have given me and none of it is to do with the plugin, It will not show what it has found and it will not run /etc/init.d/kmod
    If you install the plugin and get the error that came up, also do nothing in cli, the plugin will do all that is needed.

    [align=center]
    What I am watching/watched on my Popcorn Hour media player
    omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
    MySQL (Percona[size=8]) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

  • Installed the plugin, followed the instructions in the plugin installer window (installing and starting the kernel modules).


    Will try it again this WE and give u feedback

    Tom


    ----


    HP N54L, 6GB, 5disc Raid5, SSD Boot with OMV Stone Burner
    HP N54L, 16GB, 4disc Raid5, SSD Boot with OMV Stone Burner

  • Here we go, installed the plugin again:



    --->


    made change to /etc/modules


    did /etc/init.d/kmod start


    enabled cpu monitor


    --->


    Clicking on services brings only the wheel of death ;)


    Dtto on dashboard



    On Status page i see Temperature but just unhappy icons
    ---


    got during install two messages (email):


    Description: process PID changed from 24996 to 6865


    Description: process PID changed from 6865 to 7268



    EDIT: reboot doesnt help


    module seems to be loaded (lsmod output):


    i2c_core 24228 6 drm,jc42,i2c_piix4,drm_kms_helper,i2c_algo_bit,radeon


    k10driver was found by probe sensors, seems to be there but not used by anything:


    k10temp 12618 0

    Tom


    ----


    HP N54L, 6GB, 5disc Raid5, SSD Boot with OMV Stone Burner
    HP N54L, 16GB, 4disc Raid5, SSD Boot with OMV Stone Burner

    Edited 4 times, last by davidh2k ().

  • Quote

    also do nothing in cli, the plugin will do all that is needed.


    Code
    To load everything that is needed, add this to /etc/modules:
    #----cut here----
    # Chip drivers
    jc42
    #----cut here----
    If you have some drivers built into your kernel, the list above will
    contain too many modules. Skip the appropriate ones!
    Successful!


    This message should be ignored, In the first version that script was not run until you enabled the plugin and so it was run in the background, I forgot I moved it to run on install.
    Remove the entries from /etc/modules, and run

    Code
    rmmod jc42

    you may also need to restart


    This will undo what you did manually after that, disable the cpu temp and then enable it (generates new configuration files) then check the status page.


    please also do


    Code
    sensors
    ls /var/lib/rrdcached/db/localhost/sensors-*/
    cat /proc/cpuinfo

    [align=center]
    What I am watching/watched on my Popcorn Hour media player
    omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
    MySQL (Percona[size=8]) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

  • Removed entry in modules, did rmmod, restarted system


    After this i disabled and enabled cpu temp several times:


    1. still wheel of death
    2. no temperature tab in status


    during this steps got status mails about collectd (not exist/exist/change of pid)


    ---



    EDIT: even with enabled cpu temp there is no entry in modules (in case your scripts should create one there)

    Tom


    ----


    HP N54L, 6GB, 5disc Raid5, SSD Boot with OMV Stone Burner
    HP N54L, 16GB, 4disc Raid5, SSD Boot with OMV Stone Burner

    Edited once, last by davidh2k ().

  • can you now do


    Code
    cat /usr/share/openmediavault/mkconf/collectd.d/sensors[code]
    followed by
    [code]cat /usr/sbin/omv-mkgraph


    The first is generated by the plugin and is used to amend omv-mkgraph

    [align=center]
    What I am watching/watched on my Popcorn Hour media player
    omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
    MySQL (Percona[size=8]) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!