openmediavault-pxe first version now available for testing

  • Bitte das oma_ubcd-5.3.5.tar.gz vom 16.02.2016 von Server nehmen, das funktioniert nicht. Das oma_ubcd_5.3.5.tar.gz vom 22.02.2016 läuft los und scheint erstmal zu funktionieren; ich muss noch alle Komponenten testen und melde mich nochmals dazu.

    2 BananaPi, 1 OrangePiPC+, 2 x86-PC with OMV 5.5.x.x

  • Auch meine neues ubcd-Image funktioniert nicht, ich komme mit der verschachtelten Konfiguration nicht zurecht.


    Nun habe ich drei aktuelle clonezilla-Images auf den ftp-Serverhochgeladen.

    2 BananaPi, 1 OrangePiPC+, 2 x86-PC with OMV 5.5.x.x

  • Greetings!


    I had set up PXE booting as a test before I enabled the firewall, and after I did that in OMV, I was unable to boot from PXE.
    I've set static ports for NFS and I am able to mount NFS shares. I've opened up different ports as well to allow all clients on network access NFS shares.
    I've also opened up ports 53,67-69 for dmasq and tftp.
    Please help me as to where I've gone wrong!
    My routers gateway is 192.168.1.1, my server is at 192.168.1.8
    I might have experimented a bit with the dnsmasq settings in one of the images in a futile attempt to make it work.
    Here is my setup. There are 5 images.
    Sorry for my bad english.


    http://imgur.com/a/wyPMq


    Heres the error message I get. I could only take a screenshot in VM. Host PC just times out if I try it on bare metal.


    http://i.imgur.com/fJpV9iO.png

  • Hallo David,


    meine zwei Wily Werewolf-Images funktionieren. Die drei Clonezilla-Images (oma_Clonezilla_2.4.5_live_xxxxxx.tar.gz) booten nicht voll durch, ich hänge ein Bild an. Bis auf den Pfad ist der Fehler bei allen drei Images der selbe. Vielleicht hat @ryecoaaron einen Tipp?


    Danke und viele Grüße.

  • I've never used the ubuntu version (alternative stable) of clonezilla. I always use the stable version.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Heres the error message I get. I could only take a screenshot in VM. Host PC just times out if I try it on bare metal.


    i.imgur.com/fJpV9iO.png


    This really confuses me since it seems to try to connect to a http address in the www.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Quote from ssnape: “Heres the error message I get. I could only take a screenshot in VM. Host PC just times out if I try it on bare metal.


    i.imgur.com/fJpV9iO.png”


    This really confuses me since it seems to try to connect to a http address in the…


    Yes, I've looked on it, having googled the error message and as far as I can tell, it's because it's unable to locate/access the NFS path, if I'm not mistaken. (That error message is very specific and is basically an error code you can google.)

  • I dunno, maybe @tekkb can jump in and try to figure out what you might lack in your firewall configuration.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Hallo David,
    auch unter OMV 3.0.13 mit dem dnsmasq-plugin 3.0 muss wie bereits hier am 03. März 2015 geschrieben folgendes ausgeführt werden:


    echo "nameserver 8.8.8.8" >> /etc/resolvconf/resolv.conf.d/tail
    danach das System neu starten


    weil ansonsten der Weg ins Internet versperrt ist.


    Viele Grüße.

    2 BananaPi, 1 OrangePiPC+, 2 x86-PC with OMV 5.5.x.x

    Edited 3 times, last by omavoss ().

  • Try 3.0.1 that I just put in the repos. You will need to make a small change to your pxe config to get it to write a new config file or execute omv-mkconf pxe.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • @davidh2k
    Hey,
    ich muss es auf deutsch schreiben, mein englisch könnte zu Missverständnissen führen:


    Ich habe mit den neuen PXE-Plugin ein Image heruntergeladen, vorher die IP-Adresse ausgewählt. Hier wird nun NEU offenbar automatisch in die Append-Zeile folgendes eingefügt:


    Code
    ... nfsroot=192.168.115.15:/export/PXE/tftp/ubuntu/vivid_vervet/live/desktop/x86_ ...


    Das haut so aber nicht hin. Im Pfad ist das "/tftp" zuviel. Wenn ich das für meine OMV-Maschine passend editiere,also das "/tftp" rauslösche, funktioniert alles richtig.


    Wenn ich falsch liege, bitte ich um Antwort.


    Danke und viele Grüße.

    2 BananaPi, 1 OrangePiPC+, 2 x86-PC with OMV 5.5.x.x

  • Erm... kann es sein dass das dein Image ist und in dem Image der Pfad falsch im Textdokument hinterlegt ist?


    Gruß
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!