Update to OMV8 from 7.7.24-4 using omv-release-update failed

  • I initiated the update from OMV 7.7 to OMV 8 this morning by using the omv-release-update command in Putty. It took a while but seemed to be progressing OK until I think it was a Python section where it seemed to hang. When I tried to see what was happening it seemed as if it had frozen so I closed the Putty instance and opened a new one. When I re-ran the omv-release-upgrade I got the following error message.

    Code
    -sh: 1: omv-release-upgrade: not found


    If I run the fix7to8upgrade command, sudo wget -O - https://raw.githubusercontent.…ipt/master/fix7to8upgrade | sudo bash", I get this:

    Quote

    wget: error while loading shared libraries: libnettle.so.8: cannot open shared object file: No such file or directory

    Checking for updates in the OMV GUI I get this:

    Is my best option to wipe the OS SSD my OMV instance is running on with a Debian image and then install the fresh 8.0.2 ISO for OMV? Or does the 8.0.2 ISO take care of the Debian install for me?

  • MarcLister

    Changed the title of the thread from “Update to OMV8 from 7.7.24-4” to “Update to OMV8 from 7.7.24-4 using omv-release-update failed”.
  • I somehow fixed this last night! Took me a few hours and some hurdles came up as I was fixing things but I got there. I was able to log into the GUI but SMB/CIFS wasn't running despite being enabled. In the early hours I realised that I appeared to have two kernels installed so I removed the older one and that seemed to put me on the right road.


    I tried the omv-upgrade and omv-release-upgrade but they didn't solve the issue. I was getting "sub-process /usr/bin/dpkg returned an error code (1)" error messages when I tried to fix anything so I gave methods 1, 2 a go then did a sudo apt update followed by method 4 from this link https://phoenixnap.com/kb/fix-…pkg-returned-error-code-1. That got me a bit further to fixing it. I'd previously tried sudo apt --fix-broken install a few times but kept getting errors.

    Eventually I was able to omv-upgrade running and then I followed that with omv-release-upgrade and we were getting close. However then the GUI wouldn't let me in and was giving me error 502 bad gateway. I gambled with the fix7to8upgrade script which took a while but once it had done that the GUI let me in, SMB/CIFS was running and the drives were accessible. I did a restart as the GUI recommended it and it's been happy ever since.


    My OMV instance is now on running 8.0.2-2 (Synchrony) and the kernel is Linux 6.17.8+deb13-amd64.

  • MarcLister

    Added the Label resolved
  • I myself have been having some issues with the migration from 7 to 8. The issues / steps Marc listed in his initial post are very close to my own.
    I thought all was good, could see the new OMV8 UI. When opening the web GUI I have the yellow changes box appear and asks to apply a range of changes (zfs and so on).

    Trying to apply it leads to this error:


    Appears to be a little different to Macs output but perhaps has a similar cause?

    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LC_ALL=C.UTF-8; export LANGUAGE=; omv-salt deploy run --no-color apt 2>&1' with exit code '1': debian: Data failed to compile: ---------- The function "state.orchestrate" is running as PID 761 and was started at 2026, May 11 13:40:41.237947 with jid 202605111340412379
    • Official Post

    perhaps has a similar cause?

    Looks like another process is updating your system. Wait a few minutes and then post the output of:


    sudo omv-salt deploy run apt

    omv 8.5.8-1 synchrony | 7.0 proxmox kernel

    plugins:

    omvextrasorg 8.0.3 | kvm 8.3.2 | compose 8.1.24 | cterm 8.0.3 | borgbackup 8.2.1 | tempmon 8.0.5 |

    mergerfs 8.0.2 | scripts 8.0.6 | writecache 8.2.4 | backup 8.1 | kernel 8.0.16


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Well that process was running for a good hour. Ended with this error code:

    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LC_ALL=C.UTF-8; export LANGUAGE=; omv-salt deploy run --no-color zfs 2>&1' with exit code '1': debian: ----------
     ID: zfs_provider_install_selected Function: pkg.installed Name: omv-zfs-provider-dkms Result: False Comment: Problem encountered installing package(s). Additional info follows: errors: -
     Running as unit: run-p105004-i107824.scope; invocation ID: 2945bdd76c034ac383bc90fb415d73da E: Sub-process /usr/bin/dpkg returned an error code (1) Started: 00:44:00.384022 Duration: 2317044.767 ms Changes: ----------
     ID: zfs_provider_remove_other Function: pkg.removed Name: omv-zfs-provider-pve Result: False Comment: One or more requisite failed: omv.deploy.zfs.default.zfs_provider_install_selected Started: 01:22:37.429313 Duration: 0.009 ms Changes: ----------
     ID: zfs_provider_remove_apt_pin Function: file.absent Name: /etc/apt/preferences.d/omv-zfs-pve.pref Result: True Comment: File /etc/apt/preferences.d/omv-zfs-pve.pref is not present Started: 01:22:37.433593 Duration: 0.932 ms Changes: Summary for debian ------------
     Succeeded: 1 Failed: 2 ------------ Total states run: 3 Total run time: 2317.046 s [ERROR ] Command 'systemd-run' failed with return code: 100 [ERROR ..

    Anyway after running sudo omv-salt deploy run apt.

    Both outputs point to zfs being bonked.
    Perhaps I should run apt reinstall zfs?

    • Official Post

    The zfs package currently in Debian backports does not compile on the 7.0 kernel in backports. I can't do anything about that. This is one of the main reasons why I recommend using the proxmox kernel.

    omv 8.5.8-1 synchrony | 7.0 proxmox kernel

    plugins:

    omvextrasorg 8.0.3 | kvm 8.3.2 | compose 8.1.24 | cterm 8.0.3 | borgbackup 8.2.1 | tempmon 8.0.5 |

    mergerfs 8.0.2 | scripts 8.0.6 | writecache 8.2.4 | backup 8.1 | kernel 8.0.16


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • from the make.log


    Code
    checking whether fst->mount() exists... configure: error:
            *** None of the expected "fst->mount()" interfaces were detected.
            *** This may be because your kernel version is newer than what is
            *** supported, or you are using a patched custom kernel with
            *** incompatible modifications.
            ***
            *** ZFS Version: zfs-2.4.1-1~bpo13+1
            *** Compatible Kernels: 4.18 - 6.19


    Looks like the latest zfs is only compatible with 4.18 - 6.19 kernels https://github.com/openzfs/zfs/releases


    I didn't try to update from omv 7, but I failed to reboot. You have to set the 6.19 kernel as default in grub


    You can do this from the omv extras kernel plugin, there's an update grub button, you have to press it, it's not enough if the 6.19 kernel has a checkmark for default for some reason.



  • So I decided to cut my loses and start with a clean upgrade. Before starting the upgrade I made sure to install the proxmox kernel and then reinstall zfs.
    Upgrade mostly went smoothly, but failed at the hddfanctrl plugin + 502 error in GUI, but fix7to8upgrade command once again solved that.


    But unfortunately no dice, still the got a zfs error. Also applying these pending changes took an hour and a half? Didn't think USB 2.0 would lag it that much. Tbh the entire upgrade process took 6 hours so.

    This is the error in question:

    Code
     500 - Internal Server Error
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LC_ALL=C.UTF-8; export LANGUAGE=; omv-salt deploy run --no-color zfs 2>&1' with exit code '1': debian: ---------- ID: zfs_provider_install_selected Function: pkg.installed Name: omv-zfs-provider-dkms Result: False Comment: Problem encountered installing package(s). Additional info follows: errors: - Running as unit: run-p17078-i16691.scope; invocation ID: 8e8109cb636b45c897dac9368e966cac E: Sub-process /usr/bin/dpkg returned an error code (1) Started: 17:03:50.241302 Duration: 4032542.546 ms Changes: ---------- dkms: ---------- new: 3.2.2-1~deb13u1 old: file: ---------- new: 1:5.46-5 old: libmagic-mgc: ---------- new: 1:5.46-5 old: libmagic1t64: ---------- new: 1:5.46-5 old: omv-zfs-provider-pve: ---------- new: old: 8.0.1 ---------- ID: zfs_provider_remove_other Function: pkg.removed Name: o... 



    Going to now try uninstall ZFS, install the proxmox kernel 6.14 and then reinstall ZFS again.
    Might be worth moving to a new thread

    • Official Post

    I recommend installing the proxmox kernel, reboot into the proxmox kernel, remove the non-proxmox kernels, and then install the zfs plugin.

    omv 8.5.8-1 synchrony | 7.0 proxmox kernel

    plugins:

    omvextrasorg 8.0.3 | kvm 8.3.2 | compose 8.1.24 | cterm 8.0.3 | borgbackup 8.2.1 | tempmon 8.0.5 |

    mergerfs 8.0.2 | scripts 8.0.6 | writecache 8.2.4 | backup 8.1 | kernel 8.0.16


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Right I keep running into issue removing the kernels or removing zfs. As zfs is busted I am currently in a loop 22 of OMV trying to build every kernel before doing the action I want.

    This fails... as yes zfs is bused. So I'm going around and around.

    And the error this process ends on:

    Granted looking at the code above it appears to have removed kernel 6.12.85 and then tried to rebuild the remainder.

    • Official Post

    You need to remove zfs first.

    omv 8.5.8-1 synchrony | 7.0 proxmox kernel

    plugins:

    omvextrasorg 8.0.3 | kvm 8.3.2 | compose 8.1.24 | cterm 8.0.3 | borgbackup 8.2.1 | tempmon 8.0.5 |

    mergerfs 8.0.2 | scripts 8.0.6 | writecache 8.2.4 | backup 8.1 | kernel 8.0.16


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Yes I ran apt remove zfs, it did all the same as about and produced this error.


    So is there another way to really scrub clean zfs from my system? I kinda assumed it was gone as it's not in the web GUI / plugins anymore. But yeah no 100% I guess.

    • Official Post

    sudo apt-get remove zfs-dkms openmediavault-zfs omv-zfs-provider-dkms

    omv 8.5.8-1 synchrony | 7.0 proxmox kernel

    plugins:

    omvextrasorg 8.0.3 | kvm 8.3.2 | compose 8.1.24 | cterm 8.0.3 | borgbackup 8.2.1 | tempmon 8.0.5 |

    mergerfs 8.0.2 | scripts 8.0.6 | writecache 8.2.4 | backup 8.1 | kernel 8.0.16


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Had a shot at the above, returns:

    Code
    root@dontcareserver:~# sudo apt-get install remove zfs-dkms openmediavault-zfs omv-zfs-provider-dkms
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    E: Unable to locate package remove
    • Official Post

    I had a typo in my line which I corrected but you cut&paste before I did that evidently. Just remove the word "install".

    omv 8.5.8-1 synchrony | 7.0 proxmox kernel

    plugins:

    omvextrasorg 8.0.3 | kvm 8.3.2 | compose 8.1.24 | cterm 8.0.3 | borgbackup 8.2.1 | tempmon 8.0.5 |

    mergerfs 8.0.2 | scripts 8.0.6 | writecache 8.2.4 | backup 8.1 | kernel 8.0.16


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Legend! TY!

    With that I was able to complete fixing the kernel issues and get a new install of zfs up and running!

    Now running OMV 8 and happy days ahead!

  • Same issue here. How did you, mebradhen , proceed after executing

    Code
    remove zfs-dkms openmediavault-zfs omv-zfs-provider-dkms

    ?


    *EDIT* I already went ahead anyway & looks like I was successfull. What I did after the above command was omv-upgrade, apt autoclean, apt autoremove, then rebooted and then installed the zfs plugin just via the webinterface which this time worked as it should.

    Edited 4 times, last by villeneuve: corrected the commands I posted ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!