Error updating

  • Anyone have an idea how to fix this?

    Err:9 https://deb.debian.org/debian stable-backports InRelease

    Sub-process /usr/bin/sqv returned an error code (1), error message is: Error: Failed to parse keyring "/tmp/apt-key.ExioTw.asc" Caused by: Invalid ASCII Armor footer.


    Updating in the GUI give a big red error

    I attemped from terminal I got the above error

    • Official Post

    You should never use the stable keyword. Always use the actual release - trixie-backports. Since OMV doesn't add stable, I don't know what added it. Delete it from whatever sources.list file it is in.

    omv 8.5.8-1 synchrony | 7.0 proxmox kernel

    plugins:

    omvextrasorg 8.0.3 | kvm 8.3.2 | compose 8.1.24 | cterm 8.0.3 | borgbackup 8.2.1 | tempmon 8.0.5 |

    mergerfs 8.0.2 | scripts 8.0.6 | writecache 8.2.4 | backup 8.1 | kernel 8.0.16


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • This is all that's in the sources.list:

    deb http://httpredir.debian.org/debian trixie main contrib non-free non-free-firmware

    deb http://httpredir.debian.org/debian trixie-updates main contrib non-free non-free-firmware

    • Official Post

    This is all that's in the sources.list:

    Then it is likely in another .list file in /etc/apt/sources.list.d/

    omv 8.5.8-1 synchrony | 7.0 proxmox kernel

    plugins:

    omvextrasorg 8.0.3 | kvm 8.3.2 | compose 8.1.24 | cterm 8.0.3 | borgbackup 8.2.1 | tempmon 8.0.5 |

    mergerfs 8.0.2 | scripts 8.0.6 | writecache 8.2.4 | backup 8.1 | kernel 8.0.16


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • I have listed in etc/apt:

    apt.conf.d

    listchanges.conf

    pre-invoke.d

    sources.list.d

    update-post-invoke-success.d

    auth.conf.d

    listchanges.conf.d

    preferences.d sources.list~

    update-post-invoke.d

    keyrings

    post-invoke.d

    sources.list

    trusted.gpg.d

    update-pre-invoke.d

    • Official Post

    I have listed in etc/apt:

    But I said it would be in a file in /etc/apt/sources.list.d/


    grep -r 'stable-backports' /etc/apt/sources.list.d/*

    omv 8.5.8-1 synchrony | 7.0 proxmox kernel

    plugins:

    omvextrasorg 8.0.3 | kvm 8.3.2 | compose 8.1.24 | cterm 8.0.3 | borgbackup 8.2.1 | tempmon 8.0.5 |

    mergerfs 8.0.2 | scripts 8.0.6 | writecache 8.2.4 | backup 8.1 | kernel 8.0.16


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Ok, here is what I get with that!


    /etc/apt/sources.list.d/openmediavault-custom-2aa795aa-7380-4eb6-8fc5-761c07d7df72.sources:Suites: stable-backports


    And then what do I do to fix it?

    • Official Post

    And then what do I do to fix it?

    Disable it in the apt plugin - System -> Update Management -> Settings -> Other Software

    omv 8.5.8-1 synchrony | 7.0 proxmox kernel

    plugins:

    omvextrasorg 8.0.3 | kvm 8.3.2 | compose 8.1.24 | cterm 8.0.3 | borgbackup 8.2.1 | tempmon 8.0.5 |

    mergerfs 8.0.2 | scripts 8.0.6 | writecache 8.2.4 | backup 8.1 | kernel 8.0.16


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Well I've exhausted trying to fix but have notice, if I click the hour glass (left) at the check for updates arrow is when I get the big red error window.

    But I noticed when I just clicked the updates available button in the system information window, showed the updates, then updated seemingly correctly.

    Everything seems to work fine no other ill effects that I can discern.


    Here was the answer I was looking for and fixed the problem:

    sudo rm -rf /etc/apt/sources.list.d/*
  • Dudesplace

    Added the Label resolved
    • Official Post

    Here was the answer I was looking for and fixed the problem:

    That didn't fix the problem. You just deleted almost all of your repos and you will not get many updates. To fix. click the apt clean repos button in omv-extras.

    omv 8.5.8-1 synchrony | 7.0 proxmox kernel

    plugins:

    omvextrasorg 8.0.3 | kvm 8.3.2 | compose 8.1.24 | cterm 8.0.3 | borgbackup 8.2.1 | tempmon 8.0.5 |

    mergerfs 8.0.2 | scripts 8.0.6 | writecache 8.2.4 | backup 8.1 | kernel 8.0.16


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Dudesplace

    Removed the Label resolved
  • So is this not what I should have in the update other software section?

    Types: deb

    URL: https://deb.debian.org/debian

    Suites: stable

    Components: main contrib non-free non-free-firmware

    • Official Post

    is this not what I should have in the update other software section?

    I don't completely understand what you are asking. That is one repo - the regular debian repo. You still need the debian security repo, debian updates repo, omv repo, omv-extras repo. Possibly the debian backports repo. You really shouldn't have to be maintaining these from the command line. Doing so is just causing you more problems.

    omv 8.5.8-1 synchrony | 7.0 proxmox kernel

    plugins:

    omvextrasorg 8.0.3 | kvm 8.3.2 | compose 8.1.24 | cterm 8.0.3 | borgbackup 8.2.1 | tempmon 8.0.5 |

    mergerfs 8.0.2 | scripts 8.0.6 | writecache 8.2.4 | backup 8.1 | kernel 8.0.16


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Dudesplace

    Added the Label resolved
  • I just reinstalled, not sure how I did that, unless it was something in KVM, Docker or containers I was experimenting with.

    It is my test bench so no big deal, reinstalling fixed it.

  • ryecoaaron I am getting the same daily error message from anacron. (some Dutch language parts translated to English)

    Code
    /etc/cron.daily/openmediavault-apticron:
    W: Verification OpenPGP signature failed: https://deb.debian.org/debian stable InRelease: Sub-process /usr/bin/sqv returned an error code (1), error message is: Error: Failed to parse keyring "/tmp/apt-key.zhUSog.asc"  Caused by:     Invalid ASCII Armor footer.
    E: Package source 'https://deb.debian.org/debian stable InRelease' is not signed.

    And I do not fully understand your recommendations.

    What should be changed in my settings below?

    - NAS and Self-hosting student -

    -- OMV Dutch language translator --

    UGREEN DXP2800: N100, 16GB RAM, 128GB NVMe (OS), 1TB NVMe (Apps), 2x 6TB HDD (data + backup), OMV8

    OMV Services: Antivirus, Compose, Fail2ban, OwnTone, Scripts, SMB/CIFS, SSH, Tempmon, WeTTY, Write Cache

    Docker apps: AliasVault, BentoPDF, Collabora, FileBrowser, GrampsWeb, Grimmory, Jellyfin, Joplin, Navidrome, NMPplus, RustDesk, Sync-in, VoidAuth

  • I'm not sure which one you mean:


    openmediavault-custom-00d2bf89-f982-4529-959e-c828cc8819a8.sources holds a PUBLIK KEY BLOCK, which I snipped.

    - NAS and Self-hosting student -

    -- OMV Dutch language translator --

    UGREEN DXP2800: N100, 16GB RAM, 128GB NVMe (OS), 1TB NVMe (Apps), 2x 6TB HDD (data + backup), OMV8

    OMV Services: Antivirus, Compose, Fail2ban, OwnTone, Scripts, SMB/CIFS, SSH, Tempmon, WeTTY, Write Cache

    Docker apps: AliasVault, BentoPDF, Collabora, FileBrowser, GrampsWeb, Grimmory, Jellyfin, Joplin, Navidrome, NMPplus, RustDesk, Sync-in, VoidAuth

    • New
    • Official Post

    holds a PUBLIK KEY BLOCK, which I snipped.

    Why? It is a public key. What is the output of:


    sudo omv-salt deploy apt


    Also verify your system time is correct.

    omv 8.5.8-1 synchrony | 7.0 proxmox kernel

    plugins:

    omvextrasorg 8.0.3 | kvm 8.3.2 | compose 8.1.24 | cterm 8.0.3 | borgbackup 8.2.1 | tempmon 8.0.5 |

    mergerfs 8.0.2 | scripts 8.0.6 | writecache 8.2.4 | backup 8.1 | kernel 8.0.16


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • sudo omv-salt deploy apt

    Results in: no such command 'apt'



    Time appears to be correct


    - NAS and Self-hosting student -

    -- OMV Dutch language translator --

    UGREEN DXP2800: N100, 16GB RAM, 128GB NVMe (OS), 1TB NVMe (Apps), 2x 6TB HDD (data + backup), OMV8

    OMV Services: Antivirus, Compose, Fail2ban, OwnTone, Scripts, SMB/CIFS, SSH, Tempmon, WeTTY, Write Cache

    Docker apps: AliasVault, BentoPDF, Collabora, FileBrowser, GrampsWeb, Grimmory, Jellyfin, Joplin, Navidrome, NMPplus, RustDesk, Sync-in, VoidAuth

  • sudo omv-salt deploy apt

    It's sudo omv-salt deploy run apt

  • - NAS and Self-hosting student -

    -- OMV Dutch language translator --

    UGREEN DXP2800: N100, 16GB RAM, 128GB NVMe (OS), 1TB NVMe (Apps), 2x 6TB HDD (data + backup), OMV8

    OMV Services: Antivirus, Compose, Fail2ban, OwnTone, Scripts, SMB/CIFS, SSH, Tempmon, WeTTY, Write Cache

    Docker apps: AliasVault, BentoPDF, Collabora, FileBrowser, GrampsWeb, Grimmory, Jellyfin, Joplin, Navidrome, NMPplus, RustDesk, Sync-in, VoidAuth

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!