TFTP Permission denied

  • Hi,


    I'm configuring the TFTP server on my new OMV box.
    My DHCP server is on my router with OpenWRT and I configured it to direct the TFTP requests to OMV. I've also opened port 69 on the router firewall.
    In the DHCP server config file I've tried this two configurations:


    Code
    1) a new session:
    config boot linux
    option filename 'pxelinux.0'
    option serveraddress '192.168.1.240'
    option servername 'omv-nas'
    2) in the dnsmasq session:
    option dhcp_boot 'pxelinux.0,omv-nas,192.168.1.240'



    Every time I try to boot from a nootebook I use for tests, I have this error:

    Code
    TFTP.
    PXE-T00: Permission denied
    PXE-E36: Error received from TFTP server
    PXE-Mof: Exiting PXE ROM.



    What am I doing wrong?

  • Check permissions/privileges in the shared folder for tftp. If you can access through terminal try a chmod 775 - tftp_folder/
    For what I can see the laptop is reaching the server. BTW I can't see the need to open port 69 in openwrt.


    edit: I saw that tftp server has an option for new files creation.

  • Thankyou for the tip.
    I've forgot to set executable to the files.
    But the correct command is chmod 775 -R tftp_folder/
    And you're right, there's no need to open port 69 in the firewall

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!