openmediavault-emby plugin (formerly mediabrowser)

  • 1) When you are in the Emby UI click on "Home" (upper left) and then "Manage Server".
    2) Then in the window to the right it will tell you if your server is up to date or not.
    3) If there is an upgrade click on the "Settings" tab of the plugin and the click on the "Force Update" button.
    4) Then a window pops up and there is a "Start" button. Click on it.


    That's it. It downloads and installs the latest zip file from Emby's Github.

  • hi guys,


    I love the plug-ins you guys created for OMV; it's awesome.


    I currently using Plex, and I love it.
    What's the difference between Plex and Emby?
    Can I run two of them on the same server?


    Thanks.

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

    Edited 2 times, last by tinh_x7 ().

  • Cool.


    Just to be sure:
    According to first page of the thread, it said the cache folder location feature has been dropped.
    Therefore, I don't need to create a separated cache folder or separated folder for Emby media, right?

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

  • azza, so you have it working with the plugin??? Nice if you do. How is it working? I had built webp and imagemagick for armhf. I did not do the ffmpeg because the other architectures download it automatically. I hope the Emby devs add ffmpeg for armhf so it auto downloads like the other cpus.

  • the plugin starts and runs, i have gone through the setting and it's running. i can see the server from android clients, but i have not got media shares setup to properly test yet...
    i will try and test it out tomorrow and report back if playing media works, but for now the server is running.

  • i got some time to test and it looks like the server and library is working, media adds and clients can see it, however it is not yet streaming.
    looks like i get a transcode error in the log it fails with:
    /media/d4526d79-0444-4ddb-9694-a7f08b399dc4/emby/ffmpeg/20150717/ffmpeg: error while loading shared libraries: libxcb-xfixes.so.0: cannot open shared object file: No such file or directory
    will need to do some more research into it, looks like i am chasing libxcb-xfixes.so, anyone else come across this one?
    so as of now the server is working but media streaming is failing.

  • @tekkb
    Thank you for your assistance.


    apt-get install libxcb-xfixes0 has fixed the missing library.


    however, media streaming now won't play with a transcode fault of /media/d4526d79-0444-4ddb-9694-a7f08b399dc4/emby/ffmpeg/20150717/ffmpeg: error while loading shared libraries: libx264.so.142: cannot open shared object file: No such file or directory


    from find /usr -iname 'libx264.so.*'
    i get /usr/lib/arm-linux-gnueabihf/libx264.so.123


    looks like i need a newer version, i suspect i might need to re-compile a version of ffmpeg with libx264.so.142? actually it looks like there is a source at http://packages.ubuntu.com/trusty/libx264-142

  • New version available: 3.0.5724.6


    In the plugin click on the "Force update" button. Then on the popup click on "Start" button.


    After it is done installing you may have to click on the restart button on the plugin for the new version to show in the Manage Server section (then on right the server information) or there might be a resfresh popup at the bottom of the screen in the Emby UI. You can click on either of these.

  • Having the same problem with a arm v71 processor. Is there an ffmpeg being upped in any of the repos or an update to the emby plugin in the works? If not, what's the easiest way to get the plugin up and running?

  • It will work if you have a properly built version of ffmpeg. I already built webp and imagemagick for armv71. I am not going to do everything. It takes overnight to build this. I would ask on Emby forum if anyone has built a version of ffmpeg that works with armv71 and see if they will share it. Then come here if you need help to get it working.

  • Hi guys,


    I'm seeing two plug-ins in OMV web-gui:
    1. Mediabrowser 1.10.0
    2. emby 2.3


    What's the difference?
    I'm currently using mediabrowser plug-in, but it's not working great as I expected.

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!