openmediavault-emby plugin (formerly mediabrowser)

  • @Meniak The ffmpeg is normally downloaded by the Emby server. This is how it works for the amd64 and i386 CPUs. I have done everything for the plugin to work with the armv71 cpu except ffmpeg. I had hoped months ago the Emby developers would add ffmpeg so it would auto download for armv71 architecture. That is where it sits. But like I said if you see on their forums someone has a working version (with ffprobe) you can get this plugin working for armv71. You guys might ask them on the Emby forums to add ffmpeg so it auto downloads for the armv71 architecture. Maybe a little pressure there will get it done.

  • @tekkb I asked already but no answer still. I saw on their forums people are asking in the Qnap section too. I'm not familiar enough with CLI to install ffmpeg by myself so I hope someone includes it in Emby. I'm running the server on a NUC but that's used for home automation so it would be better if I can run Emby on my NAS. I have the paying version so I can probably transfer a backup to the new Emby.


    Apparently there's a working ffmpeg version in deb-multimedia.org

  • Hi I would like to install emby on my system but i have the dependency error. (sorry it's in french, my system is in french)

    Code
    Les paquets suivants contiennent des dépendances non satisfaites :
    openmediavault-emby : Dépend: libmono-cil-dev (>= 3.10) mais 2.10.8.1-8+deb7u1 devra être installé
    Dépend: libgdiplus (>= 3.8) mais 2.10-3+b1 devra être installé


    I see that some suggestion to test with the testing dependance, and remove the ffmpeg, but i still have the issue.


    Can you help me ?

    OMV Erasmus (always the last version) - version:AMD64 - noyau:4.7.0 - CPU:AMD II X2 250 - RAM:8Gb - RAID1 and RAID5

  • Did you enable the mono repo in OMV Extras?


    If you look at this you can see the package you are pulling up (2.10.8.1-8+deb7u1) is coming from the standard Debian repos. That tells me you do not have the mono project repo endabled that is in OMV Extras:



    PS- The command "apt-cache policy packagename" will tell you the repo in which a package resides.

  • Yes i have the mono depot activated, i try to put the testing but with same result.


    For the command it's seem that the depot is activated but for the installation, it's the debian that will be used

    Code
    apt-cache policy libmono-cil-dev
    libmono-cil-dev:
    Installé : (aucun)
    Candidat : 2.10.8.1-8+deb7u1
    Table de version :
    4.0.4.1-0xamarin1 0
    990 http://download.mono-project.com/repo/debian/ wheezy/main amd64 Packages
    2.10.8.1-8+deb7u1 0
    995 http://ftp.fr.debian.org/debian/ wheezy/main amd64 Packages
    995 http://security.debian.org/ wheezy/updates/main amd64 Packages

    OMV Erasmus (always the last version) - version:AMD64 - noyau:4.7.0 - CPU:AMD II X2 250 - RAM:8Gb - RAID1 and RAID5

  • It is the pinning... hold on. I have to start a vm.


    Give me results of this:


    ls -la /etc/apt/preferences.d/99omv-extras-org



    Sorry, when I copied and pasted I missed the / in front of the etc.

  • for the command : ls -la /etc/apt/preferences.d/99omv-extras-org

    Code
    -rw-r--r-- 1 root root 1845 oct. 20 20:05 /etc/apt/preferences.d/99omv-extras-org


    for the content of the file : cat 99omv-extras-org

    OMV Erasmus (always the last version) - version:AMD64 - noyau:4.7.0 - CPU:AMD II X2 250 - RAM:8Gb - RAID1 and RAID5

  • Yes, I wanted the cat command,, not ls -la. Hmm...


    Yeah, you have a higher pin priority for the mono project. It should be using that repo but is not.
    I know nothing about regional stuff. I'm native English speaker.


    Hopefully Aaron can look at this soon.


    @ryecoaaron

  • Everything is right. Not sure why it doesn't want to install. Has to be something with the dependencies in one of the repos. I don't use mono or even have it installed, so I couldn't tell you.

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I resolve my issue.


    I remove all the repository and save.
    I do an apt clean
    I reactivate the repository and i can install the emby plugin.


    Thanks


    for information:


    apt-cache policy libmono-cil-dev

    Code
    libmono-cil-dev:
    Installé : (aucun)
    Candidat : 4.0.4.1-0xamarin1
    Table de version :
    4.0.4.1-0xamarin1 0
    990 http://download.mono-project.com/repo/debian/ wheezy/main amd64 Packages
    2.10.8.1-8+deb7u1 0
    500 http://ftp.fr.debian.org/debian/ wheezy/main amd64 Packages
    500 http://security.debian.org/ wheezy/updates/main amd64 Packages

    OMV Erasmus (always the last version) - version:AMD64 - noyau:4.7.0 - CPU:AMD II X2 250 - RAM:8Gb - RAID1 and RAID5

  • No idea why the pinning was sticking. Since he was able to get it installed, something must have been left over from previous packages.

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!