Remote Access WebGui and other services

  • Hello.
    I know that this topic has been discussed several times, however, I was not able to find solutions to my problem by reading other topics (and sorry for my english :D ).
    As the title suggests, I would like to access the administration console (webgui) in order to manage my NAS wherever I am. To implement remote access I performed the following steps:
    1)I created a host with no-ip because my ISP gives me a dynamic ip;
    2)I enabled the DDNS service directly from my router;
    3)Finally, I opened ports 80 and 443 respectively for HTTP and for the WebGui.
    However, when I try to access from an external network (in my case with the 3G network from my smartphone), the browser continues to load endlessly, while the web pages remains white.
    I do not know if the problem is OMV or router's configurations. ?(
    What do you suggest me? Thanks to all. :)

  • Hi,
    I would NEVER expose my NAS to the internet.
    Don´t forget the guys who try to hijack devices around the clock.
    You should consider the configuration of a VPN.
    If you own a Fritzbox it should be easy.
    My VPN for example is running as "OpenVPN" on a "OpenWRT" Router.

  • Thanks for your reply.
    Unfortunately, my router does not support VPN configurations (it is able to connect to the existing VPN but not create). Do you know other systems to connect to NAS in a safe manner?
    However, the initial idea was just to test the proper operation of the connection.

  • There are two OpenVPN plugins for OpenMediaVault available. Use them for best security. ;)


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Hi davidh2k, thaks for reply. :)
    I searched in the list of available plugins, however openvpnas and openvpn are not present; I have already installed the omvextrasorg. how can I load one of these two plugins? Thanks.

  • Thank, now the plugins are present.
    I installed openVPN.
    I ask for help for the correct configuration: as I said before, my isp gives me a dynamic ip, so I created a host with no-ip. How do I enter this data into the plugin?
    Thank you for your patience.

  • You may should consider using the OpenVPNAS Plugin instead, as it is way more easy to use.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • I get the follow error when I try to enable OPENVPNAS:



  • but I can not access.


    Did enable port forwarding on your router for the OpenVPN Port?


    I get the follow error when I try to enable OPENVPNAS:


    The startscript for openvpnas wasn't installed correctly. I'm not sure if this is caused via a conflict with openvpn or not. Uninstall both plugins and reinstall OpenVPNAS alone.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Hello. Thanks for the replies and sorry for the delay.


    I uninstalled both plugins and reinstalled only OPENVPNAS; in this way, I had no problems to enable it. I followed the instructions, but when I try to access from the outside (from smartphone browser), I get the following error "HTTP 504 gateway timeout"


    The problematic steps are the follows:
    1) I used an address created with no-ip rather than with dyndns as indicated in the guide: could I have problems?


    2) The heading "Disable SSLv2 Support" is not present.


    3) Using the link "https://wanipofyouromv:943" the web page says "this webpage is not available"


    Thanks for help.

  • 1) I used an address created with no-ip rather than with dyndns as indicated in the guide: could I have problems?


    I rather doubt it.


    3) Using the link "wanipofyouromv:943" the web page says "this webpage is not available"


    Thats because you did not forward the port for the webinterface. And my guess you didnt either for the VPN port.


    I get the following error "HTTP 504 gateway timeout"


    See above. You probably forgot to forward the VPN Port. (Not sure which one it uses without looking it up.)


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Hmm... Can you check if these ports are really opened? From an outside location? If not, I may be able to help checking that.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Running a nmap portscan from a remote linux server or accessing the ports via curl would show me if they are open or not.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Excuse me, but could you explain me step by step how to do? The second option seems the easiest.
    Thank you for your patience. :)
    I ran a test on GRC ShieldsUP, but the control stops at port 1024 (the 943 is open).

  • Would you mind if we do a Teamviewer session so I get a quick overview of your configurations etc. myself?


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!