OpenVPN working on Android, not on Windows

  • I just installed the "new" openmediavault-openvpn plugin (was previously using openvpnas) and I've succesfully configured it and made it work on my personal Android device but not on my Windows laptop.

    I mean, I can connect to the VPN in both, that's not the issue. The problem is that when I try to browse to an internal IP address, it works fine on Android but on Windows (Firefox) it never loads the page. I tried this through a mobile data connection on my work phone with a wifi hotspot and I'm going to try monday at work where I have a cable connection and see if the problem persists.

    What can possibly be the cause for this, any ideas? One thing that comes to mind is that the OpenVPN Connect software creates a network adapter for this and when it's connected, it's set as "public network", not sure if that's supposed to be like that but I can't seem to change it either way.

  • Have you tried another browser with your windows notebook? I can barely remember I had problems with Safari with my iPhone getting to internal pages by DNS name. Only the direct IP adresses worked. With Chrome - no problem.

  • Did you launch the OpenVPN gui on Windows as Administrator ?

    Because if you don't, OpenVPN won't be able to add routes and therefore you will not be able to access private IPs.

    You should be able to see if OpenVPN was able to add routes or not in the log window of OpenVPN. You can also check your Windows routes in a terminal window by typing 'route print'.

  • a @Pollux says, that's routing problem. If the openvpn-gui doesn't have the rights it won't pull the appropriate routes to windows.
    Also make sure you're using different clients keys/certificates, otherwise you'll run into trouble if you connect simultaneously.

  • I did read the instructions that said to run OpenVPN GUI as admin and I was sure I ran it with admin privileges, I guess I didn't... It now works for all OMV services with a web admin behind it. Thanks guys :)

    However, it doesn't seem to open my router's web UI nor a TV box web UI. What could possibly be the reason for those?

    Do you mean just different keys per user or per user and device? For instance, for my user, one for my Android device and another for my laptop? I can only have one single connection per key, is that it?

  • Yes. Different key/certificate for each device. Unless you use duplicate-cn flag in extra options.

    The idea behind this is to have a PKI (public key infrastructure). From the certificate section once you remove one, that certificate will go to the revocation list (CRL). That device won't be allowed to connect any more. The CRL is like a rubbish bin for certificates
    Imagine if you lose the device (phone) or laptop. That's why you assign common-names to different clients, to properly identify them and control access

  • Interesting, I should probably recreate new keys with different CNs then.

    About my problem above, I fixed it by turning off the "default gateway" option. But I'm confused about using that option or a static route, can anyone explain their differences please?

  • Default gateway (aka the redirect gateway def1 flag) forwards all client traffic through the vpn service (useful for hiding your internet traffic, bypassing firewall and dns blocks). You may wanna look at the whole openvpn documentation, properly explained here.

  • hello i am having the opposite windows clients connect fine and can browse, on my android the vpn shows connected and shows the public ip of my internet service at home but when i try to browse the web it times out? I also used different certs one for my phone and one for pc.

    when i unchecked default gateway i can access the web but i do want when i connect from outside for it to go through my internet at home.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!