Slow "Password:" prompt when logging in SSH console

  • With putty, on every SSH login to my two OMV boxes, the password prompt was very slow. It was very annoying for me :)


    Today (finally...) I have found the solution:


    edit this file:


    /etc/ssh/sshd_config


    the name of the file is sshd_config with the "D". DO NOT edit the file ssh_config


    add this string at the end of the file: UseDNS no


    save the file and then restart the service and close the console by running this command:


    # service ssh restart && exit


    If you do not want to restart the service, just restart the system (or turn off the computer and boot as usual)


    For more details, use the links below:


    http://superuser.com/questions…into-my-ubuntu-9-05-serve
    http://blog.ayaz.pk/2008/02/03…s-resolution-and-openssh/

  • I always thought that delay was to help slow down brute force attacks (which it should).

    omv 5.6.5 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!