Update from 1.0.28 to 1.0.29 / Daily Mail from Anacron and 4 mails about nut / UPS

  • only to be sure:

    Code
    apt-get purge openmediavault-extplorer


    ok - did so - after that I reinstalled extplorer but result is the same... "404 not found"


    And I managed to navigate through the folders and could delete the files...


    but that did'nt help... no stats are shown....

    Scissors cuts paper, paper covers rock, rock crushes lizard, lizard poisons Spock, Spock smashes scissors, scissors decapitates lizard, lizard eats paper, paper disproves Spock, Spock vaporizes rock, and as it always has, rock crushes scissors.

    Edited 2 times, last by Parador ().

  • hi,


    Quote

    only to be sure:Source Code
    apt-get purge openmediavault-extplorer


    yes that is the one.


    it is to bad that it's not working i will test this out.


    but first i have a few questions.
    when you installed extplorer did it install without problems ?
    the extplorer user is there ?
    is the user fore extplorer sanctiond to use the system ?


    i will try to sort this out first before going to the nut plugin.


    in the meantime you can check this site out http://bugtracker.openmediavault.org/view.php?id=329 or this one http://www.revpol.com/xymon_nut_scripts

    gr. steel


    Cooler Master CM 690 III with 650 watt 80+ gold power supply
    AMD A8-5600k processor
    8 GB ddr 3 1333 ram
    crusial 120 ssd
    5 x 2 TB WesternDigital red harddrive in raid 5
    2 intel 1000mT nic's
    latest OMV stone burner

    lets get cooking .....
    don't be afraid of learning it can be fun

    Edited 4 times, last by steel2400 ().

  • Hi steel2400,


    first of all - thanks for you help and testing !!


    I started with OMV 0.5 and installed extplorer it worked with the standard extplorer user/password
    I never changed any user settings for extplorer (didn't find any)
    After upgrade to 1.0 I did not check if extplorer is working (did not need it yet)
    The installation of extplorer did not show any errors (I do not remember that any errors where shown)
    During deinstallation the was an error/notice that the directory could not be deleted because of it was not empty
    So I deleted that files manualy (after I figured out how to navigate through CLI)


    But to be sure I used "purge" again and deinstalled/reinstalled it again.


    In that directory the following was found:

    Code
    root@openmediavault:/var/www/extplorer# dir
    scripts
    root@openmediavault:/var/www/extplorer# cd scripts
    root@openmediavault:/var/www/extplorer/scripts# dir
    application.js.php  editarea  extjs3-ext        index.html
    archive.js.php      extjs3    functions.js.php  yui
    root@openmediavault:/var/www/extplorer/scripts#


    I deleted these files with

    Code
    rm -rf extplorer

    in the directory var/www/


    after that I did a shutdown and restarted - extplorer was not listed as "installed" anymore.
    So I startet a install from webgui:


    But after that explorer shows me still a "404 Not found".


    Back to your questions:

    Quote

    the extplorer user is there ?
    is the user fore extplorer sanctiond to use the system ?


    I opened ARM / Users and have only four users that I did add there.
    There is no user with name: "openmediavault"


    I did not find out how to allow/disallow/sanction a user to use extplorer


    Quote

    in the meantime you can check this site out bugtracker.openmediavault.org/view.php?id=329 or this one revpol.com/xymon_nut_scripts


    Ok I checked the first site, and tried to navigate through CLI to /usr/share/openmediavault/scripts/collectd.d/nut but within the scripts directory there is no collectd.d folder...
    (And at the moment I do have no idea how to copy files from outside to that place, sorry)

    Scissors cuts paper, paper covers rock, rock crushes lizard, lizard poisons Spock, Spock smashes scissors, scissors decapitates lizard, lizard eats paper, paper disproves Spock, Spock vaporizes rock, and as it always has, rock crushes scissors.

    Edited 4 times, last by Parador ().

  • is the user fore extplorer sanctiond to use the system ?


    the user fore explorer is explorer if you go to tab users there is a listing of all users that can use the system there needs to be a user named extplorer in it with the rights user.


    Quote

    (And at the moment I do have no idea how to copy files from outside to that place, sorry)


    this you can do in ssl. in the second www you can find more on how to configure nut.


    Quote

    Reloading web server config: apache2 not running.


    this can be a problem i dont know exactly al have to check it out

    gr. steel


    Cooler Master CM 690 III with 650 watt 80+ gold power supply
    AMD A8-5600k processor
    8 GB ddr 3 1333 ram
    crusial 120 ssd
    5 x 2 TB WesternDigital red harddrive in raid 5
    2 intel 1000mT nic's
    latest OMV stone burner

    lets get cooking .....
    don't be afraid of learning it can be fun

  • @steel2400:
    I added a user for extplorer

    that did not help...



    @subzero79:

    Code
    root@openmediavault:~# ls -la /etc/nginx/openmediavault-webgui.d/
    insgesamt 12
    drwxr-xr-x 2 root root 4096 Sep 21 19:47 .
    drwxr-xr-x 6 root root 4096 Sep 21 19:46 ..
    -rw-r--r-- 1 root root  700 Sep 21 19:47 security.conf
    root@openmediavault:~#

    Scissors cuts paper, paper covers rock, rock crushes lizard, lizard poisons Spock, Spock smashes scissors, scissors decapitates lizard, lizard eats paper, paper disproves Spock, Spock vaporizes rock, and as it always has, rock crushes scissors.

  • The user extplorer is created with the plugin with no group, that's why you don't see him. Also his home folder is at /home.
    from your command I see you don't have the nginx config for extplorer.


    Delete that user, purge extplorer plugin, and install again. After install, If you still have the same Nginx error do the following in ssh


    omv-mkconf nginx extplorer, then restart nginx


    service nginx restart


    go back to the extplorer section in webUI and check if extplorer is there this time

  • 1. deleted man.added user
    2. purged extplorer


    3. installed extplorer


    4. tried to open extplorer

    Code
    404 Not Found
    nginx


    5. used putty to:

    Code
    root@openmediavault:~# omv-mkconf nginx extplorer
    root@openmediavault:~# service nginx restart
    Restarting nginx: nginx.
    root@openmediavault:~#


    6. tried to open extplorer
    still:

    Code
    404 Not Found
    nginx


    7. restarted system
    8. tried to open extplorer
    still:

    Code
    404 Not Found
    nginx


    Scissors cuts paper, paper covers rock, rock crushes lizard, lizard poisons Spock, Spock smashes scissors, scissors decapitates lizard, lizard eats paper, paper disproves Spock, Spock vaporizes rock, and as it always has, rock crushes scissors.

  • Here's that ID Ah4VMILp


    and I have less options:

    Scissors cuts paper, paper covers rock, rock crushes lizard, lizard poisons Spock, Spock smashes scissors, scissors decapitates lizard, lizard eats paper, paper disproves Spock, Spock vaporizes rock, and as it always has, rock crushes scissors.

  • Code
    sed -i -r 's/squeeze(-lts)?/wheezy/g' /etc/apt/sources.list
    sed -i -r 's/squeeze(-lts)?/wheezy/g' /etc/apt/sources.list.d/*


    Then apt-get update && apt-get dist-upgrade


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • thanks for the help guys :thumbup:

    gr. steel


    Cooler Master CM 690 III with 650 watt 80+ gold power supply
    AMD A8-5600k processor
    8 GB ddr 3 1333 ram
    crusial 120 ssd
    5 x 2 TB WesternDigital red harddrive in raid 5
    2 intel 1000mT nic's
    latest OMV stone burner

    lets get cooking .....
    don't be afraid of learning it can be fun

  • Hi davidh2k, subzero79 and steel2400,


    thanks for your help!! I did as told :


    After that, I logged in @WebGui and started a restart..
    and got that error message after clicking on details while restart was processed :

    HTML
    <html>
    <head><title>502 Bad Gateway</title></head>
    <body bgcolor="white">
    <center><h1>502 Bad Gateway</h1></center>
    <hr><center>nginx</center>
    </body>
    </html>


    After restart, I have still the "not found error" with extplorer


    Thought It might be helpful to upload a new log:
    The ID is: e2IVcF4R


    Again: Thanks for your help!!!

    Scissors cuts paper, paper covers rock, rock crushes lizard, lizard poisons Spock, Spock smashes scissors, scissors decapitates lizard, lizard eats paper, paper disproves Spock, Spock vaporizes rock, and as it always has, rock crushes scissors.

    Edited once, last by Parador ().

  • Forgot to change old extras repos


    sed -i -r 's/sardaukar?/kralizec/g' /etc/apt/sources.list.d/*.list


    Then rename files repos


    find /etc/apt/sources.list.d/* -name *sardaukar* -exec rename s/sardaukar/kralizec/ {} \; then,


    apt-get update && apt-get dist-upgrade

  • Now I get another output: (too long)


    AND YEAHHH!!! Extplorer opens !! Great Thank you....

    Scissors cuts paper, paper covers rock, rock crushes lizard, lizard poisons Spock, Spock smashes scissors, scissors decapitates lizard, lizard eats paper, paper disproves Spock, Spock vaporizes rock, and as it always has, rock crushes scissors.

  • Everything better !!!


    Extplorer is back AND
    NUT Graphs show up !!!



    Thanks for all your help !!!


    Not that I understood most of that what you have done... but if I'm right the update was not completly correct and some old things remained / were not updated and omv tried to get things for the old 0.5 version..
    After that last action - omv knows that it was updated and fetches only the new things...


    It seems solved - should I mark that post as solved, or do you think there is something left to do?

    Scissors cuts paper, paper covers rock, rock crushes lizard, lizard poisons Spock, Spock smashes scissors, scissors decapitates lizard, lizard eats paper, paper disproves Spock, Spock vaporizes rock, and as it always has, rock crushes scissors.

    Edited 2 times, last by Parador ().

  • If it works for you then mark it as solved.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!