Ps3netsrv und OpenMediaVault

  • Hallo zusammen
    Auf dem Linux gebiet bin ich NEU habe sonst immer Windows Benutz!
    Ich möchte auf meinen nas ps3netsrv installieren kann mir jemand dabei helfen
    die ps3netsrv datei liegt auf dem nas im ordner tmp
    Lg sc2

  • genau! ps3netsrv stellt auf meinen nas die games ISOs für die ps3 zu verfügung.


    ich muss erstmal das programm ps3netsrv auf dem nas installieren
    leider weis ich nicht mit welchen befehl

  • Die datei bekommt man zb bei psx-tools aber auch auf anderen seiten wo es um ps3 geht.. leider sind die alle auf englisch da mein englisch und linux kenntnisse nicht so gut sind.. hilft mir das nicht viel weiter.. LEIDER...
    ich habe gestern mehrer seite durch geknappert.. lese immer das es schon fertig für QNAP, Synology DS und rasparypie fertig compiliert ist...
    vllt hast du etwas zeit und wir versuchen es per teamviewer...?


    Ps: Die datei ist im Dateianhang!


    gruß sc2

  • ich hab mal was zusammengebaut:
    OMV-ps3netsrv.zip
    du lädst die Datei in irgendein verzeichnis auf deinen Server und führst die Befehle auf der Kommandozeile des Servers aus:
    entpacken des ZIP

    Code
    unzip OMV-ps3netsrv.zip -d /


    Dateien ausführbar machen

    Code
    chmod +x /usr/local/bin/ps3netsrv*


    Code
    chmod +x /etc/init.d/ps3netsrv


    anpassen des start-scripts:

    Code
    nano /etc/init.d/ps3netsrv


    hier passt du die Pfade (DAEMON_OPTS) und deine Architektur 32/64bit (DAEMON) an


    Ctrl+O zum speichern und Ctrl+X zum beenden
    jetzt sollte der Server mit /etc/init.d/ps3netsrv start anlaufen. Mit /etc/init.d/ps3netsrv stop kannst du ihn wieder anhalten. Beim nächsten Boot des Servers sollte ps3netsrv automatisch mit starten.


    Wenn was nicht geht, bitte mit genauer Fehlerbeschreibung hier rein. Ich habe keine PS3 so dass ich mit dem Programm nicht weiterhelfen kann, ich hab nur die Startroutine gebaut. Wenn alles so läuft, baut Aaron oder Tekk vielleicht eine GUI dazu, sind ja nicht viele Optionen.

  • ich bekomme auch schon die erste fehler meldung


    root@nas:~# chmod +x /usr/local/bin/ps3netsrv*
    chmod: Zugriff auf „/usr/local/bin/ps3netsrv*“ nicht möglich: Datei oder Verzeichnis nicht gefunden
    root@nas:~# chmod +x /usr/local/bin/ps3netsrv
    chmod: Zugriff auf „/usr/local/bin/ps3netsrv“ nicht möglich: Datei oder Verzeichnis nicht gefunden
    root@nas:~#


    Verzeichnis konnte ich erstellen


    root@nas:/tmp# unzip OMV-ps3netsrv.zip
    Archive: OMV-ps3netsrv.zip
    creating: usr/
    creating: usr/local/
    creating: usr/local/bin/
    inflating: usr/local/bin/ps3netsrv_64
    inflating: usr/local/bin/ps3netsrv_32
    creating: etc/
    extracting: etc/.zip
    creating: etc/init.d/
    inflating: etc/init.d/ps3netsrv



    hab mal eben im eXtplorer nachgeschaut.. das verzeichnis gibt es garnicht )-:


    ist das normal??


    root@nas:/usr# cd /local
    -bash: cd: /local: Datei oder Verzeichnis nicht gefunden
    root@nas:/usr#


    vllt hilft das auch noch


    root@nas:/etc/init.d# dir
    acpid minidlna reboot
    alsa-utils monit resolvconf
    anacron motd rmnologin
    autoshutdown mountall-bootclean.sh rpcbind
    avahi-daemon mountall.sh rrdcached
    bootlogd mountdevsubfs.sh rsync
    bootlogs mountkernfs.sh rsyslog
    bootmisc.sh mountnfs-bootclean.sh samba
    checkfs.sh mountnfs.sh sendsigs
    checkroot-bootclean.sh mtab.sh shairport
    checkroot.sh networking single
    clamav-daemon nfs-common skeleton
    clamav-freshclam nfs-kernel-server smartd
    collectd nginx smartmontools
    console-setup ntp snmpd
    cpufrequtils nut-client ssh
    cron nut-server stop-bootlogd
    dbus openmediavault stop-bootlogd-single
    halt openmediavault-beep sudo
    hdparm openmediavault-engined sysstat
    hostname.sh php5-fpm tftpd-hpa
    hwclock.sh plexmediaserver udev
    jdownloader plexmediaserver.dpkg-bak udev-mtab
    keyboard-setup postfix umountfs
    killprocs procps umountnfs.sh
    kmod proftpd umountroot
    loadcpufreq quota ups-monitor
    lvm2 quotarpc urandom
    mdadm rc watchdog
    mdadm-raid rc.local wd_keepalive
    mdadm-waitidle rcS x11-common
    mediabrowser README
    root@nas:/etc/init.d#


    auch hier sehe ich kein erstelltes verzeichnis

  • Du hast den slash (schrägstrich) beim entpacken vergessen. Schau nochmal genau den Befehl an. Dann sollte es gehen
    Edit:
    und:

    Code
    root@nas:/usr# cd /local
    -bash: cd: /local: Datei oder Verzeichnis nicht gefunden
    root@nas:/usr#


    ist normal, weil es kein Verzeichnis /local gibt, sondern nur /usr/local. Wenn du bereits im Verzeichnis /usr bist, musst du cd local/ eingeben. /local sucht im Wurzelverzeichnis / nach local.

  • das mit den slash hatte ich gestern auch schon ausprobiert.... bekomme immer diese fehler meldung


    root@nas:/tmp# unzip OMV-ps3netsrv.zip /
    Archive: OMV-ps3netsrv.zip
    caution: filename not matched: /


    auch wenn ich den slash nach dem .zip gleich schreibe bekomme ich das hier


    root@nas:/tmp# unzip OMV-ps3netsrv.zip/
    unzip: cannot find or open OMV-ps3netsrv.zip/, OMV-ps3netsrv.zip/.zip or OMV-ps3netsrv.zip/.ZIP.
    root@nas:/tmp#


    hat das vllt was zutun das ich die zip datei in den ordner tmp kopiert habe?
    habe grad mal versucht die datei (OMV-ps3netsrv.zip) in andere ordner zu uploaden leider ohne erfolg! bekomme immer diese meldung "OMV-ps3netsrv.zip : Datei hochladen fehlgeschlagen."
    ich benutze eXtplorer!


    edit:
    wenn ich das zeichen slash weg lasse dann entpackt er mir die zip datei in den ordner /tmp ... kann aber von dort aus die datein nicht in einen anderen ordner kopieren.

  • @Solo0815 vielen Dank!!!! :D:thumbsup::thumbsup::thumbsup::D
    Die installation hat geklappt, starten tut das programm auch! "ist bei den Prozsessen aufgelistet"


    jetzt muss ich noch den pfad anpassen und schauen ob es klappt!


    Leider klappt das mit dem Autostart noch nicht also wenn der nas startet startet das programm nicht automatisch mit!
    wo könnte der fehler liegen... ?(


    DAEMON=/usr/local/bin/ps3netsrv_64 <--- stand so von anfang an drin.. denke das das auch so passt


    hab nochmal im eXtplorer geschaut beide files haben komplette rechte


    /usr/local/bin/ps3netsrv chmod 755
    und
    /etc/init.d/ps3netsrv chmod 755


    gruß sc2

  • ^^^ :D


    @ sc2:
    Na das ist ja schon mal ein Erfolg
    schau mal ins Log, da müsste drinstehen, warum der Dienst nicht startet.
    grep ps3netsrv /var/log/syslog
    und poste mal bitte die beiden einträge hier, die du geändert hast.
    Danke

  • root@nas:~# grep ps3netsrv /var/log/syslog
    Dec 1 19:50:58 nas /etc/init.d/ps3netsrv: ps3netsrv starting ...
    Dec 1 19:50:58 nas /etc/init.d/ps3netsrv: ps3netsrv started successful!
    Dec 1 19:56:01 nas /etc/init.d/ps3netsrv: ps3netsrv starting ...
    Dec 1 19:56:01 nas /etc/init.d/ps3netsrv: ps3netsrv started successful!
    root@nas:~# /etc/init.d/ps3netsrv start
    ps3netsrv starting.
    .
    root@nas:~# grep ps3netsrv /var/log/syslog
    Dec 1 19:50:58 nas /etc/init.d/ps3netsrv: ps3netsrv starting ...
    Dec 1 19:50:58 nas /etc/init.d/ps3netsrv: ps3netsrv started successful!
    Dec 1 19:56:01 nas /etc/init.d/ps3netsrv: ps3netsrv starting ...
    Dec 1 19:56:01 nas /etc/init.d/ps3netsrv: ps3netsrv started successful!
    Dec 1 22:09:57 nas /etc/init.d/ps3netsrv: ps3netsrv starting ...
    Dec 1 22:09:57 nas /etc/init.d/ps3netsrv: ps3netsrv started successful!
    root@nas:~#


    # This is the command to be run, give the full pathname
    # 64bit: /usr/local/bin/ps3netsrv_64
    # 32bit: /usr/local/bin/ps3netsrv_32
    DAEMON=/usr/local/bin/ps3netsrv_64


    # Add the ps3netsrv path here, port and whitelist are optional
    # rootdirectory [port] [whitelist]
    # Default port: 38008
    # Whitelist: x.x.x.x, where x is 0-255 or * (e.g 192.168.1.* to allow only conn$
    DAEMON_OPTS="/data/ps3/"


    Die beiden einträge die ich posten sollte hab ich rot makiert.. meintest du die beiden?

  • passt soweit alles.
    1. Der Dienst läuft wirklich nicht?
    Boote mal bitte neu und poste bitte die Ausgabe von ps -ef | grep ps3netsrv


    2. Deine ISOs liegen in /data/ps3?
    Du kannst deine ISOs mit
    cd /data/ps3 und ls -l (beides mal "kleines L") anzeigen?


    MEMO: Falls jemand ein Plugin dafür macht, hier die Source: https://github.com/dirkvdb/ps3netsrv--

  • zu 1.
    root@nas:~# ps -ef I grep ps3netsrv
    error: unsupported option (BSD syntax)


    Usage:
    ps [options]


    Try 'ps --help <simple|list|output|threads|misc|all>'
    or 'ps --help <s|l|o|t|m|a>'
    for additional help text.


    For more details see ps(1).
    root@nas:~#


    root markiert ist ein großes i ob das richtig ist?


    zu 2.
    Richtig meine ISOs liegen in /data/ps3/ PS2ISO,PS3ISO,PSXISO,BDISO,GAMES........


    cd /data/ps3 und ls -l (beides mal "kleines L")
    hab den befehl nicht richtig hinbekommen


    root@nas:~# cd /data/ps3
    -bash: cd: /data/ps3: Datei oder Verzeichnis nicht gefunden
    root@nas:~# cd /data/ps3 ls
    -bash: cd: /data/ps3: Datei oder Verzeichnis nicht gefunden
    root@nas:~# cd /data/ps3 -l
    -bash: cd: /data/ps3: Datei oder Verzeichnis nicht gefunden
    root@nas:~# cd /data/ps3 ls -l
    -bash: cd: /data/ps3: Datei oder Verzeichnis nicht gefunden
    root@nas:~#

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!