HP N54L - NIC Stuck at 100mbps

  • Hello everyone,

    Thanks in advance for any knowledge that you can part with. I have Googled pretty heavily and tried all methods to fix this NIC issue but with no luck. As the subject line says my NIC in my N54L Microserver is stuck at 100mbps. The N54L is plugged directly in my Gigbit ASUS router and then another port links to a unmanaged 16 port netgear switch. I have replaced cables, replaced router, installed backport kernel and also tried "autoneg off speed 1000 duplex full" install extra params in the network section.


    Here is a paste from the 'system information' tab in the GUI. This is getting pretty frustrating as the server has not been able to work fast enough for my daily work!



    Any help you can give would be much appreciated.



    Code
    ================================================================================= OS/Debian information================================================================================Distributor ID: debianDescription: Debian GNU/Linux 7 (wheezy)Release: 7.7Codename: wheezy================================================================================= OpenMediaVault information================================================================================Release: 1.6Codename: Kralizec================================================================================= Date================================================================================Tuesday 16 December 23:33:42 AEDT 2014================================================================================= Locale================================================================================en_AU.UTF-8================================================================================= System information================================================================================Linux openmediavault 3.16.0-0.bpo.4-amd64 #1 SMP Debian 3.16.7-ckt2-1~bpo70+1 (2014-12-08) x86_64 GNU/Linux================================================================================= Uptime================================================================================ 23:33:42 up 2 min, 0 users, load average: 0.35, 0.09, 0.03================================================================================= Network interfaces================================================================================1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000 link/ether c8:cb:b8:c5:38:ea brd ff:ff:ff:ff:ff:ff inet 192.168.1.168/24 brd 192.168.1.255 scope global eth0 valid_lft forever preferred_lft forever--------------------------------------------------------------------------------Interface information eth0:===========================Settings for eth0: Supported ports: [ TP ] Supported link modes: 10baseT/Half 10baseT/Full 100baseT/Half 100baseT/Full 1000baseT/Half 1000baseT/Full Supported pause frame use: No Supports auto-negotiation: Yes Advertised link modes: 10baseT/Half 10baseT/Full 100baseT/Half 100baseT/Full 1000baseT/Half 1000baseT/Full Advertised pause frame use: Symmetric Advertised auto-negotiation: Yes Link partner advertised link modes: 10baseT/Half 10baseT/Full 100baseT/Half 100baseT/Full Link partner advertised pause frame use: Symmetric Receive-only Link partner advertised auto-negotiation: Yes Speed: 100Mb/s Duplex: Full Port: Twisted Pair PHYAD: 1 Transceiver: internal Auto-negotiation: on MDI-X: on Supports Wake-on: g Wake-on: g Current message level: 0x000000ff (255) drv probe link timer ifdown ifup rx_err tx_err Link detected: yes--------------------------------------------------------------------------------Driver information eth0:========================driver: tg3version: 3.137firmware-version: 5723-v3.35bus-info: 0000:02:00.0supports-statistics: yessupports-test: yessupports-eeprom-access: yessupports-register-dump: yessupports-priv-flags: no

  • Have you checked physical matters? Tried another Router-Port? Pluged in directly to the switch? Other networkcabel?



    I have another driver, do you use backports kernel?

    | HP Microserver N54L | 8GB RAM (ECC) | BIOS-Mod | 6 Disks - 40GB Intel SSD (Erasmus), 40GB Intel SSD (VMStore), 2TB Seagate NAS HDD (Data), 2TB WD Red (DataBackup), 6TB WD Red (Rec), 6TB WD Red (RecBackup) | Delock PCI-E USB 3.0 (Art. 89315) | deleyCON Dual DS 2x USB 3.0, 1x 2,5" & 1x 3,5" HDD | APC Back-UPS ES 700G | rsync to remote site | NFS | SMB/CIFS | SSH | omv-extras.org - VirtualBox |

  • Quote

    Link partner advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full


    That's the point. To which device is eth0 connected? Are you sure that this netgear thingy is gigabit capable, which model?

    Homebox: Bitfenix Prodigy Case, ASUS E45M1-I DELUXE ITX, 8GB RAM, 5x 4TB HGST Raid-5 Data, 1x 320GB 2,5" WD Bootdrive via eSATA from the backside
    Companybox 1: Standard Midi-Tower, Intel S3420 MoBo, Xeon 3450 CPU, 16GB RAM, 5x 2TB Seagate Data, 1x 80GB Samsung Bootdrive - testing for iSCSI to ESXi-Hosts
    Companybox 2: 19" Rackservercase 4HE, Intel S975XBX2 MoBo, C2D@2200MHz, 8GB RAM, HP P212 Raidcontroller, 4x 1TB WD Raid-0 Data, 80GB Samsung Bootdrive, Intel 1000Pro DualPort (Bonded in a VLAN) - Temp-NFS-storage for ESXi-Hosts

  • Greeting from Melbourne, Australia and thanks for all the replies.


    @nachtmensch - I have tried all that you have mentioned. Replaced cable, different router port and connected directly to the switch all with the same result. I am also running the back ports kernel. What is this other driver you have?


    @subzero79 - Router model is ASUS DSL-AC68U. Pretty serious gear and definitely Gigabit ports.


    @datadigger- eth0 is connected directly to port 2 on the ASUS DSL-AC68U.


    @WastlJ - I thought about purchasing an PCIe Intel NIC but that will set me back $50 which isn't much but I'd rather get the built in NIC working. This N54l is only 2 years old!



    The NIC used to connect at 1000mbps when I was running a much earlier version of OMV. So the change just suddenly happened overnight. Do think the damaged NIC is more likely to be on the router or switch as opposed to the N54l? The status does say that the "Advertised Link Modes" can support 1000mbps, it's just the partner NIC doesn't reflect that...


    Is it possible to plug the N54l directly into the port of a PC running Windows 8.1 ? Is that feasible test? Mayhbe I could run an Ubuntu live stick and see what that shows..


    Any more thoughts?



    EDIT - Can anyone recommend the model number of a stable INTEL NIC?

  • Check energy saving settings in the router. It may drop to 100mbit die to energy saving settings.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • I don't use backports... maybe your "newer" driver is causing problems?

    | HP Microserver N54L | 8GB RAM (ECC) | BIOS-Mod | 6 Disks - 40GB Intel SSD (Erasmus), 40GB Intel SSD (VMStore), 2TB Seagate NAS HDD (Data), 2TB WD Red (DataBackup), 6TB WD Red (Rec), 6TB WD Red (RecBackup) | Delock PCI-E USB 3.0 (Art. 89315) | deleyCON Dual DS 2x USB 3.0, 1x 2,5" & 1x 3,5" HDD | APC Back-UPS ES 700G | rsync to remote site | NFS | SMB/CIFS | SSH | omv-extras.org - VirtualBox |

  • I have exactly the same on my N54L (100mb/s) - its not something I ever noticed before. I also need to investigate, can see that Im only getting 10mb/s through my tun0 interface which doesnt sound healthy. . .

  • My issue was the cable. bought a cat6a cable and straight to 1000mbps - my torrents are now flying. BTW, I googled my other issue which was the tun0 speed showing as 10mbps. This is standard apparently, its a 'placeholder' as the local machine cannot obviously know the true speed of the VPN to which its connected.

  • I have an AP-105 that will not connect at 1GB, only 100/Full. I've reset the AP and even factory defaulted it. I tried to force an Ethernet 0 Profile on it as well, but nothing. I've tried with POE switch, injectork, and DC power, and different 1GB switches/ports. Is there an evnvironment variable I am missing? ShowBox Kodi Lucky Patcher

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!