openmediavault-domoticz plugin (TESTING v1.0.1)

  • But it's not recognized by OMV or/and the systemd correctly. There's a red indicator in dashboard. And the service is inactive:

    I will have to look at it. I don't use domoticz myself so I may not be able to fix some things.

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Since the last Domoticz-Stable-Update from 3.5877 to 3.8153 (released 30.07.17) Domoticz works without probl

    I just updated the domoticz package in the omv-extras repo and it works. You should install this to get the latest systemd unit file.

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

    Edited once, last by ryecoaaron ().

  • PERFECT!!! Everything works fine again! Thank's a lot!! :):thumbsup::thumbup:



    EDIT:


    No, it doesn't.... There was shown no update in OMV. So i deinstalled the Domoticz-Plugin and installed new.
    Then it works - BUT the Domoticz-Version ist the old one 3.5877. Then i've done a domoticz-update to 3.8153 and it's the same problem.......


    Can you post the new systemd-file manually here? :)

  • domoticz-update

    I wouldn't do this. The plugin may not work with the changes.


    Can you post the new systemd-file manually here?

    I could but that is avoiding the problem. Lets try to fix it the right way first. The testing repo in omv-extras needs to be enabled. What is the output of: apt-cache policy domoticz

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • What is the output of: apt-cache policy domoticz

    Code
    domoticz:
    Installiert: 3.5877
    Installationskandidat: 3.5877
    Versionstabelle:
    *** 3.5877 0
    500 https://dl.bintray.com/openmediavault-plugin-developers/erasmus-testing/ jessie/main amd64 Packages
    100 /var/lib/dpkg/status

    The new domoticz stable version isn't recognised here...

  • Run omv-aptclean and then post apt-cache policy domoticz again

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Done. Exactly the same...


  • Done. Exactly the same...

    Sorry, I forgot to upload the amd64 package. I only uploaded the armhf version. Fixed now.

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Nice tot see ryecoaaron
    I am still using domoticZ.
    By now on a raspberry but i have plans to setup a second one on omv


    Verstuurd vanaf mijn XT1562 met Tapatalk

    ---------------------------------------------
    My HP T610 thin client NAS
    ---------------------------------------------
    ---------------------------------------------
    My Thin Client single drive NAS build
    ---------------------------------------------
    -----------------------------------------------------
    I'm from the Netherlands, excuse me for bad english
    -----------------------------------------------------------------

  • Hello,


    I installed the pluggin after update to OMV 3.1.8.


    After enabling the pluggin, I get the error :
    "Failed to connect to socket: Connection refused", and I can't enter the GUI.


    Any clue what is going on ?


    Here is the detailed error :






    Thanks for your help !!!!

  • The plugin works fine with the domoticz stable 3.8153.


    Are you sure you've choosen the right plugin? Have you installed the stable or beta relaese of domoticz?
    When have you done the update of OMV? Have you installed the plugin before?

  • I downloaded the file with link on first page of this thread.
    I loaded it into omv, and installed.
    I enabled Domoticz service.


    => from then omv does what's described above.


    Everything seems to works apart from GUI login (any user including admin) => Samba service is OK, Plex server is OK ...

  • Hello,


    I took some time to look into this.


    So I see there is an issue with domoticz install as the command omv-engined -f -dreturns this in the end :
    PHP Fatal error: require_once(): Failed opening required 'openmediavault/error.inc' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/share/openmediavault/engined/rpc/domoticz.inc on line 23



    But then... I can only face my ignorance. What can I do with this ?


    can you guys help me find a link to a similar problem in order to sort me out ?


    Thanks.
    G

  • Sounds like you have a mismatched version of OMV and the plugin. What is the output of: dpkg -l | grep openm

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hello, thank you for your help.


    The output is :

    Code
    ii openmediavault 3.0.98 all Open network attached storage solution
    ii openmediavault-domoticz 1.0.1 all Domoticz plugin for OpenMediaVault.
    ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
    ii openmediavault-omvextrasorg 3.4.29 all OMV-Extras.org Package Repositories for OpenMediaVault
    ii openmediavault-plexmediaserver 3.8.2 all OpenMediaVault Plex Media Server plugin
  • That is definitely the problem. You have a very old version of the plugin. Not even sure where you got it. I would uninstall it with apt-get purge openmediavault-domoticz then enable the omv-extras testing repo. Then you should be able to install the 3.0 version from the repo.

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • That did the trick.


    Thanks.


    I actually thought the link in the first post of this thread was kept up to date to the last version of the pluggin.


    This is what I used to install it.


    I did not install the last revision from the extras repo yet, since I installed Domoticz on a Raspberry I had available in the meantime. However, I regained access to my omv web interface.


    Not sure what will be my next move, yet.


    Thanks a lot.


    G.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!