Owncloud 8 and MySQL: alternative approach

  • Is there a way to connect without put in the port number such as abc.mydomain.com:8443 ?


    Think this is possible if you change the OC ports to 80 and/or 443.
    But therefore you'll have to change the OMV ports first.
    Other possibilty would be a proxy or port-forwarding on your router.
    That depends on your setup.

  • So you saying, if I use https port 443 for OMV, then I need to change https port 443 for OC too?
    Wouldn't this be conflict?
    I'm currently port forward 7443 to OMV, & 8443 to OC.

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

  • @tinh_x7 thanks for your answer, but what must i do exactly? :/

    omv 5.x | 64 bit | omvextrasorg 5.x | kernel 5.4
    used plugins: omv-extras | portainer | rsnapshot | antivirus
    used container: portainer/portainer | linuxserver/nextcloud | linuxserver/letsencrypt | linuxserver/mariadb | jellyfin/jellyfin | doliana/logitech-media-server | v2tec/watchtower | instrumentisto/coturn

  • @happyreacher,


    According to owncloud document, if we remove the line env [PATH] in /etc/php5/fpm/pool.d/www.conf, it should be fixed.
    Somehow it is not. I think I missed something else.



    Quote

    ;env[HOSTNAME] = $HOSTNAME
    ;env[PATH] = /usr/local/bin:/usr/bin:/bin
    ;env[TMP] = /tmp
    ;env[TMPDIR] = /tmp
    ;env[TEMP] = /tmp



    I'm back to square one w/the errors.

  • Yes, you have to give it a shared folder to store the database and you have to fill in the administrator password.
    The password ist needed in the OC setup script.
    OC then creates its database-files.


    So This is where i keep getting stuck.
    should i create another folder in www called mysql or can i select the owncloud folder i already created?
    Thanks for the guide.

  • @HackitZ,


    I been installed MySQL about ten times, and here are the solutions:


    1. dpkg -l |grep mysql


    2. write all the packages name down.


    3. apt-get --purge remove [package name]


    4. delete MySQL folder, & create a new mysql folder.


    5. reboot OMV.


    6. Re-install mySQL from apt-get.


    7. Good luck.

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

    Edited 6 times, last by tinh_x7 ().

  • @tinh_x7 i found a point to the php-fpm in the owncloud manuel:
    https://doc.owncloud.org/serve…guration-notes-to-php-fpm
    but i don't understand it
    perhaps a help in german is a litle bit easier for me :/

    omv 5.x | 64 bit | omvextrasorg 5.x | kernel 5.4
    used plugins: omv-extras | portainer | rsnapshot | antivirus
    used container: portainer/portainer | linuxserver/nextcloud | linuxserver/letsencrypt | linuxserver/mariadb | jellyfin/jellyfin | doliana/logitech-media-server | v2tec/watchtower | instrumentisto/coturn


  • Ok this worked thank you very much, i was able to get past the setup folder.
    Now I turned on ssl and it seems to load but the page is blank nothing seems to load, page is all white?
    I did go into config.php and add my dns name and it's in my ssl cert as well.
    after a restart if i run vi or nano config.php it's empty. even the config.sample.php is empty.
    not sure what i did, can someone share a working copy of there config.php and maybe i can copy it into mine.


    Ok i was able to get the config.php back, not sure what worked as i tried restarting the system and then restarting a lot of services. in the end i think stopping oc plugins with terminal did the trick. but it's blank after another reboot.
    here is the error in nginx log

    Code
    2015/07/14 22:25:23 [error] 2309#0: *39 FastCGI sent in stderr: "PHP message: PHP Parse error: syntax error, unexpected 'datadirectory' (T_STRING), expecting ')' in /media/b980b57f-07d5-41ff-8d7f-bf93f3f1adea/www/owncloud/config/config.php on line 11" while reading response header from upstream, client: ::ffff:192.168.144.246, server: , request: "GET /index.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/fpm-825f187f-bdb4-438b-90a7-6889595d1e56.sock:", host: "192.168.144.101:90", referrer: "http://192.168.144.101:90/"
  • @HackitZ,


    Ensure the ports number you using in the gnix's server settings & the php.ini are the same.
    My php.ini look something like this:
    'trusted_domains' =>
    array (
    0 => '192.168.100.100',
    1 => 'mycloud.domain.com:9443',


    ),


    Ensure you port forward appropriate ports on your router to OMV and OC.
    By the way, if you're using this alternative approach, don't install the OC plugin from OMV.
    It may causing a mess.
    I only install OC plugin if I use Tekk's OC7 tutorial.


    @happyreacer,


    I posted my questions on the github, and thanksfully I got quick solutions from them.
    The solution to fix the array error is to disabled the app updater, and any other apps that are enabled.




    I still try to fix the getenv path & https header. I still don't understand the manual instructions.
    I tried out a few methods, but no result.
    I was about to give up on this OC, I spent too much time & headache on this OC v8.1.0.
    I currently don't have time to play w/ Pydio or SeaFile.


    For anybody that been through this pain like me, here's the questions that I posted on GitHub:https://github.com/owncloud/core/issues/17647

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

    Edited 5 times, last by tinh_x7 ().


  • Is that php.ini located at /etc/openmediavault/php.ini?
    I did a search and this one seems to be the logical place , i opened it in nano and looked through the 1856 lines and found nothing.
    Thanks

  • ok so now i'm at the unsafe page in chrome, i click proceed and get the ad as trusted domain. i cant seem to get past this page.


    here's a copy of my config.php


    My ngnix matches this.

  • Fixed



    here's a copy of my config.php


    sorted it out, removed the port numbers. so now it looks like this.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!