Owncloud 8 and MySQL: alternative approach

  • iOS app for OC isn't that great; it's buggy.


    I can't stream videos on mobile device either.
    Edit: Even though I used Google Chrome on my iPhone 5S, I still can't stream my music.

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

    Edited once, last by tinh_x7 ().

  • Yep, worked like a charm. Installed the whole thing with 8.0.1 two weeks ago (Took me a whole week, because the MySQL user didnt have access to its directory for some reason).


    The update to 8.1.1 now on the other hand didn't make any problems at all. It was literally just clicking "update" in the update section of the administration site.

  • Hi,


    I found that upgrading owncloud is like having an endless nightmare....


    After I upgrade to 8.1.1


    It gave me a few errors, which were solved thanks to the previous post of Enra (thank you once again, you are doing a fantastic work!):



    But it appears the following error:


    "This server has no working Internet connection. This means that some of the features like mounting external storage, notifications about updates or installation of third-party apps will not work. Accessing files remotely and sending of notification emails might not work, either. We suggest to enable Internet connection for this server if you want to have all features."


    I have an internet connection.....


    I looked for a solution, and the only thing I found was adding a line to config.php


    Code
    'has_internet_connection' => true,


    But it still didn't solve my problem...


    Any suggestions?


    Thanks.

  • Hi,


    I did an web update, and appeared 4 errors (3 of them were mentioned by you).
    The error appeared on the "Security & setup warnings", on administrator mode like the others.

  • @GabrielRR,


    The solutions are posted on the previous pages.


    Guys,


    Anybody in here know how to force owncloud to auto redirect http to https?
    I did some searches, and some users said need to make the change in httpd.conf while others said change it in /etc/apache2/sites-available.
    Do I need to change the port number if I'm not using the default ports?


    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

    Edited 2 times, last by tinh_x7 ().

  • @tinh_x7


    I was talking about the following error (my previous post):


    Quote

    This server has no working Internet connection. This means that some of the features like mounting external storage, notifications about updates or installation of third-party apps will not work. Accessing files remotely and sending of notification emails might not work, either. We suggest to enable Internet connection for this server if you want to have all features.


    Which is not explained at any place, including the owncloud's official site.


    Thanks.

  • I never have or heard this owncloud internet connection error before.


    Ensure you using the correct ports for OMV, and OC.
    And configure your router to port ward any customized port that you using for OMV, and OC.
    I suggest use port 80 as a default for OC HTTP.
    Re-read the tutorial and double check your Nginx settings in OMV web gui and other appropriate settings.


    If you're a beginner to Linux and OwnCloud, it may take you more than three attempts to get it to work perfectly!

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

    Edited once, last by tinh_x7 ().

  • ok guys, i finally got some time (whole weekend) to read this entire thread... so i finally reinstall my OC to 8.1.2 ... it sucks that you cannot turn off SSL for OC, coz im using vpn for my OC... ok, to the thing.


    i hope someone will finally reply to my question on this forum :)


    when i add 'memcache.local' => '\OC\Memcache\APC' to my config.php file, the oc stop working. i think issue is with that path '\OC\Memcache\APC' , the apc is installed on my OMV. can someone help me please?


    thanks


    Edit: ok, i dont know if guys that created this thread dont have time for answers, but i find it by my self...


    you must have installed php-apc and this lines must be in your apc config file
    /etc/php5/mods-available/apc.ini :


    extension=apc.so
    apc.enabled=1
    apc.enable_cli=1
    apc.shm_size=128M

    omv 5.6 in proxmox 6.3-6 - AMD Ryzen 1700 - 16GB DDR4 :thumbup:

    Edited once, last by Mio ().

  • I've installed OC 8.1.1 by following this thread. But I have a problem I can't solve. OC is runnig. I see the login-screen with URL http://x.x.x.x:90/index.php
    But after I've filled out name and password, I've got an error in webbrowser.
    => Chrome says: "SSL-Verbindungsfehler ERR_SSL_PROTOCOL_ERROR"
    URL is then: https://x.x.x.x:90/index.php/apps/files/
    => IE says: "Die Seite kann nicht angezeigt werden" (The site cannot display)
    URL is then: http://x.x.x.x:90/index.php
    => Edge says: "Leider können wir nicht auf diese Seite zugreifen." (near the same like IE)
    URL is then: http://x.x.x.x:90/index.php
    When I connect with OC-Client for windows, I can login cooret and see the files. But I cannot Setup new users etc.
    In the past, there was running an OC7-installation without any problems on the same machine. I've deleted this befor I've installed the new OC 8.1.1. But the self-signed SSL-certificate was the same and expired in 2025.
    Who can help me?

  • hi, i had same issue, you must add/enable in the plugin nginx/servers ssl, and disable ssl for omv in general tab.


    because oc 8.1.1 is by default set to ssl and you cannot disable it


    ... when you are using also ssl for omv, then change the oc ssl port...

  • ok, i guess on 2nd screen shot you are trying connect to you oc from internet... the oc try to say you that you must add your public address to your oc config.php file... the guide is here or on google how to add the ip to the trusted domains in your config file...


    when you are trying to connect to your oc in your local subnet, try

    Code
    https://YourOcLocalAddress/index.php


    do not use "ipAddres:443" the port 443 = https ... so use https, not ":443"


    also clear your cookies and history form your browser and begin again....

    omv 5.6 in proxmox 6.3-6 - AMD Ryzen 1700 - 16GB DDR4 :thumbup:

    Edited 2 times, last by Mio ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!