Owncloud 8 and MySQL: alternative approach

  • yes (I got the german ui).
    Dont use that since if you do its located befor the "location ~ ^/(?:index|remote|public|cron|core/ajax/update|status|ocs/v[12]|updater/.+|ocs-provider/.+|core/templates/40[34])\.php(?:$|/) {" and overwrites it (i guess? I actualy dont know much about nginx...)
    I found that out using nano in /etc/nginx/sites-enabled/zzz-omv-nginx (dont know if its a random name)

  • According to the settings, if we're using the $socket variable in the extra options, then that 'default config' should be enable to connect to the phpm-pool.


    By the way, you need to add these at the beginning of the vhost too:



    Have you try these?



    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

    Edited 4 times, last by tinh_x7 ().

  • According to the settings, if we're using the $socket variable in the extra options, then that 'default config' should be enable to connect to the phpm-pool.

    we only need to enable php to use $socket not the default config:


    No I removed the security headers since I thought if I dont use ssl I dont need them


    Edit: At line 48 in my original config we connect to the pool manualy.


    Edit2: I added the headers to my original post

  • I just tested, it's working great.
    I just notice that the performance is faster with these NC Nginx codes compare to the old OwnCloud Nginx codes :)


    But you need to un-comment the security header at the beginning, and near the end like this:


    Code
    add_header Strict-Transport-Security "max-age=15768000;
    includeSubDomains; preload;";

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

    Edited once, last by tinh_x7 ().

  • I have an issue since i Updated to owncloud 10.0.2. When I try to write to a shared calendar on the shared account, i get an 404 error with davdroid and based on my google search:
    https://github.com/nextcloud/server/issues/2649
    https://github.com/nextcloud/server/issues/2747
    https://forums.bitfire.at/topi…wncloud-9-upgrade-issue/4


    I think the well-known addresses are now incorrect with nextcloud 11 and nextcloud 10.0.2 (should redirect to dav instead of carddav/ or caldav/ right?)


    Can anyone tell me how to fix this? Shall i just replace line 13 and 14 with:


    Code
    #rewrite ^/.well-known/carddav /remote.php/carddav/ redirect;
    #rewrite ^/.well-known/caldav /remote.php/caldav/ redirect;
    rewrite ^/.well-known/carddav /remote.php/dav/ redirect;
    rewrite ^/.well-known/caldav /remote.php/dav/ redirect;

    or do i need to change something else? I am afraid i might break something else!


    When i verified the fix, i think the first post should be updated!

  • I tried it and verified the bugfix! with dav instead of carddav and calddav it works perfectly! To fix it, just edit your nginx config and comment old lines (or delete) and include new lines:


    Code
    #rewrite ^/.well-known/carddav /remote.php/carddav/ redirect;
    #rewrite ^/.well-known/caldav /remote.php/caldav/ redirect;
    rewrite ^/.well-known/carddav /remote.php/dav/ redirect;
    rewrite ^/.well-known/caldav /remote.php/dav/ redirect;


    Enra: --> can you please edit it in the first post to help others?
    edit: thank you enra for the update!

  • According to Nextcloud doc, it's supposed to be like this:


    Code
    location = /.well-known/carddav {
    return 301 $scheme://$host/remote.php/dav;
    }
    location = /.well-known/caldav {
    return 301 $scheme://$host/remote.php/dav;
    }

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

  • Hello,


    i have a problem with the mysql database. Netxcloud could not create a new database. I can connect with the root password to the webgui form the mysql server. Any idea- Thanks a loot

    OMV 3.0.59

    Edited once, last by rakau ().

  • on first, create a database and a datauser with rights for the database in mysql. Then make your nextcloud instalation with the database databaseuser and his password.

    omv 5.x | 64 bit | omvextrasorg 5.x | kernel 5.4
    used plugins: omv-extras | portainer | rsnapshot | antivirus
    used container: portainer/portainer | linuxserver/nextcloud | linuxserver/letsencrypt | linuxserver/mariadb | jellyfin/jellyfin | doliana/logitech-media-server | v2tec/watchtower | instrumentisto/coturn

  • thank you for your answer, I did so. Now I get new message in the nginx log file:


    Page


    of 1
    1 - 1 von 1 angezeigt
    2017/01/25 15:59:09 [error] 30547#0: *870 access forbidden by rule, client: 192.168.3.2, server: , request: "GET /data/htaccesstest.txt HTTP/1.1", host: "192.168.3.2:90"


    In the nextcloud documentation they write about these configuration section :


    location = /data/htaccesstest.txt { allow all; log_not_found off; access_log off;}i will see...

  • Hello all!


    Giving up for tonight...
    Followed the guide from post #1 + the config from @Zocker1996 on #499 (ssl: on). I can only reach the setup.php if I enable php default config in nginx.
    I can start the setup, dependencies met, then I get a 502 gateway timeout, then I refresh the browser and get this:



    If click "Next" I get a 404... end of story. If I go to nextcloud dir via ftp it is empty???


    Any help welcome


    Greets
    ra

    HP ProLiant MicroServer Gen8, Celeron G1610T, 4GB RAM
    OMV 3.0.59


    32GB SDcard System
    2x4TB WD Red Raid1
    1x2TB Seagate

  • I got the same error I first tried it. I'm not sure if I remember right but I thought I fixed this by not using the web installer script but the archive file from the nextcloud page. I then simpley extracted the zip where I otherwise would have placed the installer script.

  • Hi,


    I've made a new installation with OMV3 and installed Nextcloud11 via Nginx-Plugin (installed via OMV3-Extras) and NC's setup-script, following the instructions in Post#1 with the "additional settings" mentioned in Post#499 by Zocker1996...


    All worked fine, BUT:


    After the activation of Calendar, Notes, Contact and "Order" (the one to order the App-icons myself) Apps, I always get this error:


    400 Bad Request
    The plain HTTP request was sent to HTTPS port


    ...I'm using a selfsigned SSL-Certificate (created by OMV3) and installed via accessing the php-setupfile via https-connection, and a "custom-port" for SSL: 44390...


    I can reproduce this behaviour (I deleted the nc-installation (incl. mysql-db) and started all over again); everytime I do some "App-Action", I get above error and cannot login via https again... Strangely enough, when practicing in a VM-OMV-Installation, this error never occured...



    ...where do I start the troubleshooting?
    (maybe - has anyone encountered the same issue?)


    Edit:
    tryed playing with the "trusted domains" (by adding "ok URL") and overwrite-URL-Settings (to https://IP:44390) - but no effect...


    everytime I try to accesss nextcloud, the https: gets deleted from the URL; trying to connect to the OMV-Frontend, everything works...?


    Edit 2:


    After changing the trusted domain-entrys from IP:port to IP-only, I can access nextcloud via HTTP... But still having the Error 400 when trying with SSL...


    The nginx-config for nextcloud:


    ...?

    System:
    HP N54l - 4GB RAM - 64GB-SSD OMV, 2 x 1TB Seagate, 1 x 4TB WD Blue
    OMV 3.0.58 OMV-Extras 3

    Edited 2 times, last by sehnix ().

  • If you're using HTTPS, then change fastcgi_param HTTPS off; this to fastcgi_param HTTPS on;
    Another thing, since you installed NC on a /media/...., you don't need to add set $root_path "/media/THE-uuid/www/nextcloud"; in the vhost.

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

  • Thanks, the "HTTPS on"-part did the trick...


    But I need to set the root-path, as otherwhise I get an 404...?

    System:
    HP N54l - 4GB RAM - 64GB-SSD OMV, 2 x 1TB Seagate, 1 x 4TB WD Blue
    OMV 3.0.58 OMV-Extras 3

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!