Owncloud 8 and MySQL: alternative approach

  • here is my config.php file:



    and the netstat:

  • Hello Enra, enclosed here are the open ports and the OC-settings.
    I've changed the ssl-port to 8443, but the same error.




    I've changed the ip to x.x.x.x only.

  • Thank you Mio! It works! :-)
    I've changed the line 7-8 to my ip-adress (without port) and restart all. Now I can login correctly with IP-adress and https-URL.
    I'll try to add the pc-name to this area and I think the login should also works.


    :thumbsup::thumbup:

  • Like I said in my previous posts, @tinh_x7 I did an update and it occurred that error.


    When I did the first installation, and I followed the Enra's instructions, it worked perfectly! NO errors!
    By the way, Enra suggested use the port 90 instead 80, because is the port used by OMV, which I did!


    When I did the upgrade from 8.0 to 8.1.1 It occurred 4 errors three of them were corrected by the instructions given, once more, by Enra, and it worked. Once more, Thanks to Enra's Excellent job!


    The fourth error,

    Quote

    This server has no working Internet connection. This means that some of the features like mounting external storage, notifications about updates or installation of third-party apps will not work. Accessing files remotely and sending of notification emails might not work, either. We suggest to enable Internet connection for this server if you want to have all features.


    appears, BUT everything works, I can access from outside from my home, I can upload, I can share.... (until now I cant detect any error, for my common use....)


    And after looking for the same error in the web, it appears as a bug from this update! (see next link)


    https://github.com/owncloud/core/issues/17448


    If anyone know how to solve this....


    Thanks!

  • @GabrielRR - the solution is there in that link you posted here, try:



    Code
    @shibukk it's not so complicated as you think. What helped me was:
    copy "config/ca-bundle.crt" in the zip of the owncloud server download file
    put it in the "config/" directory of my owncloud instance (for me "/var/www/config" as absolute path)
    that's all, afterwards the warning was gone.
  • Are you guys using different IP for your OMV and OwnCloud or same IP with different ports?


    I am running OC on the same IP.
    But my OMV runs under 5000 and 5001 (old synology tradition :-))
    The reason is, that i wanted to run OC as a "name-based" server under 80 and 443.
    So I can run e.g. wordpress also on 80/443 in parallel.

  • so, today is the new update out for oc, and no success to update it:


    Code
    2015/09/18 10:14:12 [error] 4389#0: *128675 upstream timed out (110: Connection timed out) while reading response header from upstream, client: ::ffff:10.8.0.14, server: , request: "POST /index.php/apps/updater/ajax/download.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/fpm-95db7cc4-8a2e-4f20-a0d1-62056a6ea0c0.sock:", host: "192.168.1.80", referrer: "https://192.168.1.80/index.php/settings/admin"


    still the upstream timeout


    guys any sugestions pls?


    can someone whom is working the update app paste here his extras from nginx/server?


  • i add this 3 things to my configs, i disabled all the applications on my OC and still nothing, i still receive the damn nginx error:


    Code
    2015/09/22
    08:02:28 [error] 4511#0: *31881 upstream timed out (110: Connection
    timed out) while reading response header from upstream, client:
    ::ffff:10.8.0.14, server: , request: "POST
    /index.php/apps/updater/ajax/download.php HTTP/1.1", upstream:
    "fastcgi://unix:/var/run/fpm-95db7cc4-8a2e-4f20-a0d1-62056a6ea0c0.sock:",
    host: "192.168.1.80", referrer:
    "https://192.168.1.80/index.php/settings/admin"


    im adding picture here too.


    could someone paste here his extra options from php-pool and from nginx server? i will be wery thankful for that

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!