Some users only should have access to samba-shares, not to FTP

  • Hi there, I've got another problem.
    I have some users, which should only have access to samba shares, not over FTP. FTP and samba are using the same shares.
    Which exact syntax do I need for denying access to the ftp service? I tried this, but then I get the following error when applying:


    I think Im using the wrong syntax...
    http://www.proftpd.org/docs/di…linked/configuration.html


    Maybe there is another way to achieve my goal? Let me know. Thank you!

    OpenMediaVault 1.12 on Debian Wheezy 7.8 64bit | 3.16 Backport Kernel | OMV-Extras.org 1.10
    ASRock Q1900-ITX | 1x4GB Corsair Vengeance SODIMM DDR3 | 1xWD Red 3TB | 1xApacer 1,8" SATA1 SSD 32GB as system drive | be quiet! Pure Power L8 350W | SilverStone Milo ML04 Black

  • Where exactly do I allow the login? Sorry, I'm a little bit confused

    OpenMediaVault 1.12 on Debian Wheezy 7.8 64bit | 3.16 Backport Kernel | OMV-Extras.org 1.10
    ASRock Q1900-ITX | 1x4GB Corsair Vengeance SODIMM DDR3 | 1xWD Red 3TB | 1xApacer 1,8" SATA1 SSD 32GB as system drive | be quiet! Pure Power L8 350W | SilverStone Milo ML04 Black

  • This gives me the same error as above.

    OpenMediaVault 1.12 on Debian Wheezy 7.8 64bit | 3.16 Backport Kernel | OMV-Extras.org 1.10
    ASRock Q1900-ITX | 1x4GB Corsair Vengeance SODIMM DDR3 | 1xWD Red 3TB | 1xApacer 1,8" SATA1 SSD 32GB as system drive | be quiet! Pure Power L8 350W | SilverStone Milo ML04 Black

  • Hi,


    I had this same issue with OpenVPN and OpenVPNAS running both with the same user.
    I quit OpenVPN just to use OpenVPNAS. The two plugins are not working together.
    Verify that you do not have another instance of FTP or SMB somewhere that can be in cause of your problem.


    Greetings

    - ASROCK FM2A88X-ITX+ (SATAIII (6Gb/s) x6 (for the DATA), mSATA x1 (for the OS))
    - AMD A6 7400K 3.5GHz
    - Corsair 2Go DDR3 1333MHz C9 (x2)
    - Intel Corporation 82574L Gigabit Network Connection
    - COOLER MASTER G450M (80+ bronze)
    - WD Red 2To 64Mo 3.5" SATAIII (6Gb/s)
    - 32 Go SSD mSATA KingSpec Half-Size Solid State
    - Fractal Design Node 304 black (HDD 3.5" x6)
    - RAID 5 XFS
    - OMV 4.1.35-1 Arrakis

  • As far as I know, OMV automatically uses the same user login details for both services, when you are creating a new user. It's wanted to be like that by the dev I guess?


    Edit:

    OpenMediaVault 1.12 on Debian Wheezy 7.8 64bit | 3.16 Backport Kernel | OMV-Extras.org 1.10
    ASRock Q1900-ITX | 1x4GB Corsair Vengeance SODIMM DDR3 | 1xWD Red 3TB | 1xApacer 1,8" SATA1 SSD 32GB as system drive | be quiet! Pure Power L8 350W | SilverStone Milo ML04 Black

  • OpenMediaVault 1.12 on Debian Wheezy 7.8 64bit | 3.16 Backport Kernel | OMV-Extras.org 1.10
    ASRock Q1900-ITX | 1x4GB Corsair Vengeance SODIMM DDR3 | 1xWD Red 3TB | 1xApacer 1,8" SATA1 SSD 32GB as system drive | be quiet! Pure Power L8 350W | SilverStone Milo ML04 Black

  • FTP and Samba are protocols. There is nothing related to the creation of the users.
    Users are only allowed to use one or both services under a precise port for each protocol.

    - ASROCK FM2A88X-ITX+ (SATAIII (6Gb/s) x6 (for the DATA), mSATA x1 (for the OS))
    - AMD A6 7400K 3.5GHz
    - Corsair 2Go DDR3 1333MHz C9 (x2)
    - Intel Corporation 82574L Gigabit Network Connection
    - COOLER MASTER G450M (80+ bronze)
    - WD Red 2To 64Mo 3.5" SATAIII (6Gb/s)
    - 32 Go SSD mSATA KingSpec Half-Size Solid State
    - Fractal Design Node 304 black (HDD 3.5" x6)
    - RAID 5 XFS
    - OMV 4.1.35-1 Arrakis

  • I'm using the same shares for both services. Both services work with the same login details.

    OpenMediaVault 1.12 on Debian Wheezy 7.8 64bit | 3.16 Backport Kernel | OMV-Extras.org 1.10
    ASRock Q1900-ITX | 1x4GB Corsair Vengeance SODIMM DDR3 | 1xWD Red 3TB | 1xApacer 1,8" SATA1 SSD 32GB as system drive | be quiet! Pure Power L8 350W | SilverStone Milo ML04 Black

  • Is your user within the group "ftp" AND the group "smb" ?
    Verify your read/write properties on your shares.

    - ASROCK FM2A88X-ITX+ (SATAIII (6Gb/s) x6 (for the DATA), mSATA x1 (for the OS))
    - AMD A6 7400K 3.5GHz
    - Corsair 2Go DDR3 1333MHz C9 (x2)
    - Intel Corporation 82574L Gigabit Network Connection
    - COOLER MASTER G450M (80+ bronze)
    - WD Red 2To 64Mo 3.5" SATAIII (6Gb/s)
    - 32 Go SSD mSATA KingSpec Half-Size Solid State
    - Fractal Design Node 304 black (HDD 3.5" x6)
    - RAID 5 XFS
    - OMV 4.1.35-1 Arrakis

  • No, its just "users"

    OpenMediaVault 1.12 on Debian Wheezy 7.8 64bit | 3.16 Backport Kernel | OMV-Extras.org 1.10
    ASRock Q1900-ITX | 1x4GB Corsair Vengeance SODIMM DDR3 | 1xWD Red 3TB | 1xApacer 1,8" SATA1 SSD 32GB as system drive | be quiet! Pure Power L8 350W | SilverStone Milo ML04 Black

  • You may have a bit of answer lying there...

    - ASROCK FM2A88X-ITX+ (SATAIII (6Gb/s) x6 (for the DATA), mSATA x1 (for the OS))
    - AMD A6 7400K 3.5GHz
    - Corsair 2Go DDR3 1333MHz C9 (x2)
    - Intel Corporation 82574L Gigabit Network Connection
    - COOLER MASTER G450M (80+ bronze)
    - WD Red 2To 64Mo 3.5" SATAIII (6Gb/s)
    - 32 Go SSD mSATA KingSpec Half-Size Solid State
    - Fractal Design Node 304 black (HDD 3.5" x6)
    - RAID 5 XFS
    - OMV 4.1.35-1 Arrakis

  • Problem solved. Seems like either the forum is bugged or there might be an incompatibility between the forum and Windows 7 64bit. I tried also different browsers. (Firefox 35 and SWare Iron 38)


    When you copy the content, that subzero79 posted here:


    Create a new group ftponly in OMV webUI. Put usernames into that group that you want login


    Then in extra options general FTP put


    Code
    <Limit LOGIN>
    DenyGroup !ftponly
    </Limit>


    Into the WebGUI of OMV or the Windows Editor, it just wont show any weird characters which don't belong there.
    When you copy it to Notepad++, something weird happens:

    (Magically a question mark appears in the first line)
    We also tried other editors:



    And this was the problem, why it did not save the configuration in the Extra Options-Tab in the FTP section without errors.
    Either typing it one by one into the tab or deleting the question mark and re-copying it after that works. FTP users only in the "ftponly"-group have now ftp access. Thread solved. Thanks subzero79!

    OpenMediaVault 1.12 on Debian Wheezy 7.8 64bit | 3.16 Backport Kernel | OMV-Extras.org 1.10
    ASRock Q1900-ITX | 1x4GB Corsair Vengeance SODIMM DDR3 | 1xWD Red 3TB | 1xApacer 1,8" SATA1 SSD 32GB as system drive | be quiet! Pure Power L8 350W | SilverStone Milo ML04 Black

  • Nice to read that.


    For future use :


    Editing files with Windows editors and then copying them into Unix systems is often a pain in the ass when comes the part to execute them...
    The fact relies in the encoding of the file from Windows to Unix (for example the file is created with Notepad++ in ANSI and Unix reads it in UTF8...)
    I also often see the fact that when you copy a file created on Notepad++ on a Unix system, you have those chars at the end of each line "^M".


    For this you can open your file with vi (not in insert mode) and do the following :

    Code
    :%s/^M//g

    (you have to press ctrl+v+Enter to type the ^M charater)
    You can also use the following command

    Code
    dos2unix

    to convert the file (here is the man page : http://linuxcommand.org/man_pages/dos2unix1.html).


    Greetings

    - ASROCK FM2A88X-ITX+ (SATAIII (6Gb/s) x6 (for the DATA), mSATA x1 (for the OS))
    - AMD A6 7400K 3.5GHz
    - Corsair 2Go DDR3 1333MHz C9 (x2)
    - Intel Corporation 82574L Gigabit Network Connection
    - COOLER MASTER G450M (80+ bronze)
    - WD Red 2To 64Mo 3.5" SATAIII (6Gb/s)
    - 32 Go SSD mSATA KingSpec Half-Size Solid State
    - Fractal Design Node 304 black (HDD 3.5" x6)
    - RAID 5 XFS
    - OMV 4.1.35-1 Arrakis

  • In notepad++, you can choose unix line endings in the Edit -> EOL Conversion -> UNIX/OSX Format and encode in UTF8 with the Encoding -> Encode in UTF-8 menu.

    omv 5.3.9 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!