Problem with CIFS-SMB ADS directory Server Role

  • Debian wheezy, openmediavault 1.9
    I followed the excellent walk through here: Join a Windows 2008 R2 domain but I found a hitch. I could not join the domain. Eventually I found that openmediavault was adding this line into /etc/samba/smb.conf:


    Code
    security = user


    This line cancelled out my extra line:


    Code
    security = ads


    And stopped me joining the domain with, among other messages:


    Code
    Host is not configured as a member server.
    Invalid configuration.


    testparm would say among other things;


    Code
    Server role: ROLE_STANDALONE


    If I took out the line


    Code
    security = user


    That was added in the ldap section then testparm gave:


    Code
    Server role: ROLE_DOMAIN_MEMBER


    My question is: how to get the webui to remove that samba config line? Because if I don't it adds it back in whenever I save the gui config.

  • Did you try putting it in the Extra options box? I thought samba used the last parameter when there were duplicates. If it is in the extra options box, it would be last.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I added it to the extra options box but the problem is that the ldap options appear after the extra options in a special section at the end of the global options.


    /etc/samba/smb.comf:

  • The file:
    /usr/share/openmediavault/mkconf/samba.d/15ldap


    adds the line "security = user"


    When I remove this line (line 43 or 44):

    Code
    -o "security = user" -n \


    and save the config from the gui then I can join the domain without problems.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!