Problem with setting up a certificate OMV-extras OPENVPN

  • Hi,
    I installed the plugin without experiencing any problem, but once I try to create a certificate I get an error message.
    I have 2 boxes available: in the 1st on I select the user and then I can name it.
    I then click to accept, get an error message, but still, the certificate appears in the list.
    When I try to delete that certificate, I get another error, but it doesn't disappear from the list. It only does when I uninstall OPENVPN.

    I tried uninstalling and reinstalling OPENVPN, but get the same errors.

    Anyone experienced it? My OMV setup is a fresh install...

    I am not at home now, but I will post the exact message that I get when I get there later.

    Thank You!

  • Error when I try to add or delete a certificate:

    • Official Post

    I think you're confused about the openvpn plugin, the server PKI is managed internally you have to place CA, certs, keys and dh with ssh or scp.
    The server generates an initial PKI you can use, for fast start. If you want your own is like I mentioned before.
    The plugin doesn't use the omv certificate generator and manager.

  • I got the same problems on my OMV on raspberry pi, but I found a solution for now, which is working very well, until the openvpn (and the openvpnAS) will work gain in a decent way.

    First of all, remove openvpn from OMV via web gui.

    After that, go to the below link and follow the very easy setup explanation, based on a script:…config-on-openmediavault/

    The script has been updated by that time, so the procedure is slightly different now (and even easier), because at the end you will get a file client.ovpn on the root (or [filename_you_choose].ovpn), which can be save and uploaded on you openvpn client (I am using it also on my phone and it is working very well).

    Please keep in mind that in your router you will need to forward the VPN UPD port to your OPV ip address. Please also consider that the script will take a very long time to generate the keys, it is normal.

    To save the client.ovpn, use the command: "scp client.ovpn"

    Do not install or activate openvpn from openmediavaul web gui, otherwise OMV will overwrite the openvpn settings and it might make a mess.

    I hope this will help, as it helped me!

  • I noticed the following errors in the system log everytime I used the vpn connection:

    ovpn-server[nnnn]: read UDPv4 [EMSGSIZE Path-MTU=1452]: Message too long (code=90)

    This message shows up when OpenVPN detects that packets get fragment somewhere between client and server (I think the raspberry Lan is not fast enough for a value MTU=1452).

    I solved the problem by adding the following line to /etc/openvpn/server.conf:

    mssfix 1400


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!