Cannot connect in FTP

  • Hi all,


    I need some help to configure the ftp on my OpenMediaVault.


    I join my configuration :


    WHen I attent logging with Filezilla :




    Status: Connecting to XXX.XXX.XXX.XXX:21...


    Status: Connection established, waiting for welcome message...


    Status: Insecure server, it does not support FTP over TLS.


    Command: USER JC


    Response: 331 Password required for JC


    Command: PASS **********


    Response: 530 Login incorrect.


    Error: Critical error: Could not connect to server


    And if i connect with user 'Admin'




    Status: Connecting to XXX.XXX.XXX.XXX:21...


    Status: Connection established, waiting for welcome message...


    Status: Insecure server, it does not support FTP over TLS.


    Status: Connected


    Status: Retrieving directory listing...


    Status: Directory listing of "/" successful


    The Directory "/" is empty .


    I don't understand what it's the problem.


    Could you help me please?

  • I think too.
    I reset all privilèges but I can't connect.




    Status: Connecting to 192.168.0.101:21...


    Status: Connection established, waiting for welcome message...


    Status: Insecure server, it does not support FTP over TLS.


    Command: USER JC


    Response: 331 Password required for JC


    Command: PASS **********


    Response: 530 Login incorrect.


    Error: Critical error: Could not connect to server




    530 Login incorrect => Why? It's a problem with one group? I'm giving to him all groups?
    I have the same error with "root"


    But i can connect with "admin" but I can see only "/" but it's empty folder.


    I need change some ".conf" ?

  • What client are you using? You're trying to connect inside lan or from wan?
    Every user can login but only those indicated in privileges will see the shares (admin for example is not available in privileges, but he can login)
    To reset privileges is not to reset permissions. Can you clarify if you resseted permissions with the utility?
    Can you post here this command :
    cat /etc/proftpd/proftpd.conf

  • Sorry, I use "Reset Permissions" with the utility.



    I try plain ftp, I try secure ftp only when plain ftp are running good ;)

  • Are you having Filezilla prompt you for credentials??? or did you try to save them? There are some changes in the new version of Filezilla.


    Edit/Settings/Interface


    then on the right "behavior"


    take check off "Do not save passwords"


    You need to do this if you save your passwords.


    I use the site manager and it would not work correctly til I did this.

  • I use a HDD, I read somewhere it's dangerous to use usb to system.
    I use an old 80Go HDD.


    I can force reinstall of this plugin by apt-get insctruction?


    I put my setting page in English and without scrollbar.



    I use the filezilla interface. I save my options in the application.
    I try with prompt but I can't connect to.

  • It may work with admin some weird way because you might be logged into the web gui.



    I don't suspect corruption now or issue with your system drive. I didn't notice the scrollbar. But read what I said about Filezilla.


    Well you cannot save your credentials now in Filezilla til you do what I said above.


    Can you give me bigger picture of shared folder privileges?

  • I would test it from the internet with this site. And give a screenshot of the results.


    Code
    https://ftptest.net/



    I see in a newer picture you have a check mark for passive ports. There is more to setting up passive port.
    Take that checkmark off for now.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!