Plex does not work with DB directory on mounted USB stick

  • Hi,


    OVM 1.16 on Cubietruck.
    Actual Plex plugin.


    - Installed Plugin, selected DB directory ("Datenbank Verzeichnis") on hard disk -> works.
    - Changed volume ("Datenbank Datenträger") to other hard disk in plex settings -> works.
    - Changed volume to other mounted USB stick -> does not work. (/etc/init.d/plexmediaserver status says it's not running even after start)


    Is there a certain reason for that?
    Stick is also ext4 formatted.
    Stick should not be corrupt!?


    Thanks in advance!

  • cubie@Cubian:~$ grep plex /etc/passwd
    plex:x:120:65534::/media/-theusbstickmount-/plexmediaserver:/bin/bash


    ==
    drwxrwxrwx 3 root root 4096 Apr 1 18:07 plexmediaserver
    ==


    sudo chown plex:nogroup plexmediaserver
    drwxrwxrwx 3 plex nogroup 4096 Apr 1 18:07 plexmediaserver


    ==



    cubie@Cubian:/media$ sudo /etc/init.d/plexmediaserver start
    Starting Plex Media Server: done
    cubie@Cubian:/media/$ sudo /etc/init.d/plexmediaserver status
    It seems that Plex Media Server isn't running (no process found).



    :/

  • No like this:


    chown -R plex:nogroup plexmediaserver


    Then try to start... You need the -R so the changes will recurse down into all the subfolders/files.


    You don't need to use sudo in Debian when you are signed in as root.

  • Code
    cubie@Cubian:/media/42ac4cc6-f85d-4e09-82bf-78fc46ddb41a$ sudo omv-showkey plexmediaserver
    <plexmediaserver>
    <enable>1</enable>
    <db-folder>/media/42ac4cc6-f85d-4e09-82bf-78fc46ddb41a/plexmediaserver</db-folder>
    <mntentref>6180eaa6-5d45-4c2d-b6fa-b7085070f1d2</mntentref>
    <showtab>1</showtab>
    </plexmediaserver>


    ...where 42ac... is the usbstickmount.
    not sure about mntentref id!?


  • btw: thx for your effort!

  • How did I mount? Via OMV


    How the fstab looks like:

    Code
    cubie@Cubian:/media/42ac4cc6-f85d-4e09-82bf-78fc46ddb41a$ cat /etc/fstab
    # UNCONFIGURED FSTAB FOR BASE SYSTEM
    #<file system> <mount point> <type> <options> <dump> <pass>
    ...
    # >>> [openmediavault]
    ...
    UUID=42ac4cc6-f85d-4e09-82bf-78fc46ddb41a /media/42ac4cc6-f85d-4e09-82bf-78fc46ddb41a ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2
    # <<< [openmediavault]
  • Finally I got it!


    Permissions on the mount path were "wrong". Was another user and group, changed it to root:root and changed to 755
    ==
    cubie@Cubian:/media$ ls -al
    drwxr-xr-x 6 root root 4096 Apr 2 02:23 42ac4cc6-f85d-4e09-82bf-78fc46ddb41a
    ==


    Again thx for your effort!


    ps: did reset the fstab (with parameter noexec).

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!