No Recycle Bin in windows explorer via SMB/CIFS

  • Hello!

    We just set up a new OMV for our agency. Everything is working quite nice so far. We use it via SMB/CIFS which is then implemented in the client computers as windows network drive via the windows explorer. We also use Apple Filing. File system is ext4. OMV-Version: 1.17.

    Let's get to my problem: I enabled the recycle bin option for both shares that I created. But neither one of them shows the recycle bin.
    I also tried to set the values for the maximum file size and the number of days to keep the files - but nothing changes or is a solution to the problem. I also checked if the recycle bin is hidden in the windows explorer... nothing. I even restarted the NAS after changes (also my pc). I also tried to create a new user and rechecked everything I described two sentences before with it. No solution. No recycle bin in my widnows explorer. Hmpf. :(

    Any further advice what I should/could try next?

    Greetings, Johannes
    nachVORNE Agency

  • Hey Subzero, thanks for helping me out!

    But as I said:


    I also checked if the recycle bin is hidden in the windows explorer... nothing.

    Even after some "sample-deletions" - there appears no .recycle folder.

    Greetings, Johannes
    nachVORNE Agency

  • There is no recycle bin as displayed in Windows with the rubbish can. Is just a dot folder. Didn't try with the size and days options. If you access by ssh can you see the recycle folder? You have to delete through samba if you want the appear there.

  • Sorry, my fault. Called it a "bin" but thought of the .recycle-folder...

    Access over SSH and I can see the .recycle-folder in both shares we use. But even if I try to delete something, the windows explorer gives me as delete-prompt not the normal "do you want to move this file to the trash bin"-message but rahter the "do you want to irrevocable delete this file"-message. Although, the items I delete appear afterwards in the recycle-folder (which I still have to access over SSH)... Saw that the .recycle folder lacked a write-permission for the users-group so I tried to give it 770 over chmod. didn't change anything.

    So still 2 shares with activated .recycle but I can't access or see them in the windows explorer.

    What do you mean with


    Didn't try with the size and days options.

    EDIT: Don't know what I did or changed - but know I can see the .recycle-folder...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!