Plugin Docker

  • I don't know if anyone can help on here, but i've installed docker perfectly find. I've then gone into the icons tab and installed nextcloud.
    From what i've read up on, you're supposed to just then go to 192.168..../nextcloud but i get a 404 error?

    Did you perform any configuration of the container?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • can someone tell, how to setup container?

    OpenMediaVault Docker-GUI Plugin Usage


    It can be very confusing at first, take a look at @subzero79s Guide.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Anyone knows how to solve this error, please: "Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start 'docker' 2>&1' with exit code '1': Job for docker.service failed because the control process exited with error code. See "systemctl status docker.service" and "journalctl -xe" for details.


    Details = Erreur #0:OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start 'docker' 2>&1' with exit code '1': Job for docker.service failed because the control process exited with error code.See "systemctl status docker.service" and "journalctl -xe" for details. in /usr/share/php/openmediavault/system/process.inc:175Stack trace:#0 /usr/share/php/openmediavault/system/systemctl.inc(86): OMV\System\Process->execute(Array, 1)#1 /usr/share/php/openmediavault/system/systemctl.inc(104): OMV\System\SystemCtl->exec('start', NULL, false)#2 /usr/share/openmediavault/engined/module/docker.inc(35): OMV\System\SystemCtl->enable(true)#3 /usr/share/openmediavault/engined/rpc/config.inc(194): OMVModuleDocker->startService()#4 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)#5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)#6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)#7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(536): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusuq...', '/tmp/bgoutputtz...')#8 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))#9 /usr/share/openmediavault/engined/rpc/config.inc(213): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)#10 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)#11 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)#12 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)#13 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)#14 {main}


    Result of systemctl status docker.service
    docker.service - Docker Application Container Engine
    Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
    Drop-In: /etc/systemd/system/docker.service.d
    └─openmediavault.conf
    Active: failed (Result: exit-code) since Fri 2018-05-04 23:45:13 CEST; 35s ago
    Docs: https://docs.docker.com
    Process: 43440 ExecStart=/usr/bin/dockerd -H fd:// $DOCKER_OPTS $OMVDOCKER_API $OMVDOCKER_IMAGE_PATH (code=exited, sta
    Main PID: 43440 (code=exited, status=1/FAILURE)
    CPU: 151ms

    HP Proliant Microserver N40L - 8Go RAM - ESXi 6 - 1*250Go + 2*3To + 1*650Go - OMV 2.x installed

  • other journal info:
    -- Unit docker.socket has begun shutting down.
    May 04 23:45:13 charybde systemd[1]: Starting Docker Socket for the API.
    -- Subject: Unit docker.socket has begun start-up
    -- Defined-By: systemd
    -- Support: https://www.debian.org/support
    --
    -- Unit docker.socket has begun starting up.
    May 04 23:45:13 charybde systemd[1]: Listening on Docker Socket for the API.
    -- Subject: Unit docker.socket has finished start-up
    -- Defined-By: systemd
    -- Support: https://www.debian.org/support
    --
    -- Unit docker.socket has finished starting up.
    --
    -- The start-up result is done.
    May 04 23:45:13 charybde systemd[1]: docker.service: Start request repeated too quickly.
    May 04 23:45:13 charybde systemd[1]: Failed to start Docker Application Container Engine.
    -- Subject: Unit docker.service has failed
    -- Defined-By: systemd
    -- Support: https://www.debian.org/support
    --
    -- Unit docker.service has failed.
    --
    -- The result is failed.
    May 04 23:45:13 charybde systemd[1]: docker.socket: Unit entered failed state.
    May 04 23:45:13 charybde systemd[1]: docker.service: Unit entered failed state.
    May 04 23:45:13 charybde systemd[1]: docker.service: Failed with result 'exit-code'.
    May 04 23:45:21 charybde CRON[42778]: pam_unix(cron:session): session closed for user root

    HP Proliant Microserver N40L - 8Go RAM - ESXi 6 - 1*250Go + 2*3To + 1*650Go - OMV 2.x installed

  • If i activate this and do a refresh at the extensions tab i get this error:


  • If i activate this and do a refresh at the extensions tab i get this error:

    There are no 32bit docker packages in docker's repo. I guess I was thinking that omv-extras didn't allow or didn't show the docker repos on that arch but I guess not. So, you will need to use a 64 bit system to use docker.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hm...


    but i'm using a 64bit System


    Code
    root@openmediavault ~ > getconf LONG_BIT
    64
    root@openmediavault ~ > uname -m
    x86_64
    root@openmediavault ~ >



    Anyhow, i managed to install the Docker GUI by using the other repo but now i can't pull at docker container for motioneye.


    This is the website which contains the link to motioneye container : Motioneye Container


    If i start the pull with

    Code
    ccrisan/motioneye

    Nothing happened and i got this at the logfile:


    Code
    Jun 19 15:02:51 openmediavault dockerd[1863]: time="2018-06-19T15:02:51.357834742+02:00" level=info msg="Attempting next endpoint for pull after error: manifest unknown: manifest unknown"
    Jun 19 15:02:51 openmediavault dockerd[1863]: time="2018-06-19T15:02:51.357948666+02:00" level=info msg="Translating \"manifest unknown: manifest unknown\" to \"manifest for ccrisan/motioneye:latest not found\""
    Jun 19 15:02:51 openmediavault omv-engined[11240]: Failed to write to socket: Broken pipe

    Is this a problem within my local installation or with image provider?


    Thanks for help

  • Anyhow, i managed to install the Docker GUI by using the other repo but now i can't pull at docker container for motioneye.

    You must have a mutlilib system. You could add [arch=amd64] to the docker repo entry then.
    deb [arch=amd64] https://download.docker.com/linux/debian jessie stable


    Another note... Jessie was EOL'd yesterday. So, I would recommend upgrading to OMV 4.x.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!