autoshutdown probleme

  • hey,


    versuche autoshutdown zu nutzen. es fährt aber nicht runter. habe 2 zyklen die 180s überprüfen und alles andere zum test aus. er fährt aber nicht runter... "pm-suspend" funktioniert über die console und kann dann per wol wieder starten. mir ist auch aufgefallen wenn ich das lan kabel raus lasse schaltet er sich by NiceOffers"> sauber ab.


    hat jemand eine idee?

  • Im Log ist nichts auffälliges zu sehen, außer, dass der Server gleich nach dem "pm-hibernate" wieder startet.
    Installier mal den "Backport-Kernel" via omv-extras und schau bitte im BIOS nach, ob nicht irgendwas bei "wake from suspend" eingestellt ist, vielleicht "wake up from network"?

  • Hi, ich hatte mal das gleiche Problem....
    Bei mir war es eine USB Funkmaus !? Als ich die entfernt habe ging alles .


    VG

    Proxmox5: Kernel 4.13.4-1-pve LXC: omv 4.x arrakis | 64 bit | omvextrasorg 4.x |

  • Das sollte die BIOS Einstellung sein:
    Wake On USB for STR State oder Wake On USB for S3 or S4 State
    http://www.bios-info.de/4p92x846/befw.htm

  • Wenn es das wirklich ist dann würde er aber doch runter fahren und sofort wieder an gehen.


    Er bleibt aber die ganze Zeit an und ist auch die ganze Zeit erreichbar

  • im script steht, es wird "pm-hibernate" ausgeführt, z.B. am 9. Mai um 16:04:29
    Gleich danach wird das script wirder gestartet.
    Schon mal den Server neu gestartet?

  • hey,


    also ich weiss nicht genau was ich gemacht habe aber es geht jetzt :-D. habe Debian neuinstalliert und dadrüber openmediavault damit ich einen Desktop über Teamviewer habe für Remote Desktop. zusätzlichhabe ich von dem Gehäuse mal das usb abgemacht. weiss jetzt nicht genau was der Fehler war .. sorry ;)


    mein problem ist jetzt das ich gerne den Benutzer auf dem Teamleiter läuft dauerhaft angemeldet haben muss damit man extern auf Teamviewer zugreifen kann. aber leider erkennt das script den nutzer so das er über port 22/21 zugreift und deshalb den shutdown verhindert. meldet man den Nutzer ab geht es ;)


    wer hat ne Idee wie ich das machen kann? ;)


    lg und danke


    übrigens port 21/22 werden nicht überwacht

  • May 24 14:40:30 Media-Server logger: autoshutdown[16170]: INFO: '------------------------------------------------------'
    May 24 14:40:30 Media-Server logger: autoshutdown[16170]: INFO: ' new supervision cycle started - check active hosts or processes'
    May 24 14:40:30 Media-Server logger: autoshutdown[16170]: INFO: ' retrieve list of active IPs for 'eth0' ...'
    May 24 14:40:31 Media-Server logger: autoshutdown[16170]: INFO: ' No active IPs in the specified IP-Range found'
    May 24 14:40:31 Media-Server logger: autoshutdown[16170]: INFO: ' Check Connections for 'eth0''
    May 24 14:40:31 Media-Server logger: autoshutdown[16170]: INFO: ' There is a user (locally) connected -> no shutdown'
    May 24 14:40:31 Media-Server logger: autoshutdown[16170]: INFO: ' It is 'karl-hei#012karl-hei' on/from 'tty8#012pts/0''
    May 24 14:40:31 Media-Server logger: autoshutdown[16170]: INFO: ' Found 1 active socket(s) from Port(s): 139,445,3689,6991,9091,49152,21,22'
    May 24 14:40:32 Media-Server logger: autoshutdown[16170]: INFO: ' sleep for 180s.'


    er überprüft immer ob noch ein user offline ist. wie kann ich das abschalten?


    it checks on whether a user always online. How can I disable it?

  • Du könntest z.b. Port 22, falls du diesen tatsächlich für SSH nutzst, aus der Liste nehmen.


    Das bringt leider nichts. Der Angemeldete Nutzer würde trotzdem auffallen, auch wenn der SSH Port nicht mehr im check ist.


    Gruß
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • genau der fällt trotzdem auf... gelöst habe ich es in dem ich alles auskommentiert habe was den user abfragt ;)


    also in der autoshutdown alles was mit # Extra Check for connected users on the CLI if other processes are negative -> [ $NUMPROC -eq 0 ] zutun hat auskommentieren. dann klappts ;)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!