Zoneminder on 1.18

  • Hi All,


    I'm working on installing the nginx version of Zoneminder from omv-extras but I'm running into installation errors. If anyone has a few minutes, could you take a look at the following:



    I'm currently running Zoneminder on an Ubuntu box, but I thought it would be nice to consolidate everything on my OMV server. I've spent quite a few hours reading forums and doing some troubleshooting, but my linux knowledge is not enough to get me through this one. I've tired the most obvious solutions like purging and re-installing and restarting the server.


    Some errors in the nginx log folder:


    24 connect() to unix:/var/run/php5-fpm-zoneminder-webgui.sock failed (2: No such file or directory) while connecting to upstream


    I'm running 1.18 with the latest updates. Kernal 3.2.0-4-amd64 on an i7 920 @ 2.67. This is a 1.0 upgrade from 0.5.X.


    I apologize if this is not the correct section to post this; I'm not sure this counts as a plug-in...


    Thanks for your time!

  • https://github.com/cptjhmiller/omv-zoneminder


    Remove your current version of ZM and follow the build instructions on that link to create a .deb package. Once built, do a dpkg -i ../PACKAGE.deb; apt-get install -f
    This will build the latest version.

    [align=center]
    What I am watching/watched on my Popcorn Hour media player
    omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
    MySQL (Percona[size=8]) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

  • Just a quick update. I followed the build instructions on the git site,built and installed the package without problems. I now have two Foscam FI8910W cameras working with pan and tilt. However, when I enable security on Zoneminder via OPT_USE_AUTH, I am no longer able to view the camera feeds. It's throwing the following error every time the camera feed is opened:


    socket_sendto( /var/run/zm/zms-112705s.sock ) failed: No such file or directory


    Additionally, I see the following log entries: Monitor1: 11000 - Capturing at 13.33 fps, so I'm under the impression that the back-end is still working.


    I've done quite a bit of looking around, but most folks with this error are facing some Apache configuration issues.


    I'll continue to research this, but I was hoping that someone here had run across this specific problem. Any help is very much appreciated.


    Again, thank you very much for your time!

  • Hi all,


    I tried to follow the omv-zoneminder at github web. But I failed can't build package.


    I stop at 4th step : "apt-get install autoconf..."


    And result : "...... 0 upgraded, 173 newly installed, 0 to remove and 2 not upgraded.
    E: Could not get lock /var/cache/apt/archives/lock - open (11: Resource temporarily unavailable)
    E: Unable to lock directory /var/cache/apt/archives/"


    Is there maybe any pre-requisite plugin installation that is required ?


    Could you help to step by step on how to install ZoneMinder on OMV 1.19 ?
    Really appreciate for your help.


    thank you

  • It might be that apt was busy with something else at the time, try again now or try again after a reboot.


    I built the package on Friday (made a few changes to the git repo) and am currently running it.

    [align=center]
    What I am watching/watched on my Popcorn Hour media player
    omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
    MySQL (Percona[size=8]) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

  • Thanks for input.
    I reboot the OMV and can proceed the instruction.


    However, after final step "dpkg-buildpackage -uc -us"
    It give output :....
    "...Updating 'db/zm_create.sql'


    -- ZoneMinder configuration generator completed successfully


    -- Configuring done


    -- Generating done


    CMake Warning:


    Manually-specified variables were not used by the project:


    ZM_PERL_SUBPREFIX


    -- Build files have been written to: /zoneminder/ZoneMinder/obj-x86_64-linux-gnu


    /bin/sh: 17: -DCMAKE_INSTALL_SYSCONFDIR=etc/zm: not found


    make[1]: *** [override_dh_auto_configure] Error 127


    make[1]: Leaving directory `/zoneminder/ZoneMinder'


    make: *** [build] Error 2


    dpkg-buildpackage: error: debian/rules build gave error exit status 2"


    Could you advice for next step.
    And if the step all complete, how can I install the package in OMV/what is next step in installation.
    Will the ZoneMinder web can be accessed directly ?


    thank you in advance.


    regards

  • It should not error. I would try deleting the zoneminder folder and start again. The warning about ZM_PERL_SUBPREFIX is normal and can be ignored.


    Once you have the .deb file you just need to run dpkg -i /PATH-TO-DEB-FILE;apt-get install -f

    [align=center]
    What I am watching/watched on my Popcorn Hour media player
    omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
    MySQL (Percona[size=8]) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

  • Hi,...
    I have tried couple of time to rm zone minder folder and then redo the step, but the result is the same.
    "...-- ZoneMinder configuration generator completed successfully


    -- Configuring done


    -- Generating done


    CMake Warning:


    Manually-specified variables were not used by the project:


    ZM_PERL_SUBPREFIX


    -- Build files have been written to: /zoneminder/ZoneMinder/obj-x86_64-linux-gnu


    /bin/sh: 17: -DCMAKE_INSTALL_SYSCONFDIR=etc/zm: not found


    make[1]: *** [override_dh_auto_configure] Error 127


    make[1]: Leaving directory `/zoneminder/ZoneMinder'


    make: *** [build] Error 2


    dpkg-buildpackage: error: debian/rules build gave error exit status 2


    "


    Not really sure what is went wrong...


    Need help maybe any other way to solve ?


    thank you

  • Sorry there was a problem with the last commit due to my windows git hub application behaving badly.


    You can either start from the beginning or just delete the debian folder and then


    Code
    git clone https://github.com/cptjhmiller/omv-zoneminder.git /zoneminder/ZoneMinder/debian
    dpkg-checkbuilddeps
    dpkg-buildpackage -uc -us

    [align=center]
    What I am watching/watched on my Popcorn Hour media player
    omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
    MySQL (Percona[size=8]) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

  • Not intentionally, you could try building this version to see if it does make any difference.


    I had not been using ZM for a while after my main cam failed, got a replacement and so reinstalled the latest version.


    If I get time I will see what happens if I enable authorisation.

    [align=center]
    What I am watching/watched on my Popcorn Hour media player
    omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
    MySQL (Percona[size=8]) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

  • I had the same issues on my end, it looks to do with md5 libraries. I will check the build log to see if there were any warnings about this but in the mean time just set AUTH_RELAY to none, restart ZM or system and you should be good to go.

    [align=center]
    What I am watching/watched on my Popcorn Hour media player
    omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
    MySQL (Percona[size=8]) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

  • It is not OMV_IP/zm but OMV_IP:81


    You can change the port by editing the /etc/ngnix/sites-available/nginx.conf, replace 81 with your port and reload nginx.

    [align=center]
    What I am watching/watched on my Popcorn Hour media player
    omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
    MySQL (Percona[size=8]) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!