Zoneminder on 1.18

  • Hi. I built the package as per the instructions on Git (think I got everything right). Installed the package. Says the zoneminder service is started. But when I go to log into the web interface, I get "ZoneMinder is not installed properly: php's date.timezone is not set to a valid timezone".


    Any ideas? Did I screw up building the package somehow?


    ** edit - I commented out the check in the zoneminder index.php and the web interface works now... But I'm pretty sure that I should probably find the cause of that error and fix it...

  • You need to edit php.ini and add your timezone to that setting, there can be 3 or more php.ini files in various locations. Your best bet would be to run find / -name php.ini and your timezone to each.

    [align=center]banner@1x.jpg
    What I am watching/watched on my Popcorn Hour media player
    omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
    MySQL (Percona[size=8]) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS

  • Thanks. I actually ended up changing my mind on that particular server (it was for my in-laws) and opted to make it a windows box with the trendnet pro software... it'll be much easier. But I'm going to put zoneminder on my own OMV box since I was gifted three IP cameras. So if I didn't do anything wrong with my install and I just need to do that, should be good.


    Thank you!

  • <a href="https://github.com/cptjhmiller/omv-zoneminder" class="externalURL" rel="nofollow" target="_blank">github.com/cptjhmiller/omv-zoneminder</a>
    follow that to see if you can build it on your pi


    Hi,


    I followed it. The first problem was when trying "apt-get install autoconf automake dpatch ..." -> Unable to locate package libcrystalhd3
    The bigger problem I encountered with "dpkg -i libjpeg-turbo-official_1.3.90_amd64.deb" -> "dpkg: error processing libjpeg-turbo-official_1.3.90_amd64.deb (--install):
    package architecture (amd64) does not match system (armhf)
    Errors were encountered while processing:
    libjpeg-turbo-official_1.3.90_amd64.deb"
    and I do think that is my problem.


    Well I am a Noob with Linux, so there may be a simple solution which I cannot find. Is there a simple trick?


    Thank you in advance

  • I just recently stumbled across this, but I thought I read that there was a testing plugin for ZoneMinder somewhere? If not, then I suppose I'll build it from the git repo (the reason I wanted a Linux based server, anyways!). I believe I'm going to start with a Foscam FI9802W for 30 fps and 720p recording.

  • There isn't a plugin. Just a package built to work on OMV. Here

    omv 6.0.27-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.0.9 | kvm 6.1.12 | mergerfs 6.1.1 | zfs 6.0.9
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • This is a great camera although only 15fps at 3 megapixel. Not sure about compatibility with zoneminder since I don't use it.

    omv 6.0.27-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.0.9 | kvm 6.1.12 | mergerfs 6.1.1 | zfs 6.0.9
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • This is a great camera although only 15fps at 3 megapixel. Not sure about compatibility with zoneminder since I don't use it.


    Interesting, I suppose I don't quite need 30 fps. I looked up some videos on that camera. It does look like a solid choice at a great price/performance/feature ratio. Thanks for the suggestion, I'm going to continue some research! And it looks like it does support ZM!
    https://wiki.zoneminder.com/Trendnet#TV-IP310PI

  • 1080p is only 2 megapixels. It might have a better frame rate at that slightly lower resolution. Never noticed the frame rate myself though. The camera also supports PoE making the wiring much easier.


    Currently, I just check my camera over the internet with the trendnet iOS app. Works well. Maybe I will try zoneminder one of these days.

    omv 6.0.27-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.0.9 | kvm 6.1.12 | mergerfs 6.1.1 | zfs 6.0.9
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hallo
    I have a problem.
    After i install the programm the webgui is defect!



    That text i see on screen if i open the webgui:


    It works!


    This is the default web page for this server.


    The web server software is running but no content has been added, yet.

    Server:
    Mainboard: Gigabyte GA-H97N-WIFI - CPU: Intel Core i3-4170T - CPU Kühler: EKL Alpenföhn BEN NEVIS - Gehäuse: BitFenix Prodigy ITX - RAM: 8GB Crucial Ballistix Sport DDR3-1600 -
    Netzteil: Be quiet! BN140 System Power 7 (300W) - 1x 120GB Samsung 850 Evo (System) - 2x 4TB WD Red (Data) - 1x 2TB Seagate Green (Data) - OMV: latest 2.x


    Plugins:
    Plex Media Server, RSync, JDownloader, ownCloud, eXtplorer, antivirus, autoshutdown

  • Run omv-firstaid.

    omv 6.0.27-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.0.9 | kvm 6.1.12 | mergerfs 6.1.1 | zfs 6.0.9
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • And there?

    Server:
    Mainboard: Gigabyte GA-H97N-WIFI - CPU: Intel Core i3-4170T - CPU Kühler: EKL Alpenföhn BEN NEVIS - Gehäuse: BitFenix Prodigy ITX - RAM: 8GB Crucial Ballistix Sport DDR3-1600 -
    Netzteil: Be quiet! BN140 System Power 7 (300W) - 1x 120GB Samsung 850 Evo (System) - 2x 4TB WD Red (Data) - 1x 2TB Seagate Green (Data) - OMV: latest 2.x


    Plugins:
    Plex Media Server, RSync, JDownloader, ownCloud, eXtplorer, antivirus, autoshutdown

  • Since the web gui isn't working right, I thought you would choose configure web gui. If you did and that didn't fix it, try this. If that doesn't work, what is the output of:


    dpkg -l | grep openmediavault

    omv 6.0.27-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.0.9 | kvm 6.1.12 | mergerfs 6.1.1 | zfs 6.0.9
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Server:
    Mainboard: Gigabyte GA-H97N-WIFI - CPU: Intel Core i3-4170T - CPU Kühler: EKL Alpenföhn BEN NEVIS - Gehäuse: BitFenix Prodigy ITX - RAM: 8GB Crucial Ballistix Sport DDR3-1600 -
    Netzteil: Be quiet! BN140 System Power 7 (300W) - 1x 120GB Samsung 850 Evo (System) - 2x 4TB WD Red (Data) - 1x 2TB Seagate Green (Data) - OMV: latest 2.x


    Plugins:
    Plex Media Server, RSync, JDownloader, ownCloud, eXtplorer, antivirus, autoshutdown

  • wget http://dh2k.omv-extras.org/debian/pool/main/z/zoneminder/zoneminder_1.27-1_amd64.deb
    dpkg -i zoneminder_1.27-1_amd64.deb
    apt-get -f install

    omv 6.0.27-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.0.9 | kvm 6.1.12 | mergerfs 6.1.1 | zfs 6.0.9
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • thx a lot -- it works!

    Server:
    Mainboard: Gigabyte GA-H97N-WIFI - CPU: Intel Core i3-4170T - CPU Kühler: EKL Alpenföhn BEN NEVIS - Gehäuse: BitFenix Prodigy ITX - RAM: 8GB Crucial Ballistix Sport DDR3-1600 -
    Netzteil: Be quiet! BN140 System Power 7 (300W) - 1x 120GB Samsung 850 Evo (System) - 2x 4TB WD Red (Data) - 1x 2TB Seagate Green (Data) - OMV: latest 2.x


    Plugins:
    Plex Media Server, RSync, JDownloader, ownCloud, eXtplorer, antivirus, autoshutdown

  • If i install and Start the Service i have 100% CPU


    Is It normal?

    Server:
    Mainboard: Gigabyte GA-H97N-WIFI - CPU: Intel Core i3-4170T - CPU Kühler: EKL Alpenföhn BEN NEVIS - Gehäuse: BitFenix Prodigy ITX - RAM: 8GB Crucial Ballistix Sport DDR3-1600 -
    Netzteil: Be quiet! BN140 System Power 7 (300W) - 1x 120GB Samsung 850 Evo (System) - 2x 4TB WD Red (Data) - 1x 2TB Seagate Green (Data) - OMV: latest 2.x


    Plugins:
    Plex Media Server, RSync, JDownloader, ownCloud, eXtplorer, antivirus, autoshutdown

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!