ACL ERROR OMV 2.07

  • Hey guys, please help with the ACL. I installed the new OMV upgraded to version 2.07, I created a RAID 5 (XFS), and creating folders I see this error:


    Code
    Error #4000:
    exception 'OMVException' with message 'Failed to execute command 'export LANG=C; setfacl --remove-all -m 'default:user:calibre:0,user:calibre:0,default:user:Petr:7,user:Petr:7,default:user:admin:0,user:admin:0,default:user:avahi:0,user:avahi:0,default:user:backup:0,user:backup:0,default:user:bin:0,user:bin:0,default:user:btsync:0,user:btsync:0,default:user:clamav:0,user:clamav:0,default:user:daemon:0,user:daemon:0,default:user:debian-transmission:0,user:debian-transmission:0,default:user:ftp:0,user:ftp:0,default:user:games:0,user:games:0,default:user:gnats:0,user:gnats:0,default:user:irc:0,user:irc:0,default:user:libuuid:0,user:libuuid:0,default:user:list:0,user:list:0,default:user:lp:0,user:lp:0,default:user:mail:0,user:mail:0,default:user:man:0,user:man:0,default:user:messagebus:0,user:messagebus:0,default:user:news:0,user:news:0,default:user:nobody:0,user:nobody:0,default:user:ntp:0,user:ntp:0,default:user:openmediavault:0,user:openmediavault:0,default:user:postfix:0,user:postfix:0,default:user:proftpd:0,user:proftpd:0,default:user:proxy:0,user:proxy:0,default:user:root:0,user:root:0,default:user:snmp:0,user:snmp:0,default:user:sshd:0,user:sshd:0,default:user:statd:0,user:statd:0,default:user:sync:0,user:sync:0,default:user:sys:0,user:sys:0,default:user:tftp:0,user:tftp:0,default:user:uucp:0,user:uucp:0,default:user:vbox:0,user:vbox:0,default:user:www-data:0,user:www-data:0,default:group:adm:0,group:adm:0,default:group:audio:0,group:audio:0,default:group:avahi:0,group:avahi:0,default:group:backup:0,group:backup:0,default:group:bin:0,group:bin:0,default:group:btsync:0,group:btsync:0,default:group:cdrom:0,group:cdrom:0,default:group:clamav:0,group:clamav:0,default:group:crontab:0,group:crontab:0,default:group:daemon:0,group:daemon:0,default:group:debian-transmission:0,group:debian-transmission:0,default:group:dialout:0,group:dialout:0,default:group:dip:0,group:dip:0,default:group:disk:0,group:disk:0,default:group:fax:0,group:fax:0,default:group:floppy:0,group:floppy:0,default:group:fuse:0,group:fuse:0,default:group:games:0,group:games:0,default:group:gnats:0,group:gnats:0,default:group:irc:0,group:irc:0,default:group:kmem:0,group:kmem:0,default:group:libuuid:0,group:libuuid:0,default:group:list:0,group:list:0,default:group:lp:0,group:lp:0,default:group:mail:0,group:mail:0,default:group:man:0,group:man:0,default:group:messagebus:0,group:messagebus:0,default:group:netdev:0,group:netdev:0,default:group:news:0,group:news:0,default:group:nogroup:0,group:nogroup:0,default:group:ntp:0,group:ntp:0,default:group:openmediavault:0,group:openmediavault:0,default:group:operator:0,group:operator:0,default:group:plugdev:0,group:plugdev:0,default:group:postdrop:0,group:postdrop:0,default:group:postfix:0,group:postfix:0,default:group:proxy:0,group:proxy:0,default:group:root:0,group:root:0,default:group:sambashare:0,group:sambashare:0,default:group:sasl:0,group:sasl:0,default:group:shadow:0,group:shadow:0,default:group:snmp:0,group:snmp:0,default:group:src:0,group:src:0,default:group:ssh:0,group:ssh:0,default:group:ssl-cert:0,group:ssl-cert:0,default:group:staff:0,group:staff:0,default:group:sudo:0,group:sudo:0,default:group:sys:0,group:sys:0,default:group:tape:0,group:tape:0,default:group:tftp:0,group:tftp:0,default:group:tty:0,group:tty:0,default:group:users:0,group:users:0,default:group:utmp:0,group:utmp:0,default:group:uucp:0,group:uucp:0,default:group:vboxusers:0,group:vboxusers:0,default:group:video:0,group:video:0,default:group:voice:0,group:voice:0,default:group:www-data:0,group:www-data:0,default:user::7,user::7,default:group::7,group::7,default:other::0,other::0' -- '/media/1c55a6c6-c315-400e-a095-21d0d3c50b22/Media//' 2>&1': setfacl: /media/1c55a6c6-c315-400e-a095-21d0d3c50b22/Media//: Argument list too long' in /usr/share/openmediavault/engined/rpc/sharemgmt.inc:1172
    Stack trace:
    #0 [internal function]: OMVRpcServiceShareMgmt->setFileACL(Array, Array)
    #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
    #2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('setFileACL', Array, Array)
    #3 /usr/sbin/omv-engined(500): OMVRpc::exec('ShareMgmt', 'setFileACL', Array, Array, 1)
    #4 {main}
  • Could you please fill in some more details so we can understand why this is happening?


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • exactly what you need to know? I installed the new OMV upgraded to version 2.07, users created Peter I created a folder, and at that moment the error occurred when I wanted to confirm the ACL permission settings


    I apologize if I write silliness, I'm not a power user

  • Can you take a screenshot of the Filesystems tab?

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I can reproduce this. It is a bug a bug that only affects OMV 2.x and xfs filesystems. I will file a bug report.


    No offense but if you aren't a power user as you say, I wouldn't use the testing version of OMV. No real reason to right now anyway.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • well, I do not upgrade. I am watching you from the beginning OMV, and confidence in your ability, why upgrade to OMV 2.07. I spent 1,200 euro per hw for OMV, is super. I keep my fingers crossed for you

  • I wouldn't always do what I do :D Bug report here

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I also wouldn't use ACLs until you really have to, which isn't the case in 99% of home user usage.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • There's a bug report openend as @ryecoaaron said.


    Also I can confirm the bug with OMV 2.07 and the xfs filesystem. It's giving me a similar error when trying to edit ACLs.
    I made a test with a new disk, and if I create the filesystem with ext4 I can edit ACLs, but not with XFS, it crashes and reports and error like @devilmax wrote.
    Hoping an update to fix this.


    Greetings,
    David.

    My business server: OMV 4.1.22 | intel J2900 + 4GB DDR3 | 64GB SSD OS Disk | 2x1TB WD raid data disks
    Home Server: OMV 4.1.22 (4.19bpo
    ) | MSI B150M PRO VDH | i5-6600T 35W | 16GG RAM DDR4 2133 | 60GB SSD OS disk | 120GG SSD Games (Minecraft+Ark)| 1x4TB+2x2TB WD NAS RED HDDs
    ---------------- File server, FTP, Printing server, Plex, Logitech Media Server, VDR, Minecraft Server, Ark Survival Server, jDownloader
    Home automation server: OMV 4.1.22 (kernel 4.19 bpo) | Intel J4205 | 128GB SSD OS | 250GB HDD DATA | USB-RS485 | mbusd MODBUS TCP<->RTU GATEWAY | HMI SCADA myscadaHome

    Edited once, last by hammondb4 ().

  • @devilmax
    The problem is fixed with the 2.08 update. ACLs working fine for me now in the XFS disk.

    My business server: OMV 4.1.22 | intel J2900 + 4GB DDR3 | 64GB SSD OS Disk | 2x1TB WD raid data disks
    Home Server: OMV 4.1.22 (4.19bpo
    ) | MSI B150M PRO VDH | i5-6600T 35W | 16GG RAM DDR4 2133 | 60GB SSD OS disk | 120GG SSD Games (Minecraft+Ark)| 1x4TB+2x2TB WD NAS RED HDDs
    ---------------- File server, FTP, Printing server, Plex, Logitech Media Server, VDR, Minecraft Server, Ark Survival Server, jDownloader
    Home automation server: OMV 4.1.22 (kernel 4.19 bpo) | Intel J4205 | 128GB SSD OS | 250GB HDD DATA | USB-RS485 | mbusd MODBUS TCP<->RTU GATEWAY | HMI SCADA myscadaHome

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!