OMV hangs on boot

  • Samer here, could someone help me and describe a step by step guide to disable quotas ? (a noob guide :!)


    thanks

    Gigabyte GA-H87M-HD3, Pentium G3220, 4 GO DDR3, 6 x 2 To raid 6, 2.5' 100 Go for system
    Donator because OMV deserves it (20€)

  • Log in as root and then type the following:
    update-rc.d quota disable


    Damn just rebooted OMV 1.0 and OMG this bug is there again, why do we not disable this at default and if someone really wants quotas to enable it later.


    grrrrrrr waiting......for quotas


    Agree w/ ryecoaaron. This is not a bug, but it should be disabled by default and enabled by the user if desired... However, I'm not sure how much Volker likes customizing the ISO's before he posts them.

    Air Conditioners are a lot like PC's... They work great until you open Windows.


    Edited once, last by KM0201 ().

  • Login as root from where, its starts duting boot, recovery starts quotas as well. i tried to type single behind the kernel line but somehow didn't work. I said bug in a joke way i know its not, but it should be disabled in the iso.


    Any tip for boot into single user with grub2 or any other way to disable it before

  • Login as root from where, its starts duting boot, recovery starts quotas as well. i tried to type single behind the kernel line but somehow didn't work. I said bug in a joke way i know its not, but it should be disabled in the iso.


    Any tip for boot into single user with grub2 or any other way to disable it before


    Do you have SSH access to the machine? If SSH has started, you might be able to run the command and reboot, and see if it will skip the quota check.


    That said, If it's already started... I would just let it finish... It shouldn't take more than 20-30min or so for most users. Once it's done it will boot normally, then make sure you disable it.

  • lol 20m its running already since me first post :-( i will look tomorrow morning but thanks for the help i don't remember what i did last time i believe i booted from a linux live cd and mounted root, but i am not sure.


    EDIT: it just finished disabling now :-D

  • its getting funny that every new user runs into this problem, yes it is a problem.


    No it's not. It's a feature that most people do not want... and they don't know to disable it. Obviously once it happens, and people are using Google and coming upon this thread... they realize they want it to be disabled.


    I wish it was disabled by default, but the fact that it's not, does not mean that it's a problem.

  • It is a problem when you have to wait minimum 20 min and in my last case about one hour to get your NAS booted up.


    It should be disabled by default to prevent this.
    When something does more harm then good being enabled by default it should be disabled.


    Well, now you're talking crazy. I don't disagree that it should be disabled by default.. but the reality is, short of having to wait a few extra minutes for the machine to boot, there is no "harm" from that comes from the checks being enabled. Annoyance? Yeah... but harm? that's foolishness.

  • I ran update-rc.d quota disable on OMV 1.9


    Here what I get :




    Is it ok ?

    Gigabyte GA-H87M-HD3, Pentium G3220, 4 GO DDR3, 6 x 2 To raid 6, 2.5' 100 Go for system
    Donator because OMV deserves it (20€)

  • Hello, I am trying to use OMV on my Raspberry Pi B+, and making NAS. I am using windows 8. I’ve got a little problem while booting.
    Scenario 1. Downloaded omv_rpi_1.9_split_for_hd_sd.tar.gz and wrote on 8GB Class10 micro sd and 8GB HP pen drive. --> inserted --> boot was smooth --> plugged in 32 memory card --> mounted and shared with different services. --> mounted 3TB WD HDD --> shared ... All working fine until I sent the command Reboot or power down or if power cut is there.
    It is not booting second time. IF I remove the 32GB pen drive “AND” hard disk and try to start , It will work smoothly --> again I have to mount it and share it manually up to next power cut or reboot.
    Scenario 2. Tried with omv_1.6_a_rpi.img.gz --> same problem. It runs smoothly up to next boot only.
    I think It is not starting up if “ANY” usb device other than OS installed device is plugged in at the time of boot.
    I reached this page and disabled quota and again tried .. not working
    Can anybody here understand, where the problem is?? That would be great help.

    Thank you...

  • With the split image, I think I used drive letters (sda) in the boot.ini file instead of a uuid. So, if there is more than one usb drive, the other drive might be sda. I don't know why the other image would have that problem though. It is looking for the OS on mmc. Does the screen give any errors? I will try to check this out later.


    By the way, using a pen drive for the second drive with the split image is defeating the point of the split image. The split image is to avoid wearing out flash media by using a mechanical hard drive or ssd.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • With the split image, I think I used drive letters (sda) in the boot.ini file instead of a uuid. So, if there is more than one usb drive, the other drive might be sda. I don't know why the other image would have that problem though. It is looking for the OS on mmc. Does the screen give any errors? I will try to check this out later.


    Thank you for the reply.. :)
    I run it through SSH over ethernet because I dont have screen. :P

    Quote


    By the way, using a pen drive for the second drive with the split image is defeating the point of the split image. The split image is to avoid wearing out flash media by using a mechanical hard drive or ssd.


    Yes but my hard disk is 2 tb used and if i want to mount split image to it, then it will formatted, so i went through pen drive mode. :P


    I tried using two different micro sd cards and two different pen drives also ...still struggling.. ?(:/

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!