• OMV: Syncthing 0.12.21
    Arch: Syncthing 0.12.21
    Android: Syncthing 0.12.20
    Have you guys noticed we've got the brand newest available version on OMV + a web ui plugin to manage it easily?-)


    Just realized that syncing via syncthing doesn't work with omv anymore! This is since the middle of may I realized.

    I know why now!
    All my clients (linux/mac/win/android) went automatically up to Syncthing v0.13.4 without interaction! The OMV-Syncthing-Plugin remains at v0.12.22, this is why they can't communicate anymore and syncing stopped working. :(


    Any news when the update arrives for OMV? Good Day!

  • on my omv is v0.12.15, Linux (64 bit) installed .. wft?!?!


    For my Linux workstations I use the the release channel provided by syncthing: https://apt.syncthing.net/



    ...it's running with v.0.13...


    Maybe this would be the right one for OMV?


    Before there was the plugin for OMV I used to use the "manual" way above... but with all restrictions (no gui integration in OMV/no easy setup/...)


    Would be nice if we get an update here ;)

  • Would be nice if we get an update here ;)


    That is the repo omv-extras has been using for over a year. My test system is on 0.13.4 with no changes.


    On OMV 2.x, if you disable the btsync repo, you disable the syncthing repo. Therefore, no updates.

    omv 5.5.22 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.4
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Quote

    On OMV 2.x, if you disable the btsync repo, you disable the syncthing repo. Therefore, no updates.


    Good to know!!! ;-)


    thx

    HP Proliant Gen8 with ESXi6.5


    Storage - Raid5 with 4 x 3TB WDRed - System on microSD / Datastore on Samsung 850Pro - 250GB


  • That is the repo omv-extras has been using for over a year. My test system is on 0.13.4 with no changes.


    On OMV 2.x, if you disable the btsync repo, you disable the syncthing repo. Therefore, no updates.


    I don't get it. I have the btsync repo enabled because syncthing remains in there. I installed syncthing this way.


    Am I right that there are no updates coming anymore for the btsync repo (=syncthing repo) for OMV 2.x?


    Can I substitute it by disabling the btsync repo in OMV and manual add the official syncthing release channel from apt.syncthing.net?


    Will it keep my settings? And will it update seamless?

  • Disabling the repo does not remove anything.


    There are no more btsync updates coming.


    Sure but why? The official syncthing release channel is enabled by enabling the btsync repo (just called sync in omv 3.x). Look at the output of grep syncthing /etc/apt/sources.list.d/*


    The updates and/or changing repos will not doing anything to your settings.

    omv 5.5.22 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.4
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!


  • I don't use btsync... I'm just using syncthing.


    I now did grep syncthing /etc/apt/sources.list.d/*


    Code
    /etc/apt/sources.list.d/omv-extras-org-stoneburner.list:# syncthing repo
    /etc/apt/sources.list.d/omv-extras-org-stoneburner.list:deb http://apt.syncthing.net/ syncthing release


    which looks good for me. But I don't get any(!) updates offered over the webfrontend?


    I did a apt-get update and apt-get upgrade
    and now I'm back in business with syncthing v0.13.5 :)


    Beside that the webfrontend stays empty I also have this error via apt-get update


    Code
    W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://apt.spideroak.com release Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 573E3D1C51AE1XYZ
    W: Failed to fetch http://apt.spideroak.com/ubuntu-spideroak-hardy/dists/release/Release


    In total it means I can safely disable the obsolete bt-sync repo and keep receiving updates for syncthing?


    Thank's for you help! I'm already heavily syncing again! :thumbup:

  • Hi OpenMediaVault,


    regarding

    Source Code


    W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://apt.spideroak.com release Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 573E3D1C51AE1XYZ
    W: Failed to fetch http://apt.spideroak.com/ubunt…rdy/dists/release/Release


    the solution is published here No updates via GUI, errors via CLI

    OpenMediaVault 5.x (most recent stable version) -- 64 bit -- OMV-Extras 5.x (most recent stable version) -- Default Kernel

  • You are missing the point. The btsync repo in omv-extras isn't just btsync. It enables the external syncthing repo, external btsync repo, and (in your version of omv-extras) external spideroak. btsync isn't the best name but it is fixed in OMV 3.x.


    No, you won't get syncthing updates if the btsync repo is disabled.


    You need to disable the btsync repo because the spideroak repo doesn't exist anymore.
    Update omv-extras which removes the spideroak repo.
    Re-enable the btsync repo.
    Update in Updates tab.

    omv 5.5.22 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.4
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hi all,


    I just had the same problem and enabled the BTSync Update. - So Syncthing received an update and started syncing with my Win7-Client again. But I cannot reach the Syncthning Web-GUI any more, resp. it says "unknown device" and shows no data, alos shows no version - so it is a more or less empty Syncthing Web GUI - what happend here and what shall I do ?
    Also my Android-phone doesn't do anything (beside saying "Fehler")


    I'm about to throw this syncthing stuff away as it appears to be not reliable enough (only if you spent half an hour on checking for updates on each machine every day)

  • So, here I was, thinking I could use the wonderful multi-user instance GUI config for syncthing in the OMV plugin, only to find it wasn't available to me when I pick the stable OMV version 2.*. I enabled the btsync repo, then got some really long error when I updated the repo, and lo and behold, it's related to syncthing. Bummer. I thought 2.* would be without such errors. And would give me that syncthing option.

  • The syncthing plugin is supposed to work on OMV 2.x. That is the version of OMV I wrote it for. "Really long error" doesn't help me. It works on my virtual machine.


    There is no syncthing client for armhf. Not much I can do to fix that.

    omv 5.5.22 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.4
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hi,


    I have conflicts with sync ".config/" directory.


    ".config/" is in home directory by default for all users, and users use SyncTrayzor on their machine where .config/ is also in their Windows home dir.


    Is it possible to add a specific location in the GUI to set this .config directory for each user and use it in init.d to the syncthing parameter "-home"


    Thanks in advance.

  • I understand but I marked it as wontfix since I don't have time to do this and there isn't enough demand for it.

    omv 5.5.22 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.4
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I'm running OMV 2.2.5 and would like to start using Syncthing. I notice the latest version of Syncthing is v 0.14.3 and that this version is not compatible with lower version clients. In OMV the plugin version is 1.9.2.


    Will this plugin work if other clients (Windows laptop/Android phone) require v 0.14.3? If no, is there a way to make this work?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!