Error #6000: exception 'OMVException' with message 'Failed to create the directory...

  • I just moved my computer to a different place. And when I plugged everything back and updated all the updates I had pending. I tried to create a share folder from one of my hard drives and got this error.



    I'm pretty new with all this stuff so I'm lost. I will appreciate any help! Thx!


    PD: I've tried to search in other threads but couldn't find anything that helped. The closest one I found is this one: Got Failed to mount '/media... Error #6000: (upgrade to 1.0 solved the original issue but created a new one )


    So I found out that the drive is listed in /etc/openmediavault/config.xml and the guy that solved the issue in that thread said that he did this:


    I removed the NTFS from /etc/openmediavault/config.xml.
    generated fstab and it worked.


    But I have no idea how he removed that NTFS, in my case CIFS share. And I have no idea what does he mean with generating a fstab.


    Thx!

  • Is the drive formatted as ext4 ??? Above you show the error but show how you are entering the settings to create the samba share. Are you trying to create the shared folder at same time you are creating the samba share? or was the shared folder already created?

  • The drive is formatted as ext4


    What I'm doing to set it up is:


    Services > SMB/CIFS > Shares (second tab) > +Add


    Then a window that says "Add share" appears. There I do the following:


    Enable: [Checked]
    Share Folder: -> "I click on the (+) sign and another window open.


    Add shared folder:
    Name: -> "the name I want"
    Volume: -> "I select the HDD i want to share"
    Path: -> auto populates as: "Backup/" which is the name I have to the share folder.
    Permissions: -> "I don't touch anything there."


    Then I click on save


    And that error message that I showed above shows up.


    Thx!

  • Here is the output of that command.


  • I don't know if this will help, but I have 2 hard drives connected to this machine. The third one is the main computer one. The other 2 are external hard drives.


    /dev/sda which is 4GB (it is where I have OVM installed)
    /dev/sdb 3 TB (This one I didn't have problem to share a folder from it). [This an external HDD]
    /dev/sdc 1.5 TB (This is the hard drive that is giving me problems creating a shared folder.) [This an external HDD]

  • Hello, may I repeat my question:


    Did you recently re-locate or delete any of your folders? The background of my question is if you are experience this problem:


    bugtracker.openmediavault.org/view.php?id=1083

  • new4u: I don't remember if I did delete or not something from that drive. I'm sure at some point I did, if the log from "$ ls -la /media/e95b642f-7f6a-4f1e-930d-156d6dcd61b0/" is right. Seems that what I have there is pretty much a backup from my other drive. Meaning that I should have the same stuff. But I'm not sure since it has been a while that I did not use that drive. So I wanted to create a share drive to check what is in there and delete stuff I don't need anymore. But I'm getting that error while trying to create the share folder.
    I'm pretty noob with this stuff, so I may be doing it wrong, but the steps above are the ones I'm following. I just followed what some tutorials taught me on youtube :P



    subzero79: The 4GB drive is an internal HDD in my machine. However, it is a VMware virtual drive.


    My machine has VMware ESXI with different virtual machines on the internal HDD. One of them is OMV with a 4GB drive space. OMV says that it still having 1.94 GB Available and 1.59 GB used.


    But the problem I'm having is creating a share folder with the 1.5 TB drive. and that just happened now that I moved my machine to a different physical location. I don't know if OMV got confused with driver names, or what is going on. That's why I need expert help :)


    Thanks!

  • Give a screenshot of Access Rights Management/ Shared Folders from the web gui.


    This seems to be his problem:


    $ $ ls -la /media/e95b642f-7f6a-4f1e-930d-156d6dcd61b0/
    total 472
    drwxrwsr-x 16 root users 4096 May 10 00:25 . <----------------------------
    drwxr-xr-x 6 root root 4096 Jun 2 02:43 ..

  • I hope this is what you mean.


    Screenshot


    When I tried to create that shared folder it appears there in the Access Rights management / Shared Folders. But I just deleted it because it is not working (I did this before you asked for the Screenshot). But when I get that error message the folder appears there in that window. But I cannot access from the Windows Explorer as I do with the other shared folder.


    Today I deleted that "Media" folder, disconnected all my drives from the machine. Restarted both the VMware ESXI and the OMV. Then reconnected both external HDDs, created the "Media" folder again and tried to create a share folder with the name "backup" with the second HDD.
    The "media" folder works as usual. But the "backup" one I'm trying to create still not working, same error message.


    Could be that the hard drive does not have enough space to create that share folder? Just wondering if that could be one of the factors.

  • In the information about I do not see the Media shared folder. It looks like when you created the shared folder with the + it shared the root of the data drive labeled Media and then you applied ACL. This ACL was the problem. Do not use ACL. Use privileges.


    Also, here is how you should create a Media folder. Do not do it via the Samba plugin.
    1) Go to Access Rights Management/Shared Folders and click on add.
    2) Put in Name "Media" and press Tab.
    3) Then select the volume and press "Save".
    4) Then click on the "Media" folder to highlight it and click on "Privileges"
    5) Assign read/write and read privileges to the users desired.


    6) Now go to the SMB/CIFS and click on the "Shares" Tab at the top.
    7) Click on and and then with the dropdown select the "Media" shared folder and click on "Save".


    Then you should connect via your PC and create other folders inside the Media folder once connected via Samba. You should be connected with the main user you want to write to the Media share. I only have one use that is read/write to my media and that is me.


  • tekkb, I've deleted all the shared folders from SMB/CIFS > "Shares" Tab and also from Shared Folders.


    I followed your steps and had no problem with the Media shared folder. Everything went great. That Media folder comes from the /dev/sdb1 HDD.
    However, when I went to do the same with my Backup drive from /dev/sdc1. I've got the same error message as before.


    Code
    Error #6000:
    exception 'OMVException' with message 'Failed to create the directory '/media/e95b642f-7f6a-4f1e-930d-156d6dcd61b0/Backup/'' in /usr/share/openmediavault/engined/rpc/sharemgmt.inc:414
    Stack trace:
    #0 [internal function]: OMVRpcServiceShareMgmt->set(Array, Array)
    #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
    #2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('set', Array, Array)
    #3 /usr/sbin/omv-engined(500): OMVRpc::exec('ShareMgmt', 'set', Array, Array, 1)
    #4 {main}


    I don't know if there is anything I can do to that drive. To the /dev/sdc1


    Thx!

  • Ok, I made some progress !


    I deleted one of the folders from the drive via SSH to make some more space. And that allowed me to create the shared folder! Yeah!


    However, now I have another issue. Now that I can create the shared folder from /dev/sdc1 when I go to a Windows machine and navigate to my server path. That "Backup" folder is empty. There are no folders.


    As you can see if I run the command asked before there is content in the HDD:



    So I don't know how to proceed now.


    By the way. I created the shared folder as you told me tekkb. So I followed those steps with Privileges, etc.


    Thanks!

  • Check that /etc/samba/smb.conf is pointing to the correct directory for the share. Otherwise it might look like you created the folder in the other disk.


    Try an apply reset permissions. next to shared folders is a utility.


    This is what shows on my /etc/samba/smb.conf



    So i guess is pointing correctly.


    I've also did the Reset Permissions on Shared Folders > Reset permissions.


    Selected my shared folder Backup on Shared folder. And I left Permissions as it was (Default). And checked the Clear ACLs.
    But it still empty my folder when I try to connect via Windows Explorer.

  • In the above smb.conf the backups looks fine but the media one does not. The media share is missing a bunch of stuff. I got feeling that the smb config file does not mesh with the config.xml either. You should not just randomly delete a shared folder via the command line either. It will cause problems because the necessary changes to the config.xml will not be made. Ugh...


    I would resintall and wipe the drives. You will not make the same mistakes and know you know correctly how to make the shares.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!