Replacement for the HP N54L - Or, My new [mammoth] home server :)

  • Oh no :-( well at least we know it's not reliable. I'll remove that section from the write up for now.

    Out of interest, do you have access to a Win install and AIDA64 on that same i7 box? I would be interested to see if AIDA64 thinks it's enabled.

    EDIT: I've just put a comment at the top of the ECC section. Maybe if we discover something else that is similar, I won't have to rewrite that section :)

  • I would be grateful if anyone with an ECC board and the ability to boot into a Windows environment could try this:

    Download AIDA64 (free trial) from here. Make sure you get the green Engineer edition, it is the most comprehensive (Extreme, Engineer, or Business will work), . Once installed, you should be able to get confirmation that ECC is enabled by looking at:

    Motherboard > Chipset point in the side menu and under the North Bridge then look for Error Correction.

    Particularly Only the information in the Chipset, as the support guys at AIDA64 say this is the indication of whether its running or not and all else isn't a sure fire indication.

  • My systems don't want to run Windows :D

    Just kidding. They are both production servers and I can't take them down to run Windows unless a VM would work?

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3 plugins source code and issue tracker - github

    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • :P not to worry. I don't want to disrupt your servers just for some info on ECC it was only if Windows happened to be installable on a spare drive and booted just the once for this.

    I don't think a VM would work because the VM may hide some of the details - might be worth a try though?

    There is a Linux audit extension here: which works with the blue business edition. This is also a free trial. However, it says that the extension just uses lshw to get the info so I don't think it'll be much help.

  • @ellnic : I disconnected the storage arrays on my two NAS at home and installed windows and AIDA64 on spare disks. It appears to report accurately, including specifics, in both casses....

    1. Supermicro X7SBL-LN2 (Intel 3200 Chipset): AIDA64 accurately identified the ECC Memory, and in the ECC Section ECC is "Supported,Enabled", with ChipKill and Scrubbing reported as "Unsupported". I think this is exactly correct for the Intel 3200 Chipset/Kingston DDR2 memory I have installed. So AIDA64 reported correctly and accurately including the details.

    2. MSI AM1I (AMD AM1 APU): This is the board I wrote about in another post that appears from every indication to have ECC capable hardware, but has ECC blocked by the BIOS. For this board, the ECC Memory is again correctly identified, while in the ECC Section, ECC is "Supported, Disabled". Which I think is also accurate. Interesting to note that AIDA64 was smart enough to recognize ECC support in the hardware, even though ECC is otherwise disabled by firmware.

  • @Markess thanks for checking that. It's good to see that, for whatever reason, AIDA64 might be the answer to checking for ECC functionality. What is particularly interesting - as you have pointed out - is that the ECC functionality on the MSI board shows as supported even though it's disabled. This to me, shows that AIDA64 clearly has some kind of check or ability that other software doesn't. Maybe this is a Windows kernel specific check, hence the ability is not available under Linux.

    My box shows the same as your Supermicro board, Supported, Enabled. If we can get just a couple of other positive reports like this, I'll alter the write up with the AIDA64 info.

    @bobafetthotmail I know you aren't keen to trust AIDA64, but this is looking promising.

    Edit: @ryecoaaron - appologies, I didn't see your post above with the screenshot. I don't know what the heck is wrong with Tapatalk at the moment but I didn't get a notification for either yours or Markess's posts in this thread. I only saw the one from Markess because I manually checked the thread. Anyway - excellent news. I will edit the write up when I get a chance over the weekend. :-) I think we have our winner.

  • I know. I was really hoping the Linux audit tool for AIDA64 would have been the answer, but I was disappointed to find out that it uses lshw.
    For whatever reason, proving that ECC is running under Linux obviously isn't something that many have ever felt the need to code for.

    There was a small program written in C by jack-kr123 on Hard Forum that was supposed to do it, but it never worked for me:…#UbuntuLiveCD-ecc_check_c

    Does it work for you? My result was just:

    ff ff ff ff
    ff ff ff ff

    Which was totally unhelpful.

  • I tried that some time back myself and got the same result as you.

    In the interest of science, I have an AMD AM3+ board known to function with ECC, I'll try AIDA64 on that as well, just to see if we can get a positive AMD confirmation too. Its not installed in anything at the moment, so it will take me a day or so to get around to it.

  • jack-kr123's program is only for intel i3 cpus. It won't work with hardly any other processors. I tried looking in the intel specs for the proper locations on an i7 and can't find the documentation.

    omv 5.5.2 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3 plugins source code and issue tracker - github

    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • @ellnic : One last test result on AIDA64.

    On an Asus M5A78L-M/USB3: Error Correction section returns ECC "Supported, Enabled" and ChipKill ECC "Supported, Disabled". In the case of ChipKill, the Memory Controller section indicates that its in "Dual Channel (128-bit) - Unganged" mode, and ChipKill, from what I understand for the K10 Processors, will only work if memory is ganged. So I'd say this is reporting accurately.

    This board has BIOS settings for Scrubbing, which I have set for DRAM and Cache, and AIDA64 reports that as well.

    I wanted to test this board because I know this model DOES support ECC, as its one of the few non-Supermicro boards that's known to work well FreeNAS. Theres's a decent amount of activity on the FreeNAS forums from users that includes reports of successful scrubbing, and log contents that show Error Correction and Error Correction logging taking place.

    So I'd say from the unscientific sample here, AIDA64's Chipset sections give back accurate data. Just need that Linux version now!

  • @Markess thank you for all your effort on this. The fact that you've been able to pair certain facts about the boards you have checked with what AIDA64 is reporting is invaluable.

    I'll alter the write up with the AIDA64 instructions over the weekend and, as we have all said, hopefully we'll find a Linux solution soon :-)

    Edit: Altered ECC check section with AIDA64 info. Thanks for all your help guys.

  • The G98 processor in the Quadro has a TDP of less than half that of the G96 in the GT9500 (I assume when you say "9500" its a GT9500?).

    So, I think, all things being equal, you're generating less overall heat even if the GPU temp is crazy.

    Those warning triangles on the heatsinks are no joke. I had one of those and it definitely got hot enough to burn you. Definitely needs a bit of airflow!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!