Failed to execute command 'export LANG=C; monit restart collectd 2>&1': monit

  • Hallo.
    Ich verzweifle!!! Ich habe den ganzen gestrigen Tag verschenkt, weil ich den OMV etwa an die 20 Mal neu aufgesetzt habe und immer wieder an die gleiche Fehlermeldung gestoßen bin:


    Failed to execute command 'export LANG=C; monit restart collectd 2>&1': monit: Cannot connect to the monit daemon. Did you start it with http support?

    weiter heißt es:



    Auffällig: Die Uhrzeit und das Datum stimmen kein Bisschen! Ich bin mal im März 2014, dann im August. Die Uhrzeit ist falsch und es läuft einfach nicht.


    Wie gehe ich vor:
    Ich bespiele die SD-Karte, boote das System und melde mich dann via SSH an, um das System zu aktualisieren. Dazu gehören:
    - apt-get update
    - apt-get upgrade
    - rpi-update


    Danach öffne ich die Konfiguration via
    raspi-config


    Hier stelle ich die Leistung ein und treffe eine Auswahl der Sprache, Tastaturlayout, Zeitzone, etc. (by the way: Selbst wenn ich das nicht mache, löst es nicht mein Problem).


    Wenn dann alles up to date ist, begebe ich mich auf´s Webinterface und konfiguriere das OMV. Leider ohne Erfolg. Ich bekomme IMMER (!!!) diese Fehlermeldung und weiß einfach nicht mehr weiter. Wo mache ich Fehler? Wer kann mich unterstützen? Ich habe mir Anleitungen und sogar Youtube-Videos angesehen. Ein Traum, wie einfach das sein kann... Hier definitiv nicht!


    Ich nutze OMV 1.17 (nach dem Update 1.19) auf meinem Raspberry Pi2.

  • Also zunächst gilt es einmal festzustellen ob der monit Daemon überhaupt läuft. Das wird wahrscheinlich bei Dir der Fall sein.


    Code
    # ps ax | grep monit


    Das kommt dabei raus:


    Code
    3343 ? Ss 0:00 /sbin/mdadm --monitor --pid-file /run/mdadm/monitor.pid --daemonise --scan --syslog
    3576 ? S 0:00 /usr/bin/monit -c /etc/monit/monitrc
    3678 pts/0 S+ 0:00 grep monit
  • Because ntpdate is installed in the image. Both ntp server and ntpdate cannot be installed at the same time. Also, the config for the ntp server does not work....


    apt-get --purge remove ntpdate


    Then in the OMV web gui set your timezone because after these changes you cannot set it again.


    then edit /etc/ntp.conf:



    remove these lines:
    server 127.127.1.0 # Local clock
    fudge 127.127.1.0 stratum 12
    server pool.ntp.org iburst


    And replace with these:
    server 0.no.pool.ntp.org iburst
    server 1.no.pool.ntp.org iburst
    server 2.no.pool.ntp.org iburst
    server 3.no.pool.ntp.org iburst


    Then you can:
    service ntp restart


    Do not disable/enable in the OMV web gui again. The mkconf file for the ntp service will overwrite thesechanges. There need to be some updates so it works properly with the rpi 2.

  • NTP does not allow to large time jumps, but this is forced by the OMV configuration.


    maybe you should think about adding a start script that uses ntpq (which has an option knob to emulate ntpdate) to sync the time.

  • A RTC module is only like 2-8 dollars. If you are serious about running OMV on this device it is well worth the investment.



    http://www.ebay.com/itm/New-DI…ain_0&hash=item5673f2ef1a


    http://www.ebay.com/itm/DS3231…ain_0&hash=item2a3c9ca960


    If you want them faster they can be bought on Amazon too, this is example for USA. Try to find seller in your country:


    http://www.amazon.com/Next-DS3…0&sr=8-15&keywords=DS3231

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!