Install of PlexMediaServer Plugin

  • Hey All:

    Please bear with me as I'm a complete n00b to OMV, but here's my inquiry. I have (4) HDDs in RAID5 with the OMV OS installed on a separate SSD. I have a video, pictures and music directory created and shared on the root filesystem of the four HDDs. The folders have permissions and ACLs to only allow specific users to edit, but all can view. I'd like to be able to stream my videos from my OMV NAS to my Roku (I suppose via Plex or miniDLNA). How do I go about installing Plex or the required plugins to make this happen. I've searched the forums but only found topics that pertain to errors relating to PlexMS, not a n00bie walkthrough to install it. From what I've loosely gathered I need to use the root user and apt-get install the plugin via a specific repo, but I don't know. Any help would be greatly appreciated. Thank you.

    Something like this?

    apt-get install openmediavault-plexmediaserver

    Now that I look at it...I think I installed OMV 2.0.13...sigh, oh well.


  • Thank you tekkb. I reinstalled v1.19 OMV, and installed PMS via the linked instructions. I did have to perform a purge of an old PMS to get the service to start. It works now with the plugins and the web gui. I have a directory called /media/d86*/plexmediaserver that has the following rights

    drwxr-sr-x 4 plex users 4096 Jun 27 16:40 plexmediaserver

    I shared that directory via Shared Folders and SMB/CIFS yet as a normal LAN user couldn't place files in that directory.

    I backed up and created a shared folder within that /media/d86*/plexmediaserver/ called Videos that I can copy videos to via the SMB. I set the PMS to look in that directory (see pic attached) and I still can't see any MP4 or AVI files via the PMS -- "The library has no content yet. Click here to add content to the library."

    Where might I be going wrong? Thank you.

  • First you should not call your media share plexmediaserver. Plexmediaserver has a working directory called plexmediaserver and you make things confusing by doing this. You should call your samba share "media". So path would be /media/UUID/media. Then in that samba share once you connect create folders like Music, TV, Movies, etc....

    cd /media/d86 then press TAB to complete the UUID number/
    stat plexmediaserver

    Give me the output of that stat command.

    Also, get rid of the ACL man. Take it off. Use privileges.

    See this is bad drwxr-sr-x

    Always try to use privileges first. Only use ACL when you have no other choice.

  • Thank you for the clarification.

    I have removed the Videos folder and created a media directory as instructed (/media/UUID/media).

    I think I've reset (via web gui?) the ACLs and the /media/UUID/plexmediaserver folder now has these permissions:

    drwx--S--- 3 root users 4096 Jun 28 09:30 plexmediaserver

    the stat plexmediaserver output is:

    File: `plexmediaserver'
    Size: 4096 Blocks: 8 IO Block: 4096 directory
    Device: 900h/2304d Inode: 19791873 Links: 3
    Access: (2700/drwx--S---) Uid: ( 0/ root) Gid: ( 100/ users)
    Access: 2015-06-28 09:46:58.694676928 -0400
    Modify: 2015-06-28 09:30:03.223048500 -0400
    Change: 2015-06-28 09:46:58.654678142 -0400
    Birth: -

    Noted on ACLs and privileges. Thank you so much for your guidance and patience I really appreciate it.

  • Is that the stat of the old folder that you made???? The media folder you should have used the default drop down when you created the shared folder. Are you creating a shared folder just with SAMBA???

    Make a shared folder in the Shared folder section with the default drop down that gives other read access which PlexMediaServer needs
    Then share it with SAMBA in the SMB/CIFS section

    @ryecoaaron we so need a video on this. It gets so old.

  • So having nothing else working on the OMV server I reinstalled OMV OS (plus I was running into a wall where the PlexMediaServer appeared to have a corrupt database?, anywho) and figured I'd document my attempt from the get go.

    Key notes:

    Default Web GUI Username: admin
    Default Web GUI Password: openmediavault
    Do NOT use ACL.

    These are parameters that are unique to my configuration, if you see these please replace with you appropriate information.

    OMV Server LAN IP:
    Physical Disks: (4) 1 TB HDDs & (1) 120 GB SSD
    RAID UUID: 9e215*
    Filesystem: OMV v.1.19 (Kralizec) OS on SSD and RAID10 on remaining HDDs
    My Media Directory: mymedia

    1) (via web GUI) System > Update Manager > Check (button) > Select All > Upgrade
    2) Download the omv-extras plugin to your local PC > (web GUI) System > Plugins > Upload (button) > select the newly downloaded *.deb file.
    3) (web GUI) System > Plugins > openmediavault-omvextras 1.29 (check button) > Install > Yes > Done
    4) (web GUI) System > > enable Plex (check button) > Save > Apply > Yes
    5) (web GUI) System > Plugins > Multimedia (section) > enable openmediavault-plexmediaserver 1.0.12 (check button) > Install > Yes > Close > Ok
    6) (web GUI) Services > Plex Media Server > select your database volume (mine was my RAID array), select the Enable (button) > Save > Apply
    7) Your Database folder will be updated from the /var/lib/plexmediaserver to /media/UUID/plexmediaserver This folder is the root directory for the Plex Media Server application. DO NOT install anything within this folder, think of it as the equivalent to "C:\Program Files" on windows. All the important stuff is in there to make the magic happen.

    8 ) Okay so now that it's installed let's create a shared folder. (web GUI) Access Rights Management > Shared Folders > Add > Give it a name, select the volume, the path will auto populate, and don't touch, just verify that "Others" have at a minimum read access to this directory in the Permissions > Save > Apply

    9) Assuming your planning on using Windows to upload the media and stream it via Plex Media Server, don't forget to enable SMB/CIFS sharing. (web GUI) Services > SMB/CIFS > Enable > Save

    10) Let's share the newly created folder. (web GUI) Services > SMB/CIFS > Shares (tab) > Add > select the newly created shared folder and leave everything as-is. You may notice I enabled recycle bin, but that's merely a preference > Save > Apply

    11) Create a user if necessary. I'll assume you can do that via the web GUI.
    12) Now via your windows PC go to the newly shared mymedia (or whatever you called it) directory and create the sub-directories as desired. I personally followed suit with Plex Media Server and added - music, tv, movies, pictures, and home_movies. But you can organize it as desired. Put just a file or two of a TV show or music mp3...etc. in the directory for testing/validating purposes.

    13) Now let's add the newly shared and created directories to the Plex Media Server. (web GUI) Services > Plex Media Server > Settings (tab) > select the Plex Web Client (button) > a new tab/webpage will open to the Plex Media Server interface > Accept the ToS

    14) Select the Add Library Icon (+ sign) > Select TV Shows > Next > Now navigate to your newly created TV folder it should be called /media/UUID/mymedia/tv in my case > Add > Save > Hopefully your Plex Media Server will have found the TV shows you shared in that directory. I've modified the library to rescan on an interval, to do such go to wrench icon in the corner > Server (gray tab on upper right) > Library > then enable Update my library periodically. viola

    Hope this helps & thanks a million tekkb, I couldn't have done this without your guidance and patience. Cheers!

    Also, if I've done something silly, please do call me out. But at present I managed to get the tv directory working and assume (danger!) that the others will work accordingly. Thanks a million!

  • Thank you. Yeah I debated about the recycle bin, but opted to have it purge every so often. I do have a follow-up inquiry that might need to be broken out into another thread, but it stems from a partially incomplete setup as aforementioned

    I'm running into the issue that newly user created (via Samba) sub-directories and files cannot be edited/deleted after the fact; from both the creator PC and a fellow user's PC.

    It seems that my new files and folders are defaulting to read/execute in lieu of read/write/execute for the users. (note: I viewed this via the web GUI but did not apply any changes)

    I thought having the "Honor existing ACLs" would default the new folders and files to the parent folder's rights.

    I tried to test this on a completely separate folder, that was 100% public (Permissions = "Everyone: Read/Write" at inception; SAMBA = Public: "Guests Only"; SAMBA = "Honor Existing ACLs") but even still newly created sub-directories couldn't be deleted or modified as I didn't have permission. Any ideas? Thanks.

  • So I tried replying yesterday when I believe I figured out the issue, but it never accepted my reply. If this one goes through, I'll try again when I return home. Long story short, read the POSIX permissions for Samaba, that default to 755 (aka only you have rights to stuff you create initially). - OMV General POSIX File System Permission Balance: chmod – chown – setgid - umask concepts

    Edit: well since it posted, I'll upload my pictures and fixes as I've encountered it this evening. Thanks.

  • Okay, here goes for the fourth time as best as I can remember.

    So the lesson that fellow greenhorns should take to heart is that if they are having R/W problems on their server via Samba, it may be the default nature of Samba (755), which " all your files will not be writable by other than you. Other users might read it."

    So to correct that, the simpliest way to to reset the ACLs (assuming you've done the prior steps to get Plex up an running) and use the Reset Permissions option via the previously installed plugin.

    1) Shared Folders > Reset Permissions (tab) > select the folder in question, select the desired permissions (e.g. rwxrwxr-- ...etc.) , enable the Clear all ACLs > Save > a new dialog displays showing the resetting process > Done (or Close, I can't recall)

    2) Now it's time to enable/toggle the Enable permission inheritance option of Samba. SMB/CIFS > Shares (tab) > select the folder > Edit > Enable the "Enable Permission Inheritance" > Save > Apply

    3) Now the most important step...reboot the server.

    After you do this, you should, in theory based on my limited understanding have the aforementioned permissions (not privileges) for the desired folder accessible via Samba. Just tested it on my roomie's PC to see if it worked, and yes it resolved my follow up issue. Hope this helps someone else. Thanks again everyone!

  • Hello, I have attempted to follow the step by step from smokingplatypus on July 1st to properly get PMS going on OMV. However, i get a roadblock on step 13. The PMS web-gui will not load ("webpage is available"). I know tekkb has helped others figure this out in specific circumstances, hopefully he can with mine! I've attached a pic of my system. In services PMS is enabled but Running has a red light. I've attempted "/etc/init.d/plexmediaserver start" which leads to "Starting Plex Media Server: done". But then when i "/etc/init.d/plexmediaserver status" it always states "It seems that Plex Media Server isn't running (no process found)." Also, when i "stat plexmediaserver" and "id plex" this is the result:

    root@OMVServer:/media/5d3465f2-52fa-477b-a915-deb30d0942c9# stat plexmediaserver
    File: `plexmediaserver'
    Size: 4096 Blocks: 8 IO Block: 4096 directory
    Device: 821h/2081d Inode: 77463553 Links: 3
    Access: (2755/drwxr-sr-x) Uid: ( 112/ plex) Gid: (65534/ nogroup)
    Access: 2015-11-15 20:08:42.915487149 -0500
    Modify: 2015-11-15 19:51:14.659423489 -0500
    Change: 2015-11-15 20:08:42.919487239 -0500
    Birth: -
    root@OMVServer:/media/5d3465f2-52fa-477b-a915-deb30d0942c9# id plex
    uid=112(plex) gid=116(plex) groups=116(plex)


    root@OMVServer:/media/5d3465f2-52fa-477b-a915-deb30d0942c9# dpkg -l | grep plex
    ii libmpc2:amd64 0.9-4 amd64 multiple precision complex floating-point library
    ii openmediavault-plexmediaserver 1.0.12 all OpenMediaVault Plex Media Server plugin
    ii plexmediaserver amd64 Plex Media Server for Linux

    Any help would be appreciated!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!