no webui nginx error with ssl certificate after recent updates

  • Good morning guys, after the last update I find no access to the web server and when I try to restart the service nginx I get this error:



    what is happening? and especially as I fix


    thanks for help

  • Which software version are you using? How did you install the update? Are we talking about the OMV webgui or Owncloud?


    Please tell us your OMV version and paste the file /etc/default/openmediavault here.


    When you are using 2.0.15 I assume your file is missing


    Code
    OMV_SSL_CERTIFICATE_DIR="/etc/ssl"
    OMV_SSL_CERTIFICATE_PREFIX="openmediavault-"


    because you installed the package update via 'apt-get upgrade' manually and not 'omv-update' or the WebGUI.


    After you've added the missing ebvironment variables recreate the nginx config and restart the service


    Code
    # omv-mkconf nginx
    # service nginx restart

  • not worked, David



    its the OMV webui, and now that I look... owncloud does not work either
    I have the latest version OMV and all packages, This has happened to me after installing the latest version of OMV-extras, I think!


    this is my file /etc/default/openmediavault



    votdev, I have always used webui to update



    i dont know how rebuild missing ebvironment variables??
    and then do everything you tell me is still not working

  • Hello,


    Fresh installation of OMV 2.1.
    Installed nginx plugin.
    Pool configured. Then trying to set new server with SSL and getting this error:

    Failed to execute command 'export LANG=C; nginx -t 2>&1': Site configuration file 'openmediavault-nginx' not found. nginx: [emerg] SSL_CTX_use_certificate_chain_file("/certs/b167d8f5-1755-4639-b0ef-f286f52451ca.crt") failed (SSL: error:02001002:system library:fopen:No such file or directory error:20074002:BIO routines:FILE_CTRL:system lib error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib) nginx: configuration file /etc/nginx/nginx.conf test failed


    what is more it crashes also OMV WebUI - it's not accessible anymore, so only omv-firstaid help to fix it.
    server w/o SSL works with any problems.

  • Did a little more investigation.


    I have in /etc/default/openmediavault, variables:
    OMV_SSL_CERTIFICATE_DIR="/etc/ssl"
    OMV_SSL_CERTIFICATE_PREFIX="openmediavault-"


    ...but on the other side here is how ssl config looks like in openmediavault-nginx:


    ssl_certificate /certs/b167d8f5-1755-4639-b0ef-f286f52451ca.crt;
    ssl_certificate_key /private/b167d8f5-1755-4639-b0ef-f286f52451ca.key;


    ...so, directry and prefix for a file is inccorect.


    Correcting directory and prefix for a file fix the issue.
    But it's manuall work :(

  • HK fixed the cert location. Update is in repo now.

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I had exaclty the same problems.
    At the weekend i tried to post my message here in the forums but there were some strange posting-issues which are now fixed. (not all i think!)


    I recently found the latest changes to the ssl-certificate config here:
    https://github.com/OpenMediaVa…6317ae1e38e9f33d504c663ed


    and was able to fix the problem by myself.
    If someone stumbles over this problem one should take a look at the corrected openmediavault-nginx above.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!