Posts by cactus-online

    Thanks for this cook book. For me were there some little changes necessary.


    Hallo,


    ich versuche gerade meinen HP CP1515n Netzwerk-Drucker in OMV 4.1.6 zu konfigurieren. Dabei schlägt etwas fehl:


    Error #0:
    OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; omv-cups-avahi 2>&1' with exit code '1': Traceback (most recent call last):
    File "/usr/sbin/omv-cups-avahi", line 298, in <module>
    files.append(genPrinterService(p, v, False))
    File "/usr/sbin/omv-cups-avahi", line 120, in genPrinterService
    port_no = self.port
    NameError: global name 'self' is not defined in /usr/share/php/openmediavault/system/process.inc:175
    Stack trace:
    #0 /usr/share/openmediavault/engined/module/cups.inc(129): OMV\System\Process->execute()
    #1 /usr/share/openmediavault/engined/module/cups.inc(105): OMV\Engined\Module\Cups->regenerateServiceDefinitions()
    #2 /usr/share/openmediavault/engined/rpc/config.inc(194): OMV\Engined\Module\Cups->startService()
    #3 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
    #4 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
    #6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(565): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusGz...', '/tmp/bgoutputtK...')
    #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
    #8 /usr/share/openmediavault/engined/rpc/config.inc(213): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)
    #9 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
    #10 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #11 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)
    #12 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)
    #13 {main}


    Bevor ich das tat, hatte ich bereits Airprint aktiviert. Ob es einen Zusammenhang gibt weiß ich nicht und kann es auch nicht erkennen. Jedenfalls kann ich kein Apply machen, der Drucker ist aber trotzdem da und ich kann auch eine Testseite im WebUI auslösen. Airprint klappt nicht.


    Leider kann ich gar nichts mehr konfigurieren, da bei jedem neuen Log


    The configuration has been changed. You must apply the changes in order for them to take effect.


    kommt. Weder Revert noch Apply funktionieren.


    Wo könnte ich suchen, um das Problem einzugrenzen. Ich bin für jeden Tipp sehr dankbar !


    lg.


    cactus-online

    Hallo,


    bei der Verwendung von verschlüsselten Platten und NFS gibt es ein großes Problem - wenn ich nicht etwas total falsch mache. Ich habe RAID5 konfiguriert. Das entstandene Mapper-Device (bei mir /dev/md127) habe ich verschlüsselt. Das entstehende LUKS-Mapper-Device ist /dev/md127-crypt. Darauf habe ich dann mein shared-FS (Volume share-1) angelegt. Darauf habe ich dann u.a. einen share camera-1 angelegt, der auf dem Volume share-1 auf das Verzeichnis camera-1/ zeigt. Dieser share ist per nfs exportiert.


    Nach einem Reboot gibt es (logischerweise) /dev/md127-crypt noch nicht, da es erst mittels passphrase geöffnet werden muss. Leider exportiert der NFS-Server jedoch seine exports schon, obwohl die mounts (in meinem Fall /dev/mapper/md127-crypt on /export/camera-1 type ext4 (rw,noexec, ...) ) noch gar nicht existieren. Das führt dazu, das auch nach dem Öffnen des LUKS-Devices per NFS nichts mehr vernünftig exportiert werden kann. CIFS dagegen klappt. Ich stecke jetzt nicht so tief drin. Ich bin mir nicht ganz sicher, wie die mounts für die NFS Exports erzeugt werden. Auf jeden Fall müssten meiner Ansicht nach nach dem Öffnen des LUKS-Devices die mounts für den NFS Export erzeugt und der NFS-Server neu gestartet werden.


    lg.


    TF