Posts by fightforlife

    Last Post. I hope somebody has a solution.



    Fresh image install. All Cups files are owned by root and most are 755. Cupsd is started by root. root is member of the lpadmin group.
    if I change the permissions of the files to 777 the web interface says "not found" and the logfile says unsecure permission settings.


    Standard errorlog for all Cups Tabs:


    Code
    D [22/May/2016:21:54:16 +0200] [CGI] Started /usr/lib/cups/cgi-bin/admin.cgi (PID 10550)
    I [22/May/2016:21:54:16 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=10550)
    D [22/May/2016:21:54:16 +0200] cupsdSendCommand: 14 file=15
    D [22/May/2016:21:54:16 +0200] PID 10550 (/usr/lib/cups/cgi-bin/admin.cgi) stopped with status 113 (Permission denied)
    D [22/May/2016:21:54:16 +0200] cupsdWriteClient: 14 Closing because Keep-Alive disabled

    I cant edit so here follows:


    root@BPI:/usr/lib/cups# ls -al
    total 40
    drwxrwxrwx 10 root root 4096 Jul 20 2015 .
    drwxr-xr-x 53 root root 4096 May 27 17:52 ..
    drwxr-xr-x 2 root root 4096 Jul 20 2015 backend
    drwxr-xr-x 2 root root 4096 Jul 20 2015 backend-available
    drwxr-xr-x 2 root root 4096 Jul 20 2015 cgi-bin
    drwxr-xr-x 2 root root 4096 Jul 20 2015 daemon
    drwxr-xr-x 2 root root 4096 Jul 20 2015 driver
    drwxr-xr-x 2 root root 4096 Jul 20 2015 filter
    drwxr-xr-x 2 root root 4096 Jul 20 2015 monitor
    drwxr-xr-x 2 root root 4096 Jul 20 2015 notifier

    I just tried to your 2.2.1 Image for my Banana Pi M1.


    But CUPS Plugin isnt working. I always get "internal server error" trying to access any of the tabs on the CUPS webpage.
    It seems to be a permission problem...


    On OMV3 Cups is just wroking fine, but many other things are broken.