Posts by luxflow

    there is omv-zfs plugin in both OMV 2.x 3.x and support importing disk
    if you can import zfs disk in OMV 2.x, I'm sure it will works in 3.x


    I'm currently fixing omv-zfs and omv-zfs 3.x has little bug
    Do not use omv NFS share for zfs filesystem (but workaround is exist)

    as I know cp stands for copy
    /usr/sbin is in path environment variable, you can see all global path `echo $PATH` (similar windows %PATH%)
    more detail, there is article


    I cannot 100% sure what is need since I don't have HFS file
    but according this blog you need

    Code
    sudo modprobe loop
    sudo modprobe hfs
    sudo modprobe hfsplus

    before


    mount -o loop -t hfsplus /tmp/my-disk-image/sparsebundle.dmg /mnt/my-disk

    Quote

    Note: If your FUSE installation is in a non-default location you may have to export PKG_CONFIG_PATH before compiling.

    you don't need to set PKG_CONFIG_PATH since your fuse installed by debian package and it is installed in default location


    just

    Code
    curl -L https://github.com/torarnv/sparsebundlefs/tarball/master | tar xvz
    apt-get install libfuse-dev fuse
    make

    and follow usage

    Code
    #completely remove old letsencrypt
    apt-get purge openmediavault-letsencrypt
    #remove letsencrypt directory
    rm -rf /etc/letsencrypt
    #reinstall
    apt-get install openmediavault-letsencrypt

    @Ruschi
    First remove le cronjob in OMV, and try this script to completely remove omv-letsencrypt and reinstall
    After that try generate letsencrypt cert again

    I cannot understand your problem
    Please describe more detail what is your issue and what you did also what you want


    You don't need choose LE in nginx manually (I'm not sure what you mean choose LE in nginx)
    omv-letsencrypt do all things automatically you don't need to manually edit nginx configuration


    enable `Schedule Refresh` -> put your domain in `Domain`, email in `Email`, '/var/www/openmediavault/' in `WebRoot` -> save & generate certificate

    googling following keyword


    tvserver nginx reverse proxy
    couchpotato nginx reverse proxy
    nextcloud nginx reverse proxy


    give you application specific reverse proxy configuration


    if you use same domain, only different thing is path (/tvserver /couchpotato /nextcloud)
    you just get only one cert from LE for that domain

    But after rebooting OMV I had again three SNAT rules in iptables Is the rule added for every interface that exists on the system? Because I have exactely three interfaces (included the tun0 device from OpenVPN). It doesn't hurt to have them there, just would like to have confirmed this looks normal to you guys too.

    yes you're right it seems bug, iptables rules is applied multiple (number of interfaces) which should be applied once
    I will open issues for this isseus (and also suggest plugin developer to use masquerade instread of SNAT)



    What is weird now is that when connected over VPN all my browsers (Chrome, Edge, Firefox) are able to load all web resources (internet & local web pages). Also I can access my SMB share through windows explorer. I swear it wasn't working before I had added the MASQUERADE rule. I am puzzled why it does work now

    as I stated above,


    SNAT and masquerade are similar except that SNAT works with static IP, msquerade can works with dynamic ip


    But, for home users, most user uses dynamic IP, so omv-openvpn cannot route your internet packet whenever ip is changed

    My guess is that omv-openvpn plugin set 192.168.1.10 but your omv server ip was something other than 192.168.1.10 due to dhcp, so NAT didn't work that time (this is my guess I don't know why it was)
    so I recommend set your ip (192.168.1.10) static, but also beware of your router not to assign that static ip for other devices (ip collision)

    sorry I give wrong information check again my previous post
    not
    `iptables -t nat -A POSTROUTING -s 10.8.0.0/24 -j SNAT --to 192.168.1.10` to add
    but
    `iptables -t nat -D POSTROUTING -s 10.8.0.0/24 -j SNAT --to 192.168.1.10` to delete


    (A,D changed)



    @florianb
    SNAT rules are automatically added by omv-openvpn you up your interface
    so don't need to add iptables-persistent config file.
    remove all is ok


    for your environment
    you should have two NAT
    first is 10.8.0.0 <-> 192.168.1.10 <-> internet IP
    router do NAT for 192.168.1.10 <-> internet IP (they uses masqurade here since most isp uses dynamic ip)
    but OMV should do NAT for 10.8.0.0 <-> 192.168.1.10 (masqurade or snat)




    don't know why your SNAT rules was't working
    and masqurade worked, as I know your two rules(masqurade,snat) are same