Posts by luxflow

    issue three times below command to remove all SNAT rules
    `iptables -t nat -D POSTROUTING -s 10.8.0.0/24 -j SNAT --to 192.168.1.10`
    or
    `iptables -t nat -D POSTROUTING 2` means delete second rule
    `iptables -t nat -D POSTROUTING 3`
    `iptables -t nat -D POSTROUTING 4`




    your iptables is set to always uses MASQURADE rules first
    and uses SNAT rules second third, fourth


    what is your output `ifconfig eth0`

    Basically omv-openvpn do the jobs for you (don't need masquerade) since it add SNAT routing rules


    SNAT and masquerade are similar except that SNAT works with static IP, msquerade can works with dynamic ip


    But, for home users, most user uses dynamic IP, so omv-openvpn cannot route your internet packet whenever ip is changed
    so check `iptables -t nat -L` to see how your SNAT rule is set and check your current ip using ifconfig
    and ensure both ip are same

    roughly,
    lan speed 1000Mbps = 125MB/s
    most consumer hdd have 100MB/s sequential read
    (if you use raid 0 or similar, speed will be double, failure rate is also double)


    you cannot exceed 125MB/s if you share files via ethernet (bottleneck)
    there is also filesharing program overhead


    so.. I think your speed is normal


    ===
    changed unit according to @gderf's advice
    thx!

    @hoppel118
    hmm I think there are package collisions between zfsonlinux repo and debian repo
    I can see collision in your logs (sorry below is translated one)


    Code
    Unpacking zfsutils-linux (0.6.5.8-2 ~ bpo8 + 1) ...
    Dpkg: Error editing archive /var/cache/apt/archives/zfsutils-linux_0.6.5.8-2~bpo8+1_amd64.deb (--unpack):
    Try to override /sbin/mount.zfs, which is also in package zfsutils 0.6.5.7-8-jessie
    ...
    Dpkg: Error editing archive /var/cache/apt/archives/zfs-zed_0.6.5.8-2~bpo8+1_amd64.deb (--unpack):
    Attempt to override /lib/systemd/system/zfs-zed.service, which is also included in package zfsutils 0.6.5.7-8-jessie


    So there are collisions between zfsutils in zfsonlinux and zfs-zed, zfsutils-linux in debian official repo



    It's not possible to enable "zfs testing repo" anymore after the last changes from @ryecoaaron according to zfs.

    I'm not sure why you can't do this, can you point what change was made?
    (also try enable testing omv-extras)


    Suggested my solution is

    Code
    # clean ZoL already installed packages
    apt-get autoremove debian-zfs libnvpair1 libuutil1 libzfs2 libzpool2 zfsutils spl-dkms zfs-dkms openmediavault-zfs
    # reinstall omv-zfs
    apt-get install openmediavault-zfs


    By the way, @ryecoaaron I think it is good to remove zfsonlinux in ZFS stable repo in omv-extras plugin
    Since backport zfs package is compatible with debian, proxmox, debian-backports kernel


    Sometimes debian-backports kernel doesn't support zfs due to backports kernel update
    Then we have options such as debian, proxmox kernel

    omv-zfs 3.0.6 is released. you can upgrade as soon as @ryecoaaron upload it


    whats new?

    • Fix snapshot creating
    • Add snapshot rollback
    • Add force pool import option
    • Add zfs zed notificationomv-zfs

    zed is zfs event daemon utility. more detail is here
    so, you can just enable it by clicking omv -> notification -> notifications -> ZFS ZED button


    Unfortunately there is bug currently zfs-zed (not omv-zfs, and it will be fixed soon I think)
    so after install omv-zfs,

    Code
    ln -s /usr/sbin/zed /sbin/zed
    systemctl restart zfs-zed

    Generally, seperating socket is recommended for security reason
    Also if one socket is blocked then sites using that socket will be also blocked


    there are two sockets by default in omv
    one is /var/run/php5-fpm-openmediavault-webgui.sock (for openmediavault website)
    the other is /var/run/php5-fpm.sock (this is installed by debian php package)
    so, if you uses php5-fpm socket, omv site is already seperated


    I don't think you don't have to seperate anymore for personal uses

    Ok. From what I understand is if I use the php-fpm-pool, then it will set the socket as $socket.
    The $socket is then pass as a variable to php_use_default_config.
    But the php_use_default_config is also allow me to use my own socket if it's unchecked.

    if I use the php-fpm-pool -> if I use `Enable php` option


    php_use_default_config option control how nginx handle .php extenstions
    for example, if you want to use .ppp extenstions
    turn off this option, and write


    Code
    {
    location ~ \.ppp$ {
    include snippets/fastcgi-php.conf;
    fastcgi_pass $socket;
    }


    if you set vhost extra options like

    Code
    fastcgi_pass unix:/var/run/php5-fpm.sock

    you don't need to enable both `enable php` and `default config`
    By default, openmediavault have /var/run/php5-fpm which is not seen omv-nginx pools tab (hidden)
    checkout

    Code
    vim /etc/php5/fpm/pool.d/www.conf