Posts by Luke

    Filesystem EXT4.
    It seems to be a rough electric issue.
    I tried 4 power supply, the same used for cellphones, all of them 5V and 1.5 A. It not seems to be differences between them.
    1 on 4 works fine, the hd is working, but i didn't understood why.


    However, i think i've asked something out of the scope of this forum...
    I was curious about other member's experience about external hd's power supply.


    Thanks a lot !
    Luke

    Hi to everyone,


    I'm in a little trouble with the 3,5" hd connected to my rpi.
    I use an external box adapter with the 5V power plug. The external power supply gives 1.5 A, the HD requires 700 mA to works.
    There's no way to view the hd, I tried a lot of 5V power supply, even when powered stand-alone without a power-strip.
    I've also tried a power bank.
    That box connected to my pc (so, without the 5V power), works great.


    3 questions:

    • any suggestions for my problem ?
    • Is there some option to manage the power supply via software ?
    • may I use an usb key as external drive ? (I do not need so much space, although it is a pity). If so, any key to suggest ?


    Thank you !
    Luca

    I tried with a usb key, but the automount does not work.
    I have to manually mount the key and then execute the backup, and works fine.


    Another question. When the backup has ended, I can just unplug the key or I have to unmount the key before ?

    Hi,


    I'm trying to configure USB backup so that, when I plug an external USB drive (an external 3,5" hd),
    the system starts the backup to the external drive, with pre-configured options.


    At the moment, I have to mount the usb drive and start the backup manually.
    Is there a solution so that the backup starts when I plug the drive (with automount)?
    I don't want to let the drive always plugged in (it's an old, noisy 3,5 hd).


    Thank you !

    Hi,


    before posting the issue I found during the OC installation (most all of them due to my newbie, of course),
    I want to ask this: do someone use OC with RPi 1 ?
    Because I fear that OC requires a lot of resources.


    First of all, is the guide complete, or it must be added something ? I mean, I read the many of the pages
    of the post, and are indicated some solutions to insert (like SSL, extra-options in nginx), but I can't
    understand if they are suitable for everyone or are specific solutions for the user who posted the question.


    Following the guide, when I have to choose the folder where to install OC, the browser goes in timeout.
    Re-opening the setup-owncloud.php, the system tells me: OC is NOT installed. There's already an installation
    of OC in this folder...".
    Actually, the folder is now filled with the installation files, but when I try to create the admin account,
    the system always goes in timeout and the CPU is always at 100% load.


    In the OMV main panel I can't find OC in the services (should I find it ?)
    I can't understand if OC is installed or not.


    Now, a couple of question about OMV .


    1- Without OC, what is the best interface to use to access the NAS file, by a smartphone or a pc ?
    The only one I found is an FTP client, is this the best solution ?


    2- How I can access the OMV installation files with a GUI ? I mean, the three partitions that are created
    in OMV installation. I can do that only plugging the sd card in my Linux Mint system.


    Thank for your patience, but the language and my linux newbie makes all this difficult for me.

    Just to understand the whole system, sometimes I have some difficulties with user's privileges and authentications and maybe there's something to do there.

    Hi,


    can someone tell me how to recreate the "Pi" user which is created
    in the original installation of OMV ?
    What were its permission ?
    Can i import it from a file ?


    I deleted it and I want to recreate it.

    I'm not sure I've understood this:


    Quote from ryecoaaron

    You would have to create the raid array on something other than OMV. OMV doesn't use partitions for raid arrays.

    What do you mean with "Create the raid array" ?
    The raid selection in the menu is for what ? Now I just have 1 hd, then I cannot try it.


    I installed Rsnapshot and USB backup plugin, I can't see the difference between them.
    It seems that both allow you to select a folder to backup and a target folder where to write it.


    Are you saying that I have to create the partition before plug the HD to the rasp ?
    Do you know what can I use other than OMV ?

    Hi,


    I want to show you my project so you can tell me what you think about it
    and if I'm forgetting or wronging something.


    I have a raspberry one with OMV installed to create a NAS.
    Two hd 2,5" in RAID 1 (always powered on) plugged in an external usb hub with external power,
    the hub plugged in the raspberry. Here I want the maximum security level.
    The RAID content is for important files (photo, ecc...).
    An hd is bigger than the other one (500 vs 320 GB), the RAID
    partition will be 320 GB, obviously.


    The remaining space will be used for low-important data, and
    maybe used to be accesible to other user with a password
    (or other ways ?).


    I want to use a third HD, and old 3,5 ", to manually backup the
    RAID content, and be manually powered on.


    This is my project, do you think it is feasible, do you notice
    some critical issue ?
    Do the RAID works with logical partitions too, or only with whole physical HD ?
    How can I simply manage the manual backup in the third HD ?


    Any suggestion will be accepted, thank you !

    Hi,


    the installation is ok with that image.
    After the image writing, I gave:


    apt-get update && apt-get dist-upgrade && omv-update


    Here I had all the possible problems with the php5-fpm packet, and I installed it manually:


    wget http://omv-extras.org/debian/pool/main/p/php5-pam/php5-pam_1.0.3-2_armhf.deb
    dpkg -i php5-pam_1.0.3-2_armhf.deb
    reboot


    At this point I could not reach the address via http, and I solved this way:


    sudo rm /var/lib/apt/lists/* -vfsudo apt-get updateThen I tried to upgrade to the latest version:omv-release-upgradebut I had a lot of errors, and I read that there are problems with the latest version of OMV, and I tried the downgrade:
    wget http://packages.openmediavault.org/public/pool/main/o/openmediavault/openmediavault_3.0.4_all.debdpkg -i openmediavault_3.0.4_all.deb


    but I've got errors:
    openmediavault openmediavault-flashmemory openmediavault-omvextrasorgCreating index of upgradeable packages ...Creating index of openmediavault plugins ...E: Sub-process /usr/bin/dpkg returned an error code (1


    )and I tried an apt-get -f install to solve and I've got:
    Errors were encountered while processing: openmediavault openmediavault-flashmemory openmediavault-omvextrasorgCreating index of upgradeable packages ...Creating index of openmediavault plugins ...E: Sub-process /usr/bin/dpkg returned an error code (1)


    I know I made a mess and surely I forgot some command and output errors, but I'm working on it since many days. I'm just trying to update OMV to the latest (stable) version after the image writing. Any help is welcome, thanks !

    Yes, I have Raspbian.


    The installation process ended this way, after a lot of time:




    Processing triggers for libc-bin (2.19-18+deb8u4) ...
    Processing triggers for systemd (215-17+deb8u4) ...
    Processing triggers for initramfs-tools (0.120+deb8u2) ...
    Processing triggers for php5-fpm (5.6.24+dfsg-0+deb8u1) ...
    Job for php5-fpm.service failed. See 'systemctl status php5-fpm.service' and 'jo urnalctl -xn' for details.
    invoke-rc.d: initscript php5-fpm, action "restart" failed.
    dpkg: error processing package php5-fpm (--configure):
    subprocess installed post-installation script returned error exit status 1
    Processing triggers for openmediavault (3.0.31) ...
    Restarting engine daemon ...
    Updating locale files ...
    Updating file permissions ...
    Purging internal cache ...
    Errors were encountered while processing:
    php5-fpm
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Hi Wolf2000,


    the command you gave me has no effect, no package to install/remove/upgrade.


    If I follow the command in the link, when I put apt-get install openmediavault
    I get the same error


    openmediavault:


    Depends: php5-pam but is not going to be installed
    Depends: proftpd-mod-vroot but is not going to be installed
    Depends: php5-proctitle but is not going to be installed
    E: Unable to correct problems, you have held broken packages


    I don't know where's the error.

    Hello to everyone,


    I'm trying to install OMV on raspberry 1 with Raspbian.
    I met many problems, here's the command i gave:


    echo “deb http://packages.openmediavault.org/public stoneburner main” > /etc/apt/sources.list.d/openmediavault.list (the same problem with Erasmus version)

    apt-get install openmediavault-keyring postfix
    apt-get update


    After the update, here's the output:


    The following packages have unmet dependencies:



    openmediavault:

    Depends: php5-pam but is not goung to be installed
    Depends: proftpd-mod-vroot but is not going to be installed
    Depends: php5-proctitle but is not to be installed
    E: Unable to correct problems, you have held broken packages


    Any suggestion?


    Thanks in advance