Posts by Jaime

    I use the asrock C236 board. I just changed my ups on it where I have the 40 inch tv that I use as my monitor, a camera dvr that is also running off the same ups and the nas. Without the nas being on and only the tv and dvr with, chromecast and wiifi ap all turned on, I get 0 kw. When I turn the nas on, I go from .145 at turn on and then it goes does to .056 kw if that means anything. I'm not accessing it or anything, I just turned it on and that is with 6 hard drives installed and it's just humming along. I also keep my nas off when I don't use it and just turn it on when I need it, I can do this remotely too which is why I set it up this way so it's not always on just to extend the life of my nas a bit more. I changed the power supply on my previous nas three times over the time I had it since I kept that one on all the time and I hardly ever used it so this works for me. The board works well so I like it, but depending on how many hard drives you are going to plug into it, a pico psu will not be what you want unless it's just one drive or two, which I doubt will be the case if you're getting this board.

    I thought I test the virtualbox plugin, I got 3 errors but I only have two screenshots. The first one had to do when I enabled virtualbox. Sorry, I can't remember what that was. Anyway I'm trying to import an old virtualbox machine I have in another share. I thought I could do it manually first by going to the new virtualbox share that I created, but again, it changes the rights on that folder from root to virtualbox so I can't manually access it. IF that's how this is suppose to work, I don't mind, but I then went to the phpvirtualbox, click file, import appliance, went to the share that contains the folder with my old virtualbox files but I could not go down any further to choose the specific file. I just can't see the individual files in that folder to import. Anyway I just thought I show this to you guys.

    Great thanks for clarifying this.

    I used it once to do backup the system but haven't tried restoring from it. I have found a weird problem. I wanted to move the backup to a different share since I was just testing it, but it won't let me. I also went to the acl to change the rights for all folders as well but I still couldn't copy the folder to my desktop so I could move it. So I think there is something still not right with that plugin. I mean you can back up but if you can't restore and I can't move the folder I wouldn't trust it to restore. At least not at the moment until someone can actually test that. One more thing, there are more updates so make sure you update your omv.

    I wanted to update this post since I have finally got all this working today. I did a little write up so I'll post it below to hopefully help you guys with this. If the admins want to add or clarify anything I don't mind. i just couldn't find anything that made sense to me so this is what I did.


    Setting up accessto omv through the web.


    First things first.Make sure that the server has all the latest updates before starting.


    1. Don’t installany plug-ins for now. The first thing you want to make sure is thatyou can access the nas locally from any workstation.


    2. You need toconfigure the port for the web access and the ssl access through thenas general settings. I suggest only using ssl afterwards, but we’llleave both http and https for now. Make sure the ports are differentfrom your router.


    The reason formaking sure that you use a specific port is that depending on yourrouter, it may already be using the default ports. So choosing a portthat is not a default will keep things working without any conflicts.


    Now, I decided toput back my old router because the first one was not letting methrough from outside, no matter what configuration I used. Guesswhat, the second router did the same thing. You may be thinking thatit was all me. Not really, every system works differently so findingwhat worked was interesting to say the least. Why, because I have nowgot everything working correctly which is the reason I’m typingthis.


    3. Now if you havelocal access working the next step is to make sure that you canaccess the web login from the outside as well before trying to getany other service working from outside. Now I’m going to skip theddns or static ip here. I will assume you have that working becausethat’s another thing that will need to work before you can accessanything from outside.


    My router has abuilt-in web access app of some sort which is what I used to accessmy network before I got all this working. So I used that which alsoallowed me to make sure my ddns was working correctly. Now I did allthe port forwarding I could until I was turning blue and nothingworked. This is when I decided to leave it alone for some time, thenI came back and decided to start at the beginning which is what I’mwriting to make it easier for you. So now that my ddns works Idecided to make sure I could access the web login from outside. Portforwarding was not working so I said screw it and took all that out(deleted all the port forwarding). I tested the access and whamo! Iwas able to login. Normally you need to point to the server throughport forwarding, but I didn’t need to for the web login in thiscase with the second router. Not sure why that is. Unfortunately forwhatever reason this worked fine until I added a port forwarding forthe webserver. So now I have had to add a port forwarding for bothwebserver and omv login https port access and they seem to workagain. Weird but this is what happened. I have updated the router tothe latest firmware.


    Okay, now that thatlogin access is working it was time to test the https with the otherport I used. So far it still works and enabling just ssl accessautomatically takes me to the correct port which was neat. Problemone solved.


    Setting up webdav
    Yes, I already hadaccess through the router for the nas but I still wanted to set thisup even if it’s just for the purpose of testing since I don't’even need it. But I like things that work.


    1. Now I just wentahead and installed the webdav plugin and went to work. Enable theservice, make a share just for this service if you don’t want touse a current folder/share. I found that if you use a current share,whatever service you pointed to the share would change the rights andthen I could not access the files with my user account. It was adifferent share. Anyway that’s another issue I had but I think itwas fixed. Once that is done, go back to the webdav service and clickon show, you may have to cancel it for it to show you the ip address.This is what you will follow to access the webdav from inside oroutside, you’ll just change the address accordingly to whatevername you are using. As I’m testing this I noticed that my webaccess stopped working again. So I went back to the port forwardingon the router and added another https access port for the webdav. Itseems to be working again. This is weird as everything startedworking without any port forwarding and now it wants the portforwarding. So I’m back typing the ddns address and the correctports to make sure I can still access the nas web login(https://ddnsurl:port), the webdav (https://ddnsurl:port/webdav/) andmy regular router cloud access (ddnsurl). Your router may be a bitdifferent. In order to get the correct url, just go to the serviceand look at what it shows you there, that’s where I got these url’sfrom. I couldn’t remember what the correct order was before sinceit had been a long time since I used anything like this.


    Now for the enginexaccess you just need to set up a certificate to use for ssl which youshould have since it’s the same one used above, enable the service,add a server where you also tell it where your web files are and testthe ports, then change to use the ssl only settings. So that shouldlook like this (https://ddnsurl:port) This port should be differentthan the router and webdav port. Now I hope I’m not making thismore confusing as I’m trying to condense this from everything Ihave tried. This has had me scratching my head for a while, but atleast it seems to work now. In short you should only need to portforward any https port, depending on what service or services you areusing. This is what at least works with my current router. It seemseasy now but it has taken me a days to finally get it working.

    ?( ..the port goes after the base domain or IP address not at the end of the URL


    http://dyndnsip:8080/webdav

    Yes, but I thought webdav was still part of the URL? Well it's been years since I used that outlook, so I'm just going by what I sort of remember. Anyway, I tried that too but it's still no working for me. I even tried just with the port too but I'm not sure what's going on at the moment. So I'll keep looking to see if I find anything.


    It looks like the webserver (nginx) doesn't work either. I can't see the site from outside at all. Everything seems to be there so I have no idea what else it could be. Everything does seem to work internally though. I noticed that when I went to change the port on the server it didn't take it and put another port instead, so I think there is something weird going on with that plugin.

    I was just trying to show that I'm using the same internal 192.168 ip, just to keep it less comfusing. In any case, I want to ask if the correct way of using webdav from the outside is for example: http: //dyndnsip/webdav:8080 or https: //dyndnsip/webdav:4434? I changed the ports so that's why these are different. Do correct me if I'm wrong. I thought it worked just like the outlook webdav I used years ago. I'm guessing it still works the same, but I realized I had not ask this question and haven't seen any posts of anyone actually using it. I only briefly used that webdav years ago so I'm not sure it that's still works the same here. And yes, dyndns seems to be working fine. I put an extra space in the address since the forum automatically makes these into links and takes out the first part. Thanks.
    Below is the error I get when I try to log in.

    Okay I have been trying this out and locally I can access the webdav, but I can't from outside. Here are the numbers I'm using to test the port forwarding. I also can't access the webserver from outside either. My ddns is working fine from what I can tell. Obviously I can't use the same ports for the web server since it tells me that that port is already being used, yeah I tried that too. Everything is turned on and rights seem fine too. I'm not sure what I'm missing or doing wrong.


    I can ping my ddns fine. I also forgot to mention that I can see the website locally too through both of those ports.

    Okay I can't find the post I did earlier so I'll make this one here. I just found out that forwarding port 443 to the nas leaves me out of my router. I can no longer log into it. So is there an easy way to change and use a different port for webdav on the nas since I don't see an option there? I want to leave the router ports where they are to make it easier for me to get in there and just change them on the nas side. I'm not sure how easy or not that would be, but I just found out the hard way and kept leaving myself out of the router every time I try to forward port 443 to the nas. I just tried a different port just to check, but that still didn't work.

    Hey thanks. I installed the updates and it seemed to fix somethings, but haven't tried executing anything. Well I just tried and it seems to work now. Sorry for the late reply.

    I know this is an old post, but I'm now testing the webdav and wondering the same thing. I'm on version 3 though. Is this using port 443? I can access it locally since it works when I click on the show button, but I'm getting a 404 error when I try from the web. The reason I am asking is because when I try to forward port 443 to the nas, I lose complete connection to my router. So I can't log back into it in order to try anything else. I'm not sure if that's having an issue but I already posted that problem on their site. So I'm not sure if forwarding 443 to the nas is causing things to go haywire on the router side or there is some other problem there. Obviously it still works since I'm online making this post but something is just not cooperating.

    Hi. I am trying to execute my nikon camera program from the nas, but I keep getting this error, so I can no longer execute any program. I have added all the read/write privileges to my user, but I'm still getting this. As you can see I can access the files when connecting to the nas with the IP and after logging through the network neighborhood too. I just can't seem to execute anything if I want to just run a program directly from the nas. Any help is appreciated, thanks.

    There is an sftp plugin for this now. Very easy to use.

    Thanks Aaron. I'm guessing that's your name from the name on your avatar, it it's not forgive me. The only reason I didn't do it it's because I was just testing this. I also read that part where it said I would have to unmount the share or drive or something to that effect and knowing me, I'll probably forget and lose a few files if I were to forget so that was the other reason I didn't want to leave that on. But good to know that. In any case the I shouldn't keep any files in an ftp drive/share anyway since that would be only for temporary transfers if I ever need it which I haven't for the longest time, but you never know.


    Not sure if this means anything but I just started getting this error when I tried to submit this reply.

    There is an sftp plugin for this now. Very easy to use.

    Thanks Aaron. I'm guessing that's your name from the name on your avatar, it it's not forgive me. The only reason I didn't do it it's because I was just testing this. I also read that part where it said I would have to unmount the share or drive or something to that effect and knowing me, I'll probably forget and lose a few files if I were to forget so that was the other reason I didn't want to leave that on. But good to know that. In any case the I shouldn't keep any files in an ftp drive/share anyway since that would be only for temporary transfers if I ever need it which I haven't for the longest time, but you never know.

    Okay I just tested adding the user homeftp to the ssh group and I am able to log into the server, but it takes me to the root of the system instead of the ftp share I have set up. On the second picture you can see the groups I have made so that I can leave all the rights alone when I first create a user and just make the changes under each group to keep it simple. The error I was also getting is the account error as you can see. So how do I make this go to the share and not the system root? I'm using homeftp as my test account. I added that to the ssh group and I was able to log in, but it took me to the wrong place. I guess I can leave that alone and do it for each user for now and just make all the privileged changes in each instead of the group as I have done here. The user itself does not have these privileges since I just left those user accounts at their defaults.


    Okay, i just changed the priviledges in the user as well and it still doesn't take me to the share.

    You're right it was a bit vague, but I did read that about adding the user to ssh. Since I'm using groups can I do add the group or it has to be the user? I know user will work but I'm also testing the rights with groups since I don't want to have to edit each user if I were to have a few. I won't here at home, but was just testing. I was just using the domain name in the host part and didn't type sftp on it but I'll try that since I totally forgot about that as well. I forgot what the error was that's why I didn't add it. Thanks.