Posts by copytco

    I am trying to get some more simplicity in accessing my services without using ports. Sickbeard plugin has this great function of setting proxy pass automatically by one click, so now I can access it through http://myserver.local/sickbeard, the code in /etc/nginx/openmediavault-webgui.d/sb.conf shows:


    Code
    ##Generated by the openmediavault-sickbeard plugin.
    location /sickbeard {
    proxy_pass http://localhost:8081/sickbeard;
    proxy_set_header Host localhost:8081;
    proxy_redirect default;
    }


    I tried to adapt it for Radarr as follows:


    Code
    location /radarr {
    proxy_pass http://localhost:7878;
    proxy_set_header Host localhost:7878;
    proxy_redirect default;
    }


    The thing I received going into http://myserver.local/radarr is a plain text website saying "Radarr Ver." What can be the issue?

    Hi, I had my Radarr plugin set up and it all of sudden stopped to work. The service vanished, but OMV dashboard shows plugin as enabled and running. I removed it and installed once again - no change. I can provide logs, but do not even know where to find them. Any suggestions?

    Since some time I have been experiencing gradual RAM consumption increase by SickBeard, Plex and Radarr - it used to be that I had about 50 % of RAM used all the time, but within the week it got up to 70 % on "idle" (of course server is doing some scheduled tasks, but the number is an average from few hours). Below you can see results of htop.


    Is it ok that there are so many processes?

    I face the same issue, SMB is not working on share created on Nextcloud folder.



    The nextcloud folder is 770, maybe try changing it to 775

    For me permissions seems not to be the problem, as other shares work perfectly with 770.



    Read only access to your files is possible and works, but would not recommend it. Too risky messing up your database.

    WebDAV is very slow and therefore annoying. For my purposes I only would like to have read only access with Samba, but I do not know how it can mess up the database.

    Sorry for digging out, but I have still not figured that out. For example for OMV nginx config (/etc/nginx/sites-available/openmediavault-webgui) shows the following:



    So theoretically I should be able to access my site via "openmediavault-webgui"? I tried that, also "openmediavault-webgui.local" and "openmediavault-webgui.bananapi.local", as my hostname is "bananapi" and domain is "local", but nothing seems to be working. Still, I can access the site through "bananapi.local", but I would like to also be able to reach Nextcloud by for example "nextcloud.bananapi.local" instead of "bananapi.local:88".

    Hi,


    I decided to backup my os SD card with OMV in the most simple way with rsync to HDD and then to pack it. For that I am using 2 cron jobs:


    Code
    rsync -aAXv / --exclude={"/dev/*","/export/*","/proc/*","/sys/*","/tmp/*","/run/*","/mnt/*","/srv/*","/media/*","/lost+found"} /srv/dev-disk-by-id-XXX/backup/raw


    and


    Code
    tar -cvjf /srv/dev-disk-by-id-XXX/backup/backup_$(date +%Y%m%d).tar.bz2 /srv/dev-disk-by-id-XXX/backup/raw


    The 2nd line of code works fine. I have tested rsync line 3 times with different results:
    1st time - Copied what was supposed to copy (excluded not needed folders).
    2nd time - Copied what was supposed to copy + created folders from "excluded" but did not copy their contents.
    3rd time - Copied everything, including folders from "excluded".


    I have been always running the same and only command. Why do I have so different (and incorrect) results? 3rd time resulted in 20 times looped backup before I spotted something is wrong.

    Hi,


    is it possible to somehow set local domains for services? Like I can access OMV admin page by bananapi.local now, but for Plex I need to use bananapi.local:32400 or local_ip:32400, while would it be possible to have something like plex.bananapi.local? It is just a matter of remembering all those ports...

    I solved my problem by commenting out the following line in nginx config (/etc/nginx/sites-available/zzz-omv-nginx in my case) for Nextcloud:

    Code
    fastcgi_param HTTPS on;


    And the following in /etc/nginx/nginx.conf:

    Code
    ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
    ssl_prefer_server_ciphers on;


    Hope it helps somebody else.

    Hi,


    I tried to install according to the guide, but during installation I got error 502, still, I see that tables in the MySQL database were created.


    Additionally, I changed in /etc/php5/fpm/pool.d/www.conf the listen parameter from

    Code
    listen = /var/run/php5-fpm.sock

    to

    Code
    listen = 127.0.0.1:90


    Now, when I try to launch the page I get "This page isn’t working 10.103.210.3 redirected you too many times ERR_TOO_MANY_REDIRECTS" on Chrome, and blank page on any other browser. Nginx log does not show any errors, nextcloud log is not created. Any clues? Should I provide some of my config files?

    I would said get a router you can configure. I am certain that if telnet did not give anything neither tcpdump then is not forwarding. What if the people from the isp put UDP instead of TCP?
    How is the message different now?

    Yes, it was connection time out when only UDP was enabled, with both TCP and UDP it is connection refused.



    It shows that the port is closed (weird).




    Just to discard the firewall, check it


    iptables -vnL post the output here

    The output was
    Chain INPUT (policy ACCEPT 0 packets, 0 bytes) pkts bytes target prot opt in out source destination

    Chain FORWARD (policy ACCEPT 0 packets, 0 bytes) pkts bytes target prot opt in out source destination

    Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes) pkts bytes target prot opt in out source destination

    Again the port forward is not configured correctly in the router probably. There are no firewall rules included by default in omv or debian. The default policy is ACCEPT in input, output and fwd chain

    Router settings are owned and configured by my ISP and they told me it is working correctly - I can access my Plex, OpenVPN and other services, but not SSH. Before, when the port was not forwarded the message was "server not reachable", while now it is different.

    Ok, I have tried

    Code
    tcpdump -i eth0 -n | grep "IP adress of your external client"

    with IP in the quotes, but it is showing nothing when I try to connect from the outside. So is it stuck somewhere on the router? Weird, my router is AP only. So maybe OMV has some internal firewall rules? I have set no rules by myself there.

    I did that, from the local network the answer was:


    Code
    SSH-2.0-OpenSSH_6.7p1 Debian-5+deb8u3

    from the outside network still connection refused.


    I still need to test with tcpdump, but need 2 machines for that (1 in local network running terminal with tcpdump and other trying to connect from outside).

    Hi,


    install tcpdump on your omv-box and check, whether the SSH pakets reach your server.

    I tried to run it on my 22 port with output saved to a file, but it seems like rubbish. Is it possible to make it save data in human-readable form?



    Are you trying to reach remotely on the wan side externally or from your local lan?

    Outside of my local LAN - tried from work, parent's home etc., but all the time it is the same.

    I have an issue with SSH as it does not work from outside of the home network. I performed a test using the same machine and Putty.


    In my home network I connected through local IP address and port 22. I tried to reach the device remotely using public IP and some high port (above 2000), which was assigned to me by ISP and linked to my device and its port 22. It seems like the device is reachable, but for some reason it refuses to establish connection. I use the same user, which is in ssh group. I have also allowed root user login, but it did not help.


    Do you know what might be the solution?