Posts by thor17

    Does anybody else got into problems with USB 3.0 devices?
    I'm using a second NIC connected to an USB 3.0 port of my NAS. It's not detected on boot anymore since I'm on Kernel 4.5. Only happens if it is connected to USB 3.0, USB 2.0 works fine, but it's too slow.
    If I reconnect it after boot, it works fine, but this bothers me...
    Any workarounds?


    EDIT: My bad, the BIOS was the problem. I disabled the legacy support for USB 2.0, now it works fine.

    Ok, now I'm pretty sure I tracked it down.
    In the first place, the problem was a bad Realtek driver module, I guess. This was solved by using a new kernel. Due to some bad Samba server configuration, I had that strange behaviour described above. Sometimes I got 110MiB/s on writes, but mostly I got 5MiB/s.
    What I did now was to disable any tuning option in the smb.conf, including the socket options. Now I got at least 70MiB/s on writing large files (tested with 10GiB files or even bigger). Next step was to set only two options, "aio write behind = true" and "write raw = yes". Now I get an average of 110MiB/s on large file writes and at least 55MiB/s on small file writes. It's stable, I tested it with several files with an overall size of about 200GiB. I even did some reboots to ensure, this doesn't change anything.


    Well, I guess I'm fine with it... :D


    @ryecoaaron
    Thanks a lot for your help!

    Ok, very strange...
    After it did work this morning, now, after a reboot of my NAS, I'm back to low speed again...
    I noticed something strange, if I take a look on the RX/TX speed bmon shows (on the NAS), the RX speed matched with the TX speed on my client. But in addition, the TX speed of the NAS is very high, but why, it is a write from the client to the NAS, so what does the NAS transmit? There is no read transfer running.
    The transmission stops immediately after canceling the file transfer, so there is any kind of relation. After some testing, I can say, this problem is related to Samba. NFS do have some slow downs while transfer, but the overall speed is about 60MiB/s. Any ideas?


    [spoiler}[/spoiler]

    Well, I'm not sure, if an Intel NIC helps anyway...
    My other NAS, running with Ubuntu 14.04 Server, is using a HP NC364T. The write speeds was as unstable as the speeds on the small NAS with OMV2. Even in bonding mode round-robin (4 NICs), the speed was often down at 11MiB/s though my directly connected desktop pc had a 364T, too.
    After upgrading to a newer kernel (4.x), because the old 3.x kernels were no longer supported, the speed problems are just gone. But I'm not sure it is related to the driver module, because I compiled the module by myself before and it didn't help either. It seems to be something else kernel related.


    Today I tested kernel 4.5 with my OMV2 NAS, it seems to work. I transferred some files with sizes from 8GiB to 20GiB and got at least 60MiB/s. Compared to before, this looks great :-)



    @Dropkick Murphy
    just write the line "max protocol = SMB2" (without "" of course) to your smb.conf and test if it helps.


    Some links:


    https://www.arm-blog.com/samba…r-better-transfer-speeds/


    http://lug.krems.cc/docu/samba/appb_02.html



    The second one contains a list of recommended samba settings at the bottom of the site.

    I assumed you would start openvpn as a service.
    OpenVPN should use the client.conf under /etc/openvpn/client.conf by default. My VPN configuration (*.opvn file) is also under /etc/openvpn/.

    Hello!


    I've been using OMV2 for a while. My System specs are:


    AsRock AM1B-ITX
    AMD Athlon 5350 @2.05Ghz
    8GB RAM
    2x Seagate ST4000LM016 (2x 4TB, RAID0 with ZFS)
    1x Crucial M4 128GB mSATA
    OpenMediaVault 2 (Backports Kernel)


    The problem is, the transfer speeds TO the NAS are very slow, it doesn't matter which protocol is used. NFS is slightly faster than Samba and FTP, but 20MiB/s are just too slow. When reading from a Samba share I get about 110MiB/s, so almost everything the gigabit network can passthrough. When I write something to the share, I got about 6MiB/s.
    I tried already several Samba tuning options. The well known socket options, as well as sendfile, aio read/write behind and some others. Nothing helped.
    The strange thing is, sometimes I get high transfer speeds of about 80MiB/s on large files, but if I then copy another large file it's slow again. The speed isn't stable and I have no clue how to improve this. Any advices?
    The network speed is stable, tested it with iperf very often, it's always about 940MBit/s. My clients running all with Ubuntu.
    This isn't a problem about the speed of the ZFS pool, tested it already with transfering a file from an external hdd directly attached to the NAS. I got consistent speeds of up to 120MiB/s.

    Do you intend to use your NAS as a gateway?
    If so, you have also to deal with routing to pass the internet traffic from and to you local network.
    I'm using my NAS as a gateway because my TP-Link routers are just too slow to deal with 256-Bit AES encryption.


    However, you have to create a client.conf which could look like this:

    The path after auth-user-pass defines a file where you username and password is stored.

    Using backports kernel since this morning. Until now, I didn't notice any stability problems with the Realtek NIC.
    However, if the network connection problems, after a night without usage, still persists will be clear tomorrow.

    Hello!


    I'm not sure if it's about autosuspend, but in the morning, everytime I got connection problems with my NAS.
    The NAS have two NICs, the on board one is a RTL8168 and the USB3.0/network adapter is a TP-Link UE300, recognized as:

    Code
    cdc_ether 6-1:2.0: eth1: register 'cdc_ether' at usb-0000:00:10.0-1, CDC Ethernet Device

    The NAS is the gateway in my network. It runs openvpn to connect to my VPN provider through the USB ethernet device. The RTL8168 is connected to my local network.


    If I have no internet connection in the morning, I just ssh into the NAS, but this needs some time, it usually doesn't, so maybe even PCI devices are suspended or in any power saving mode.


    How can I disable power saving on every device in my NAS? (except the CPU of course)

    Not at the moment. Maybe this would help with the stability problem of my Realtek NIC. It's a RTL8168. I installed the driver manually, because the r8169 driver the Kernel contains doesn't work properly.
    In the past, I had the same problem with my big server.

    I configured a custome fan profile in the BIOS and used sysbench to find out the maximum CPU temperature.


    Fan speeds:
    CPU temp idle: 46°C 2200RPM
    CPU temp full load: 52°C 3700RPM
    Drive temps: 28 - 32°C


    Power consumption at idle: 22W
    consumption at load: 40-42W


    At the moment I'm building my own PSU, because I don't trust that cheap picoPSUs from China. Maybe that will change the power consumption, the LM2696's efficiency is rated with 82-90%. The high range of input voltages will allow the use of various power supplies that lies around here.

    Hello everybody!


    Recently, I built a very small NAS. Due to my high electricity costs I simply had to change something, my big home server with 10 HDDs needs too much juice...including the UPS about 180W idle.
    So created this system:


    AsRock AM1B-ITX
    AMD Athlon 5350 @2.05Ghz
    8GB RAM
    2x Seagate ST4000LM016 (2x 4TB, RAID0 with ZFS)
    1x Crucial M4 128GB mSATA
    OpenMediaVault 2


    The case I used is a Chieftec IX-01B. A very cheap and cool case, but unfortunately, it's only for drives with standard size. The height of the Seagate HDDs is 15mm, not 9mm like other 2.5" drives. Another problem, you can only use very thin CPU heatsinks.
    Chieftec says, you can use 40mm heatsinks, but you have to subtract the drive's height. So in my case, there are only 25mm left for the heatsink. The boxed cpu cooler is about 22mm high plus the fan's height of 10mm, there are only 8mm left.
    But this wasn't the biggest problem. The HDDs are too high (about 3mm), so one of them was touching the RAM and as mentioned before, the other one collided with the cpu cooler.
    So I did some DIY work on that :D
    I had an Aluminium heatsink with dimensions of 90mm x 90mm x 15mm in my junk box. I just tripped two parts to make it fit in and cut two M4 threads into it for mounting. After that, I made a 2mm thick Aluminium plate for mounting the HDDs in a way, they would fit in perfectly.
    Finally, I could place two HDDs and one mSATA SSD (stuck between one HDD and the cpu cooler) in the case.
    Everything is running very well, the two Titan TFD-5010M12Z case fans are pretty silent if cpu is in idle.




    Hi!
    After installing OMV 2 on my Crucial M4 I noticed, the logical sector size is just 512 Byte. But during installation there was no way to do the partitioning manually. So how can I format it with 4k sector size?


    Thanks in advance!