Posts by Cole Trickle

    Thanks bud,


    when installing openmediavault as you suggested,



    I get an error related to php5-fpm:


    Unpacking openmediavault (3.0.59) ...
    Setting up php5-fpm (5.6.29+dfsg-0+deb8u1) ...
    Job for php5-fpm.service failed. See 'systemctl status php5-fpm.service' and 'journalctl -xn' for details.
    invoke-rc.d: initscript php5-fpm, action "start" failed.
    dpkg: error processing package php5-fpm (--configure):
    subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of openmediavault:
    openmediavault depends on php5-fpm; however:
    Package php5-fpm is not configured yet.


    dpkg: error processing package openmediavault (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    php5-fpm
    openmediavault



    The way I installed is is by downloading the 3.0.5 Img -file (of sourceforge) and putting it on an SD card.

    Chaps,


    Not an expert by anymean, but I have exhausted most of my skills, think I have and issue between NGINX and PHP Fast CGI


    I am getting the following error when opening the WebGUI for omv:


    502 Bad gateway error NGINX,



    on raspberry pi, freshly installed.


    I can SSH into the IP address.



    in the var/log.nginx/openmediavault-webgui_error.log


    "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-openmediavault-webgui.sock:", host: "10.10.10.100"
    2017/02/08 21:25:09 [crit] 1493#0: *1 connect() to unix:/var/run/php5-fpm-openmediavault-webgui.sock failed (2: No such file or directory) while


    indeed I see no such /var/run/php5-fpm-openmediavault-webgui.sock



    I run the following versions:


    root@raspberrypi:/var/run# dpkg -l | grep openm
    rc openmediavault 3.0.59 all Open network attached storage solution
    rc openmediavault-flashmemory 3.4.3 all folder2ram plugin for OpenMediaVault
    ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
    rc openmediavault-omvextrasorg 3.4.16 all OMV-Extras.org Package Repositories for OpenMediaVault
    rc openmediavault-resetperms 3.2 all Reset Permissions





    root@raspberrypi:/usr/share/openmediavault# systemctl restart php5-fpm
    Job for php5-fpm.service failed. See 'systemctl status php5-fpm.service' and 'journalctl -xn' for details.


    looking into systemctl php5:


    127 loaded units listed. Pass --all to see loaded but inactive units, too.
    To show all installed unit files use 'systemctl list-unit-files'.
    root@raspberrypi:/usr/share/openmediavault#
    root@raspberrypi:/usr/share/openmediavault# systemctl status php5-fpm.service
    â— php5-fpm.service - The PHP FastCGI Process Manager
    Loaded: loaded (/lib/systemd/system/php5-fpm.service; enabled)
    Active: failed (Result: signal) since Thu 2017-02-09 23:11:47 CST; 48s ago
    Process: 5720 ExecStart=/usr/sbin/php5-fpm --nodaemonize --fpm-config /etc/php5/fpm/php-fpm.conf (code=killed, signal=ILL)
    Process: 5713 ExecStartPre=/usr/lib/php5/php5-fpm-checkconf (code=exited, status=0/SUCCESS)
    Main PID: 5720 (code=killed, signal=ILL)


    Feb 09 23:11:47 raspberrypi php5-fpm-checkconf[5713]: Illegal instruction
    Feb 09 23:11:47 raspberrypi systemd[1]: php5-fpm.service: main process exited, code=killed, status=4/ILL
    Feb 09 23:11:47 raspberrypi systemd[1]: Failed to start The PHP FastCGI Process Manager.
    Feb 09 23:11:47 raspberrypi systemd[1]: Unit php5-fpm.service entered failed state.


    I seem to be unable to tie the two together but I would reckon that as long as php-fpm is not running, I am flogging a dead horse.
    please not that this is an unchanged image.


    I know there is an existing post on this forum that touches parts of what I am seeing, but doesnt seem to be the same issue.


    thanks guys