Posts by Jap0

    Man learns all his life. I changed that as well. You're right "Subzero 79"


    That command was helpful:

    Code
    cryptsetup -v --cipher aes-xts-plain64 --key-size 256 --hash sha512 --iter-time 5000 --use-urandom --verify-passphrase luksFormat /dev/sdX

    where X is your device, partition

    I found solution form my problem. Trivial.
    There was no bug, like I suspected.
    The log file located at /var/log/rsync.log was huge above 100 MB. I couldn't view it via Diagnostics/Systemlogs/Rsync Jobs - "Connection Failure" so I moved it somewhere else and now I can synchronize data without special options f.e. -e "ssh -p 44225" on any ports without any glitches.


    Thanks again

    Subzero79 have you tried that? Please provide an example command.



    You can still use Veracrypt. Is a multiplatform soultion. Any way you need to mount a disk to the device-mapperer first to open encrypted area, same as in Veracrypt. you tried

    I wanted to upgrade my OMV as well so, what I did:
    1. apt-get update; apt-get upgrade; apt-get dist-upgrade
    2. omv-update (it's probably the same as that above, any way I've done that 2)
    3. omv-release-upgrade (it's took a while), after that
    4. dpkg -r openmediavault-omvextrasorg
    5. next I followed the instructions from http://omv-extras.org/joomla/index.php/guides:
    # wget http://omv-extras.org/openmedi…extrasorg_latest_all3.deb
    # dpkg -i openmediavault-omvextrasorg_latest_all3.deb
    # apt-get update
    6. reboot the system and...
    That worked fine 4 me.

    I don't mind:

    Open Rsync tab / Jobs / Edit your job and at the bottom in Extra Options add:
    -e "ssh -v"
    Save, apply and run it again. You'll see more informations about the error.
    Did you open SSH port, add firewall rules?


    Try to connect via terminal first.

    I can copy, synchronize files via terminal and rsync command without any problems:

    Code
    rsync -avz -e "ssh -p 22445" me@10.0.0.3:/var/www/ /tmp/test/

    I can not do that via OMV's interface and rsync task. Apparently there's a bug with SSH Port setting, at least in this particular case.


    I found simple workaround. I've opened rsync task for edit and in Extra options field added:
    -e "ssh -p 22445"
    That line resolved my problem.


    Anyway thanks subzero79 and chris789.
    Respect !


    Here it is,