Posts by FreshMike

    That is exactly what the plugin does. No need to make a symlink and do anything from the command line. It creates the cert with certbot and then imports that cert into the ssl cert section of the OMV web interface. If you want to use the cert for ftp, it should be in the dropdown in the ssl tab. If you want to use it for the omv web interface, look in the web administration tab. No idea about mumble but maybe you could point it at the /etc/letsencryp/live cert.

    Ah hmm , It looks like that for some reason when the letscencrpt certs gets renewed I still see the old expired cert under Certificate SSL.

    Hi All


    Is there a way to link the letsencrypt cert to the cert in the admin console under certificates ?
    I tried to simlink the /etc/ssl/openmediavault-uuid cert to /etc/letsencrypt/live/mydomain/ but it doesn't like it as the /etc/openmediavault/config.xml has this cert embedded .


    The whole idea here is to be able to use systemwide the letsencrypt cert for FTP, mumble etc, admin console, which gets autorefreshed by the letsencrypt plugin.


    Thanks for any suggestions.

    I had the same issue with the python 3.5 lib, thanks for the fix suggestion. Going through all logs after the OMV3 - > OMV4 upgrade and I have the following trace:



    Might have something to do with the php5 to php7 migration

    Seems fixed in 4.0.13-1
    Cheers

    Ah ok :( Btw. I have installed the old plugin from 3.0 back. Getting this error:



    Will continue to see if I can relink the new openssl version.

    What is the output of:
    dpkg -l | grep php
    omv-engined -df

    Code
    root@nas:/tmp# omv-engined -df
    omv-engined[31811]: Daemon already running (pid=12512)
    Daemon already running (pid=12512)


    Code
    Nov 21 01:04:02 NAS monit[1520]: 'php-fpm' process is not running
    Nov 21 01:04:02 NAS monit[1520]: 'php-fpm' trying to restart
    Nov 21 01:04:02 NAS monit[1520]: 'php-fpm' start: '/bin/systemctl start php5-fpm'
    Nov 21 01:04:33 NAS monit[1520]: 'php-fpm' failed to start (exit status 5) -- '/bin/systemctl start php5-fpm': Failed to start php5-fpm.service: Unit php5-fpm.service not found.

    OK I thing I'm back in the game


    Code
    dpkg --list |grep "^rc" | cut -d " " -f 3 | xargs sudo dpkg --purge
    apt-get --reinstall install openmediavault-<plugins>

    But still can't open the Admin GUI correctly in Chorme 62, works though in Edge and IE. I have cleaned cache in Chrome but the problem still persists.



    Gone use Edge for now.

    Hi All.


    I have successfully upgraded omv3 to omv4. After the upgrade everything worked besides the sensor plugin as I had issues to start collectd etc. I read the plugin has not been ported yet so I uninstalled it and now I'm not able to get the admin console working. I started uninstalling from CLI more plugins. After login I see only the openmediavault jpg.


    When I check the dev console in Chrome I'm getting this:

    Code
    192.168.1.3/:1 Refused to execute script from 'http://192.168.1.3/js/omv/module/admin/storage/luks/Containers.js' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
    192.168.1.3/:1 Refused to execute script from 'http://192.168.1.3/js/omv/module/admin/storage/luks/Luks.js' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
    192.168.1.3/:1 Refused to execute script from 'http://192.168.1.3/js/omv/module/admin/system/wakealarm/Wakealarm.js' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
    192.168.1.3/:1 Refused to execute script from 'http://192.168.1.3/js/omv/module/admin/system/backup/SystemBackup.js' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
    192.168.1.3/:1 Refused to execute script from 'http://192.168.1.3/js/omv/module/admin/system/backup/Backup.js' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
    192.168.1.3/:1 Refused to execute script from 'http://192.168.1.3/js/omv/module/admin/service/apttool/Search.js' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
    192.168.1.3/:1 Refused to execute script from 'http://192.168.1.3/js/omv/module/admin/service/apttool/Apttool.js' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
    192.168.1.3/:1 Refused to execute script from 'http://192.168.1.3/js/omv/module/admin/service/apttool/Packages.js' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
    192.168.1.3/:1 Refused to execute script from 'http://192.168.1.3/js/omv/module/admin/service/usbbackup/UsbBackup.js' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
    192.168.1.3/:1 Refused to execute script from 'http://192.168.1.3/js/omv/module/admin/service/usbbackup/Jobs.js' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.


    I have tried to uninstall some more plugins from command line but they have rc? status ?


    All packages are updated:
    Any help would be appreciated.


    Code
    root@nas:/tmp# apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    root@nas:/tmp#

    I had the same issue with the python 3.5 lib, thanks for the fix suggestion. Going through all logs after the OMV3 - > OMV4 upgrade and I have the following trace:



    Might have something to do with the php5 to php7 migration

    Hi Guys,


    I'm running OMV 3.0.81 with an ASROCK J3455 mainboard, linux-image-4.9.0-0.bpo.3-amd64, and I see never ending error messages in the logs in form of:


    Jul 1 15:04:54 NAS kernel: [ 3724.848250] hpet1: lost 7161 rtc interrupts
    Jul 1 15:04:55 NAS kernel: [ 3725.716304] hpet1: lost 7160 rtc interrupts
    Jul 1 15:04:56 NAS kernel: [ 3726.581818] hpet1: lost 7160 rtc interrupts
    Jul 1 15:04:56 NAS kernel: [ 3727.427496] hpet1: lost 7161 rtc interrupts
    Jul 1 15:04:57 NAS kernel: [ 3728.298614] hpet1: lost 7160 rtc interrupts
    Jul 1 15:04:58 NAS kernel: [ 3729.170907] hpet1: lost 7161 rtc interrupts
    Jul 1 15:04:59 NAS kernel: [ 3730.035575] hpet1: lost 7161 rtc interrupts
    Jul 1 15:05:00 NAS kernel: [ 3730.908491] hpet1: lost 7160 rtc interrupts
    Jul 1 15:05:01 NAS kernel: [ 3731.781357] hpet1: lost 7161 rtc interrupts
    Jul 1 15:05:02 NAS kernel: [ 3732.650678] hpet1: lost 7161 rtc interrupts
    Jul 1 15:05:02 NAS kernel: [ 3733.501129] hpet1: lost 7161 rtc interrupts
    Jul 1 15:05:03 NAS kernel: [ 3734.374422] hpet1: lost 7161 rtc interrupts
    Jul 1 15:05:04 NAS kernel: [ 3735.247879] hpet1: lost 7161 rtc interrupts
    Jul 1 15:05:05 NAS kernel: [ 3736.120894] hpet1: lost 7161 rtc interrupts



    I do have the Schduled Wakealarms and Autoshutdown plugin installed.
    Not sure if that contributes to the problem ?


    Any suggestions, advise ?
    Thanks

    No banana .. I see the new size in the startup log it looks like it's not taking into account by the scan ..


    I had some issues with other plugins too, everything is gone after doing this



    Bash
    root:/etc# ls -l /sbin/*start-stop*
    cp /sbin/start-stop-daemon-Script.REAL /sbin/start-stop-daemon-Script


    looks like a previous installation or package upgrade went wrong .. :/

    I had some issues with other plugins too, everything is gone after doing this:


    Bash
    root:/etc# ls -l /sbin/*start-stop*
    cp /sbin/start-stop-daemon-Script.REAL /sbin/start-stop-daemon-Script

    looks like a previous installation or package upgrade went wrong ..

    Hi Guys,


    I have installed the mumble plugin and I don't see any process or even log file created.


    Bash
    mumble-server.service - LSB: Mumble VoIP Server
    Loaded: loaded (/etc/init.d/mumble-server)
    Active: active (exited) since Fri 2017-06-23 23:12:38 BST; 20min ago
    Process: 11392 ExecStop=/etc/init.d/mumble-server stop (code=exited, status=0/SUCCESS)
    Process: 11399 ExecStart=/etc/init.d/mumble-server start (code=exited, status=0/SUCCESS)
    Jun 23 23:12:38 NAS mumble-server[11399]: Warning: Fake start-stop-daemon called, doing nothing.
    Jun 23 23:12:38 NAS systemd[1]: Started LSB: Mumble VoIP Server.

    Not sure what that FAKE Server stuff is.




    Code
    root@NAS:~# sudo dpkg-reconfigure mumble-server
    invoke-rc.d: policy-rc.d denied execution of stop.
    <W>2017-06-23 23:35:20.907 Initializing settings from /etc/mumble-server.ini (basepath /etc)
    <W>2017-06-23 23:35:20.908 OpenSSL: OpenSSL 1.0.1t 3 May 2016
    <W>2017-06-23 23:35:20.979 ServerDB: Opened SQLite database /var/lib/mumble-server/mumble-server.sqlite
    Password: <F>2017-06-23 23:35:23.461 Superuser password set on server 1
    invoke-rc.d: policy-rc.d denied execution of start.

    Any idea what went wrong here ?

    Got it finally working. This thread helped
    https://unix.stackexchange.com…y-disappears-after-reboot


    mdadm --stop /dev/md<number> mdadm --zero-superblock /dev/sda1/sdb1 (do this for all your raid disks)


    dd if=/dev/zero of=/dev/sda bs=1M count=10
    This will zero out the first 10 megabytes of /dev/sda1. Repeat for /dev/sdb1. Recreate the array after that, and then /dev/md0 should come up on boot.


    - recreated Array md0
    - mdadm --examine --scan >> /etc/mdadm/mdadm.conf
    - omv-mkconf mdadm


    something was wrong with the partition signature I guess.