Posts by JMocki

    Hello good Morning,


    first i want to explain my configuration.


    - Macbook Pro 13" and 15" both from 2015 running on catalina stable

    - Raspberry 4 with first try OMV5 and now upgrade to OMV6


    Before i used single HDD with USB3.0 using time machine on each Mac works fine


    Now i setting on the raspbarry a SMB / Share with TimeMachine support

    The initial backup works fine but the further did not start again with the following messages


    --> Die identität des Backup-Volumes hat sich seit dem letzten Backup geändert...."


    I try to mount (doubleclick) on the sparsebundle but the access was denied.. volume not recognizes



    I try again with a fresh sparsebundle create with mac HDD tool

    Mounting (doubleclick) and unmounting from desktop is possible several times without problems


    But if i copy this sparsebundle to SMB Share(OMV) is it not possible to mount is with doublelclick

    --> image not recognized

    and further if i want to delete that sparsebundle file from SMB Share it is also not possible (access denied / Zugriffsrechte)


    before i post any log files is there some hints what i can check?

    At this point i have no other ideas what i can do..

    I can also post some pictures or videos of the issue


    thanks in advance and greetings from Germany.


    Jörg

    Ahh ja stimmt hab eine Null zuwenig bei der DNS Zuweisung.


    Was mich noch interessieren würde, ist welche Möglichkeit habe ich mit dem Handy (iPhone 7) auf das NAS zuzugreifen. Also direkt in einen Ordner.
    Wenn das geht wie richte ich das ein.


    Das finde ich bei nem Kumpel echt komfortabel, der hat ein QNAP und
    eine App dafür.


    Ich hab das Apple Filing gefunden, weiß aber nicht ob das damit funktioniert oder übeehaupt das richtige ist.

    Ja danke für den Hinweis, das hatte ich noch auf dem Schirm.
    Sind die korrupten Daten selbst dann zu erwarten, wenn man den PR einfach mit mehreren HDD betreibt ohne ein RAID System. Also
    jeder HDD für sich arbeitet?


    Das Datenträgerformat kann ich ja auf BTRFS formatieren. Dachte nur immer EXT4 wäre das optimalste..



    Ich habe eben mal einen Versuch unternommen indem ich die HDD über den PR formatiert etc.. und dann den PR abgesteckt und die HDD's einzeln an den Pi
    und sie lassen sich einhängen.

    Guten Morgen!


    votdev:
    Ja, das hat sich erledigt, da ich das Image von HTPC-Guides nicht mehr nutze, kann ich dir die Info nicht mehr geben..




    Zum Grundverständnis..
    Ich habe ja jetzt die zwei Platten über den PR am Pi hängen. (Einghängt, Ordner erstellt etc..) kein RAID


    Sollte jetzt der PR abrauchen oder was auch immer ihn in der Funktion beeinträchtigen,
    komme ich dann noch an meine Daten dran?
    Sprich kann ich die HDD einzeln in OMV wieder einhängen und darauf z.B. über SBM mit Windows drauf zugreifen?
    Oder gibt es hier Probleme da ja zwei HDD eingehängt sind und plötzlich fehlen..


    Auch muss ich ja bestimmt den Eintrag
    in der
    nano /boot/boot.cmd
    Füge in setenv bootargs am ende ahci_sunxi.enable_pmp=1 ein
    Dann
    mkimage -C none -A arm -T script -d /boot/boot.cmd /boot/boot.scr
    reboot



    wieder entfernen?


    Gruß Jörg


    ..so ich habe jetzt das neue Image draufgezogen.
    Läuft auf Anhieb!


    Ich kann die Platten einbinden, aushängen etc..


    Ich möchte mit dem Port Replicator kein RAID System aufbauen.
    Es geht lediglich dadrum, das ich noch eine weitere Platte anschließen kann um den Speicher zu erweitern.
    Oder sind hier auch Ausfälle oder Verluste bekannt?


    Ich wollte mit meinem Anliegen keinen Streit provozieren..bei mir ist es egal wenn ich die HDD lösche, partitioniere etc.. das
    ist ja wie gesagt alles noch im Testbetrieb.


    Schönen Abend noch und danke für die Hilfen!


    Bis demnächst, habe mit Sicherheit noch neue Fragen.


    Gruß Jörg

    ok..


    ich habe es nach folgender Anleitung versucht, reicht das oder muss ich das mit der Gparted.. durchführen. BTW, ich kann doch auch unter Windows mit DiscDirector oder so Partitionen löschen.. Wo genau liegt das Problem in Verbindung mit OMV, das habe ich noch nicht verstanden?





    Nach folgender Anleitung GPT entfernt..



    1. Type "parted /dev/<devicename>", usually "parted /dev/sda".
    2. Once inside parted type "mktable":
    -> Table type: msdos
    -> Destroy data: yes
    -> quit
    3. GPT should now be removed.




    fdisk -l


    root@server1:~# fdisk -l


    Disk /dev/mmcblk0: 14.9 GiB, 15931539456 bytes, 31116288 sectors


    Units: sectors of 1 * 512 = 512 bytes


    Sector size (logical/physical): 512 bytes / 512 bytes


    I/O size (minimum/optimal): 512 bytes / 512 bytes


    Disklabel type: dos


    Disk identifier: 0x5bd0f4d4


    DeviceBoot StartEndSectorsSize Id Type


    /dev/mmcblk0p12048 31116287 31114240 14.9G 83 Linux


    Disk /dev/sdb: 465.8 GiB, 500103634432 bytes, 976764911 sectors


    Units: sectors of 1 * 512 = 512 bytes


    Sector size (logical/physical): 512 bytes / 4096 bytes


    I/O size (minimum/optimal): 4096 bytes / 4096 bytes


    Disklabel type: dos


    Disk identifier: 0x847e8e46



    nach Dateisysttem erstellen in OMV:
    fdisk -l


    root@server1:~# fdisk -l
    Disk /dev/mmcblk0: 14.9 GiB, 15931539456 bytes, 31116288 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x5bd0f4d4
    Device Boot Start End Sectors Size Id Type
    /dev/mmcblk0p1 2048 31116287 31114240 14.9G 83 Linux
    Disk /dev/sdb: 465.8 GiB, 500103634432 bytes, 976764911 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: gpt
    Disk identifier: 4FD65EA5-642F-45EA-9F22-AED337F97599


    Device Start End Sectors Size Type
    /dev/sdb1 2048 976764877 976762830 465.8G Linux filesystem



    nach dem erstellen ist die GPT wieder da.. ?(?(


    @tkaiser
    ok, das kann ich auch mal ausprobieren..
    da muss ich nichts mehr selbst installieren unter der Konsole?

    ok..


    ich habe es nach folgender Anleitung versucht, reicht das oder muss ich das mit der Gparted.. durchführen. BTW, ich kann doch auch unter Windows mit DiscDirector oder so Partitionen löschen.. Wo genau liegt das Problem in Verbindung mit OMV, das habe ich noch nicht verstanden?





    Nach folgender Anleitung GPT entfernt..



    1. Type "parted /dev/<devicename>", usually "parted /dev/sda".
    2. Once inside parted type "mktable":
    -> Table type: msdos
    -> Destroy data: yes
    -> quit
    3. GPT should now be removed.




    fdisk -l


    root@server1:~# fdisk -l


    Disk /dev/mmcblk0: 14.9 GiB, 15931539456 bytes, 31116288 sectors


    Units: sectors of 1 * 512 = 512 bytes


    Sector size (logical/physical): 512 bytes / 512 bytes


    I/O size (minimum/optimal): 512 bytes / 512 bytes


    Disklabel type: dos


    Disk identifier: 0x5bd0f4d4


    DeviceBoot StartEndSectorsSize Id Type


    /dev/mmcblk0p12048 31116287 31114240 14.9G 83 Linux


    Disk /dev/sdb: 465.8 GiB, 500103634432 bytes, 976764911 sectors


    Units: sectors of 1 * 512 = 512 bytes


    Sector size (logical/physical): 512 bytes / 4096 bytes


    I/O size (minimum/optimal): 4096 bytes / 4096 bytes


    Disklabel type: dos


    Disk identifier: 0x847e8e46



    nach Dateisysttem erstellen in OMV:
    fdisk -l


    root@server1:~# fdisk -l
    Disk /dev/mmcblk0: 14.9 GiB, 15931539456 bytes, 31116288 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x5bd0f4d4
    Device Boot Start End Sectors Size Id Type
    /dev/mmcblk0p1 2048 31116287 31114240 14.9G 83 Linux
    Disk /dev/sdb: 465.8 GiB, 500103634432 bytes, 976764911 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: gpt
    Disk identifier: 4FD65EA5-642F-45EA-9F22-AED337F97599


    Device Start End Sectors Size Type
    /dev/sdb1 2048 976764877 976762830 465.8G Linux filesystem



    nach dem erstellen ist die GPT wieder da.. ?(?(


    @tkaiser
    ok, das kann ich auch mal ausprobieren..
    da muss ich nichts mehr selbst installieren unter der Konsole?

    Ja seltsam, hast du auch das Jessie drauf?


    Vielleicht habe ich ja was grundlegendes falsch gemacht..
    manuelles mounten klappt


    root@server1:/etc# mkdir /server
    root@server1:/etc# mount /dev/sda1 /server
    root@server1:/etc#


    jetzt wird die Platte unter "Dateisysteme" korrekt angezeigt. (Gesamt / Verfügbar.. etc..)
    Ordner erstellen kann ich dennoch nicht.
    Unter "Freigegebeben Ordner hinzufügen kann ich kein Laufwerk auswählen.. es wirds nichts im PullDown Menü angezeigt.


    Aushängen geht ebenfalls nicht.
    Als ob OMV überhaupt keinen Zugriff bekommt..



    fdisk -l



    Disk /dev/mmcblk0: 14.9 GiB, 15931539456 bytes, 31116288 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x5bd0f4d4



    Device Boot Start End Sectors Size Id Type
    /dev/mmcblk0p1 2048 31116287 31114240 14.9G 83 Linux



    Disk /dev/sda: 465.8 GiB, 500103634432 bytes, 976764911 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: gpt
    Disk identifier: 45AD6F40-6102-4CA4-9505-A0B3F1E02094



    Device Start End Sectors Size Type
    /dev/sda1 2048 976764877 976762830 465.8G Linux filesystem



    Disk /dev/sdb: 3.8 GiB, 4089446400 bytes, 7987200 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: gpt
    Disk identifier: 8EEACB99-8157-4A24-B71D-B4B805FCAA19



    Device Start End Sectors Size Type
    /dev/sdb1 2048 7987166 7985119 3.8G Linux filesystem

    ok..


    ich habe jetzt testweise einen USB STick noch mit zusätzlich zu der Festplatte angeschlossen.
    Unter Dateisystem beide EXT4 ertellt
    HDD (Server1)
    USB Stick (test)


    beide sind Online nicht eingebunden und nicht refernziert.


    nach dem Versuch die HDD einzubinden und
    nach der Fehlermeldung OK geklickt und widerrufen angewählt.


    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; mount -v --source '/dev/sda1' 2>&1' with exit code '32': mount: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so.



    blkid
    root@server1:/etc# blkid
    /dev/mmcblk0p1: UUID="2109ff16-9187-44a6-bb05-e29f1c1b6cc4" TYPE="ext4" PARTUUID="5bd0f4d4-01"
    /dev/sdb1: LABEL="test" UUID="ab602426-7396-4527-a197-23ecf852cf86" TYPE="ext4" PARTUUID="4d26e6df-18ee-4c9e-89a4-a797ba4d5fa8"
    /dev/sda1: LABEL="Server1" UUID="b80b3b32-2f78-4b6c-98b2-bc066f9a66c9" TYPE="ext4" PARTUUID="85a7768b-e718-4195-87f6-4ea010b0c16a"
    /dev/mmcblk0: PTUUID="5bd0f4d4" PTTYPE="dos"


    ls -alh /dev/disk/by-label
    root@server1:/etc# ls -alh /dev/disk/by-label
    total 0
    drwxr-xr-x 2 root root 80 Nov 4 18:49 .
    drwxr-xr-x 7 root root 140 Nov 4 18:44 ..
    lrwxrwxrwx 1 root root 10 Nov 4 18:49 Server1 -> ../../sda1
    lrwxrwxrwx 1 root root 10 Nov 4 18:44 test -> ../../sdb1


    /etc/fstab

    # UNCONFIGURED FSTAB FOR BASE SYSTEM
    /dev/mmcblk0p1 / ext4 defaults,noatime,nodiratime,data=writeback,commit=600,errors=remount-ro 0 0
    /var/swap none swap sw 0 0
    tmpfs /tmp tmpfs defaults 0 0
    # >>> [openmediavault]
    /dev/disk/by-label/Server1 /srv/dev-disk-by-label-Server1 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2
    # <<< [openmediavault]


    jetzt mach ich erstmal keine Veränderung mehr..




    ..am root Passwort oder Rechte für OMV etc.. kann es nicht liegen..? ich musste das nach dem ersten einloggen in die Konsole von "htpcguides" auf mein neues ändern.

    blkid


    root@server1:/etc# blkid
    /dev/mmcblk0p1: UUID="2109ff16-9187-44a6-bb05-e29f1c1b6cc4" TYPE="ext4" PARTUUID="5bd0f4d4-01"
    /dev/sda1: LABEL="servera" UUID="20079907-3d61-475b-9218-9dd75ec8cf2c" TYPE="ext4" PARTUUID="b9825925-fdb4-4449-bc7a-418f1f253589"
    /dev/mmcblk0: PTUUID="5bd0f4d4" PTTYPE="dos"



    ls -alh /dev/disk/by-label


    root@server1:/etc# ls -alh /dev/disk/by-label
    total 0
    drwxr-xr-x 2 root root 60 Nov 4 18:25 .
    drwxr-xr-x 7 root root 140 Nov 4 18:25 ..
    lrwxrwxrwx 1 root root 10 Nov 4 18:25 servera -> ../../sda1

    ok, nichts besonderes.. die ist zum testen da.


    ich kann die auch unter der Konsole formatieren oder meinst du unter Windows? Wie NTFS oder ext4?


    WIe mache ich das unter Linux?


    Soll ich mal als Alternative einen USB Stick anschließen und den versuchen zu mounten?
    ..gleiche Fehlermeldung beim mounten..

    was soll ich da ändern..?


    <fstab>
    <!--
    <mntent>
    <uuid>xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx</uuid>
    <fsname>xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx|xxxx-xxxx|/dev/xxx</fsname>
    <dir>/xxx/yyy/zzz</dir>
    <type>none|ext2|ext3|ext4|xfs|jfs|iso9660|udf|...</type>
    <opts></opts>
    <freq>0</freq>
    <passno>0|1|2</passno>
    <hidden>0|1</hidden>
    </mntent>
    -->
    </fstab>